Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Demo crashes - audio problem [ubuntu]
Author Message
zk123 Offline
Junior Member

Posts: 4
Joined: May 2012
Reputation: 0
Post: #1
Not Solved Demo crashes - audio problem [ubuntu]

When I try to play the
Amnesia demo, it first starts normally, tells me the normal stuff, asks
for gamma setting (which all look the same to me, btw), I get to the first
loading screen and then it's just gone.


The terminal output is at http://paste.ubuntu.com/952375/, seems to be some kind of audio problem.
The sound in the menu works fine.
(This post was last modified: 05-05-2012 02:52 PM by zk123.)
05-05-2012 02:39 PM
Find all posts by this user Quote this message in a reply
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #2
Not Solved RE: Demo crashes - audio problem [ubuntu]

The audio errors tend to be misleading. Really that is the openAL library detecting what is on your system. Can you post your hpl.log file? ~/.frictionalgames/Amnesia/Demo/hpl.log and the launcher.log as well.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
05-05-2012 02:56 PM
Visit this user's website Find all posts by this user Quote this message in a reply
zk123 Offline
Junior Member

Posts: 4
Joined: May 2012
Reputation: 0
Post: #3
Not Solved RE: Demo crashes - audio problem [ubuntu]

(05-05-2012 02:56 PM)Urkle Wrote:  The audio errors tend to be misleading. Really that is the openAL library detecting what is on your system. Can you post your hpl.log file? ~/.frictionalgames/Amnesia/Demo/hpl.log and the launcher.log as well.
http://paste.ubuntu.com/969210/ ← hpl.log
http://paste.ubuntu.com/969212/ ← launcher.log
05-05-2012 03:08 PM
Find all posts by this user Quote this message in a reply
plutomaniac Offline
Super Moderator

Posts: 5,949
Joined: May 2011
Reputation: 171
Post: #4
Not Solved RE: Demo crashes - audio problem [ubuntu]

I don't know about Linux but as far as I understand you have Intel HD 2000 and a driver from Q1 2011 (7.10.2). The latest is from Q1 2012 (8.0.1) and you can find it here:

http://intellinuxgraphics.org/2012.02.html

Again, I'm a Windows helper so I might be wrong...

[Image: L72ChX.png]
(This post was last modified: 05-06-2012 07:45 PM by plutomaniac.)
05-06-2012 07:44 PM
Find all posts by this user Quote this message in a reply
zk123 Offline
Junior Member

Posts: 4
Joined: May 2012
Reputation: 0
Post: #5
Not Solved RE: Demo crashes - audio problem [ubuntu]

(05-06-2012 07:44 PM)plutomaniac Wrote:  I don't know about Linux but as far as I understand you have Intel HD 2000 and a driver from Q1 2011 (7.10.2). The latest is from Q1 2012 (8.0.1) and you can find it here:

http://intellinuxgraphics.org/2012.02.html

Again, I'm a Windows helper so I might be wrong...

Could that be it? The website says "If you are not experienced doing this, we recommend that you get precompiled packages from one of the many Linux distributions." - where do I get one?
05-07-2012 09:35 AM
Find all posts by this user Quote this message in a reply
plutomaniac Offline
Super Moderator

Posts: 5,949
Joined: May 2011
Reputation: 171
Post: #6
Not Solved RE: Demo crashes - audio problem [ubuntu]

I don't know how Linux works. I think there is a search place where you can find all linux applications. Search there I guess...

[Image: L72ChX.png]
05-07-2012 10:53 AM
Find all posts by this user Quote this message in a reply
Your Computer Offline
SCAN ME!

Posts: 3,475
Joined: Jul 2011
Reputation: 234
Post: #7
Not Solved RE: Demo crashes - audio problem [ubuntu]

(05-07-2012 09:35 AM)zk123 Wrote:  Could that be it? The website says "If you are not experienced doing this, we recommend that you get precompiled packages from one of the many Linux distributions." - where do I get one?

According to the hpl.log you already have the Mesa drivers installed, but it's not version 8.0.1. Configuring the X server is not a fun task. If you're not used to doing it, i wouldn't mess with it.

Tutorials: From Noob to Pro
05-07-2012 11:51 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #8
Not Solved RE: Demo crashes - audio problem [ubuntu]

The reason is this line from the logs.

Texture compression S3TC: 0

You have no S3TC. You have to either compiled & install the libdxt_txcn library or (for more recent distributions) do some mojo to enable S3TC in the open source driver

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
05-07-2012 03:17 PM
Visit this user's website Find all posts by this user Quote this message in a reply
zk123 Offline
Junior Member

Posts: 4
Joined: May 2012
Reputation: 0
Post: #9
Not Solved RE: Demo crashes - audio problem [ubuntu]

(05-07-2012 11:51 AM)Your Computer Wrote:  
(05-07-2012 09:35 AM)zk123 Wrote:  Could that be it? The website says "If you are not experienced doing this, we recommend that you get precompiled packages from one of the many Linux distributions." - where do I get one?

According to the hpl.log you already have the Mesa drivers installed, but it's not version 8.0.1. Configuring the X server is not a fun task. If you're not used to doing it, i wouldn't mess with it.
I remember having some issues with the X server on my desktop once, that was a royal pain in the ass. I'd like to not have to do that ever again...


(05-07-2012 03:17 PM)Urkle Wrote:  The reason is this line from the logs.

Texture compression S3TC: 0

You have no S3TC. You have to either compiled & install the libdxt_txcn library or (for more recent distributions) do some mojo to enable S3TC in the open source driver

Is there any (sort of) simple way to get this done?
(This post was last modified: 05-07-2012 05:31 PM by zk123.)
05-07-2012 05:30 PM
Find all posts by this user Quote this message in a reply
Post Reply 


[-]
Quick Reply
Message
Type your reply to this message here.

Image Verification
Please enter the text within the image on the left in to the text box below. This process is used to prevent automated posts.



User(s) browsing this thread: 1 Guest(s)