Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Thread Closed 
Overture - Graphical issues.
Author Message
Greenie Offline
Junior Member

Posts: 9
Joined: Jun 2009
Reputation: 0
Post: #31
Solved: 7 Months, 2 Weeks, 4 Days, 22 Hours, 34 Minutes, 26 Seconds ago RE: Overture - Graphical issues.

OMG..I just edited the post above and it had [spoiler] correctly :X A second
06-07-2009 09:32 PM
Find all posts by this user
Herr Bernard Offline
Junior Member

Posts: 7
Joined: Jun 2009
Reputation: 0
Post: #32
Solved: 7 Months, 2 Weeks, 4 Days, 22 Hours, 34 Minutes, 26 Seconds ago RE: Overture - Graphical issues.

Quickly recorded a short clip of the graphical issues inside the bunker in the beginning.. The clip is way to dark because of YouTube

I have a ATi HD 2600 Pro graphics card.

The clip
Spoiler below!
http://www.youtube.com/watch?v=pa9ZdJsrIME

Log
Spoiler below!
-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 800 x 600 - 32 bpp
Init Glee...OK
Setting up OpenGL
Max texture image units: 16
Max texture coord units: 16
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 16
Multisampling: 1
Vertex Program: 1
Fragment Program: 1
NV Register Combiners: 0
NV Register Combiners Stages: 11
ATI Fragment Shader: 1
Creating graphic systems
Creating Renderer2D
Renderer2D created
Creating Renderer3D
Load Renderer3D gpu programs:
Extrude
Diffuse Vertex
Diffuse Fragment
Fog
Creating fog textures: Solid Additive Alpha
init sky box
Renderer3D created
Creating screen buffers size 800.000000 : 600.000000
Creating programs
CG ERROR : The compile returned an error.
-----------------------------------
core/programs/PostEffect_Motion_fp.cg(32) : error C5013: profile does not support "for" statements and "for" could not be unrolled.
-----------------------------------
Error loading: 'core/programs/PostEffect_Motion_fp.cg'!
ERROR: Couldn't create program 'PostEffect_Motion_fp.cg'
Dynamic loops in motion blur fp not supported, loading static instead.
RendererPostEffects created
Adding engine materials
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL.
Trying to open software device... Success!
Device name: Generic Software
Number of mono sources: 32
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
WARNING: Language entry 'EventKeyInNoPower' in category '01_10_small_shaft' already exists!
Initializing Penumbra: Overture Episode 1
Version $Rev: 1789 $
Date $Date: 2007-11-13 03:43:19 +0100 (ti, 13 nov 2007) $
Trying to load vertex program!
Success!
Creating and binding ATI spot shader to 1
Creating and binding ATI bump shader to 2
Creating and binding ATI diffuse shader to 3
--------------------------------------------------------

Game Running
--------------------------------------------------------
Loading collada for 'maps/level01_02_mine_entrance.dae' took: 1222 ms
ERROR: Couldn't find particle system file 'particle_dust.ps'
ERROR: Couldn't create particle system 'sust01' of type 'particle_dust'
ERROR: Couldn't find particle system file 'dust_sust01.ps'
ERROR: Couldn't create particle system 'particle' of type 'dust_sust01'
ERROR: Couldn't load particle system 'particle' with type 'dust_sust01'
--------------------------------------------------------

Statistics
--------------------------------------------------------
Medium framerate: 56.896499
--------------------------------------------------------

User Exit
--------------------------------------------------------
Saving to config
Saving keys
Saving to config
Saving keys
Reset maphandler
Exit Player
Exit Button Handler
Exit Map Handler
Exit Game Message Handler
Exit Radio Handler
Exit Inventory
Exit Fade Handler
Exit Save Handler
Exit Trigger Handler
Exit Attack Handler
Exit Notebook
Exit Numerical panel
Exit Intro story
Exit Death menu
Exit Graphics helper
Exit Main menu
Exit Player hands
Exit Music handler
Exit Map Load Text
Exit PreMenu
Exit Credits
Exit Demo end text
Saving config
Exit Effect Handler
Exit Game
--------------------------------------------------------

Exiting Gui Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Scene Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Input Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Sound Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Graphics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Resources Module
--------------------------------------------------------
Done with tilesets
Done with fonts
Done with scripts
Done with particles
Done with sounds
Done with meshes
Done with materials
Done with Gpu programs
Done with images
Destroyed all textures
Done with sound entities
Done with animations
All resources deleted
--------------------------------------------------------

Exiting Physics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting System Module
--------------------------------------------------------
--------------------------------------------------------

Deleting game setup provided by user
- Deleting lowlevel stuff.
Physics
Sound
Input
Resources
System
Graphics
Haptic
HPL Exit was successful!
Saving last config

|--Memory Manager Report-------------------------------|
|
| No memory leaks detected. Memory left: 0
|
|------------------------------------------------------|

Deleting ATI shader to 0
Deleting ATI shader to 1
Deleting ATI shader to 2
Deleting ATI shader to 3

(This post was last modified: 06-07-2009 09:39 PM by tuxan.)
06-07-2009 09:36 PM
Find all posts by this user
IIPEE Offline
GameScraper.net

Posts: 3,202
Joined: Mar 2007
Reputation: 55
Post: #33
Solved: 7 Months, 2 Weeks, 4 Days, 22 Hours, 34 Minutes, 26 Seconds ago RE: Overture - Graphical issues.

(06-07-2009 09:32 PM)Greenie Wrote:  OMG..I just edited the post above and it had [spoiler] correctly :X A second

No, you just didn't put the [*/spoiler] in the end (Without *). Wink:

• It took me 7 years to get THIS far...
06-07-2009 09:40 PM
Visit this user's website Find all posts by this user
Raz0rx Offline
Junior Member

Posts: 22
Joined: Jun 2009
Reputation: 0
Post: #34
Solved: 7 Months, 2 Weeks, 4 Days, 22 Hours, 34 Minutes, 26 Seconds ago RE: Overture - Graphical issues.

I just gave Black Plague a shot and I'm getting graphical issues there, too.
No missing walls or floors, and no crazy stretched textures, just a few invisible objects that appear to look like numerous glitching triangle shadows.

You can interact with them, but you can't see them.
06-07-2009 09:58 PM
Find all posts by this user
Greenie Offline
Junior Member

Posts: 9
Joined: Jun 2009
Reputation: 0
Post: #35
Solved: 7 Months, 2 Weeks, 4 Days, 22 Hours, 34 Minutes, 26 Seconds ago RE: Overture - Graphical issues.

(06-07-2009 09:40 PM)Scraper Wrote:  
(06-07-2009 09:32 PM)Greenie Wrote:  OMG..I just edited the post above and it had [spoiler] correctly :X A second

No, you just didn't put the [*/spoiler] in the end (Without *). Wink:
I did but my log is longer than enabled letters in one post Wink And I found out its not whole I edited it again Tongue

To Herr: You could use G btw I have some glitches as you.
06-07-2009 10:12 PM
Find all posts by this user
Raz0rx Offline
Junior Member

Posts: 22
Joined: Jun 2009
Reputation: 0
Post: #36
Solved: 7 Months, 2 Weeks, 4 Days, 22 Hours, 34 Minutes, 26 Seconds ago RE: Overture - Graphical issues.

I'm getting the insane 'stretched-across-my-screen' texture issue in Black Plague as well now (which can be seen in my Overture screenshots in my original post), coupled with the invisible items/shelves thing I mentioned earlier.

Though with Black Plague, it seems every time I load the save game, it's something new that's messing up.

With Overture it's the same all the time.
06-08-2009 08:07 AM
Find all posts by this user
Herr Bernard Offline
Junior Member

Posts: 7
Joined: Jun 2009
Reputation: 0
Post: #37
Solved: 7 Months, 2 Weeks, 4 Days, 22 Hours, 34 Minutes, 26 Seconds ago RE: Overture - Graphical issues.

Save us developers! :mrgreen:
06-08-2009 02:16 PM
Find all posts by this user
IIPEE Offline
GameScraper.net

Posts: 3,202
Joined: Mar 2007
Reputation: 55
Post: #38
Solved: 7 Months, 2 Weeks, 4 Days, 22 Hours, 34 Minutes, 26 Seconds ago RE: Overture - Graphical issues.

OK, good news for you guys who is using ATI's card: See here!

• It took me 7 years to get THIS far...
06-08-2009 04:30 PM
Visit this user's website Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)