Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Thread Closed 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not starting
Author Message
Wiisper Offline
Junior Member

Posts: 21
Joined: Jun 2011
Reputation: 0
Post: #1
Solved: 9 Months, 3 Weeks, 4 Days, 12 Hours, 9 Minutes, 51 Seconds ago Not starting

Hi,

I got the game and installed it, along with the 1.2 update, everything went wel until i wanted to start the game. Nothing happened so i started googleling but there were no working solutions.

I get this error:

"Amnesia.exe cause an EXCEPTION_ACCES_VIOLATION in module atioglxx.dll at 0023:6903B2B2, DrvSwapBuffers()+0162 byte(s)"

I'm working on a laptop with a intel i7 Q720, 4gb ram and a mobility radeon hd 5470 with windows 7x64

I updated al my drivers and checked all the options. When i click the launcher in the start menu the mouse changes to the loading mouse but then suddenly stops and nothing happens. When i click amnesia.exe in the install folder in program files it goes black but then stops and i get the error above.

Anyone knows how to fix this?
06-20-2011 07:50 PM
Find all posts by this user
Tanshaydar Offline
From Beyond

Posts: 3,085
Joined: Mar 2009
Reputation: 66
Post: #2
Solved: 9 Months, 3 Weeks, 4 Days, 12 Hours, 9 Minutes, 51 Seconds ago RE: Not starting

Probably you need to update your drivers.
http://support.amd.com/us/gpudownload/wi...n7-64.aspx

Edit, you say you updated your drivers. So can you please send you hpl.log file under Documents/Amnesia/Main ?

(This post was last modified: 06-20-2011 07:58 PM by Tanshaydar.)
06-20-2011 07:57 PM
Visit this user's website Find all posts by this user
Wiisper Offline
Junior Member

Posts: 21
Joined: Jun 2011
Reputation: 0
Post: #3
Solved: 9 Months, 3 Weeks, 4 Days, 12 Hours, 9 Minutes, 51 Seconds ago RE: Not starting

Here you go


Attached File(s)
.log  hpl.log (Size: 1,004 bytes / Downloads: 15)
06-20-2011 08:03 PM
Find all posts by this user
plutomaniac Offline
Super Moderator

Posts: 6,033
Joined: May 2011
Reputation: 173
Post: #4
Solved: 9 Months, 3 Weeks, 4 Days, 12 Hours, 9 Minutes, 51 Seconds ago RE: Not starting

Well, from the log it seems that it can not proceed further after setting up the graphics. Try running the game as administrator. Also, go here:

http://www.frictionalgames.com/forum/thread-3754.html

Check all of Problem A, it might help you...

[Image: L72ChX.png]
(This post was last modified: 06-20-2011 08:12 PM by plutomaniac.)
06-20-2011 08:09 PM
Find all posts by this user
Wiisper Offline
Junior Member

Posts: 21
Joined: Jun 2011
Reputation: 0
Post: #5
Solved: 9 Months, 3 Weeks, 4 Days, 12 Hours, 9 Minutes, 51 Seconds ago RE: Not starting

(06-20-2011 08:09 PM)plutomaniac Wrote:  Well, from the log it seems that it can not proceed further after setting up the graphics. Try running the game as administrator.
Not working either.

Edit: i already tried all the options in your link but they all end up with the same result, nothing.

Edit 2: it seems that i got a new error when running windows xp sp2 compability: "Could not load main init file: config/main_init.cfg"
(This post was last modified: 06-20-2011 08:27 PM by Wiisper.)
06-20-2011 08:12 PM
Find all posts by this user
plutomaniac Offline
Super Moderator

Posts: 6,033
Joined: May 2011
Reputation: 173
Post: #6
Solved: 9 Months, 3 Weeks, 4 Days, 12 Hours, 9 Minutes, 51 Seconds ago RE: Not starting

mmm, interesting. Right click both Launcher.exe and Amnesia.exe and select run as administrator and set compatibility to Windows XP SP3. Try to launch the game and if the problem persists and you get the previous new error then attach us again the file HPL.log here to check it.

[Image: L72ChX.png]
06-20-2011 08:33 PM
Find all posts by this user
Wiisper Offline
Junior Member

Posts: 21
Joined: Jun 2011
Reputation: 0
Post: #7
Solved: 9 Months, 3 Weeks, 4 Days, 12 Hours, 9 Minutes, 51 Seconds ago RE: Not starting

(06-20-2011 08:33 PM)plutomaniac Wrote:  mmm, interesting. Right click both Launcher.exe and Amnesia.exe and select run as administrator and set compatibility to Windows XP SP3. Try to launch the game and if the problem persists and you get the previous new error then attach us again the file HPL.log here to check it.

Nop with sp3 the same behavior as first happens and the error of sp2 isn't there. And the error doesn't show up again when i try to load in sp2 mode.

anyway here's the log


Attached File(s)
.log  hpl.log (Size: 1,004 bytes / Downloads: 12)
06-20-2011 08:39 PM
Find all posts by this user
Tanshaydar Offline
From Beyond

Posts: 3,085
Joined: Mar 2009
Reputation: 66
Post: #8
Solved: 9 Months, 3 Weeks, 4 Days, 12 Hours, 9 Minutes, 51 Seconds ago RE: Not starting

By any chance, is there a possibility you have another integrated graphic card like Intel?

06-20-2011 08:59 PM
Visit this user's website Find all posts by this user
plutomaniac Offline
Super Moderator

Posts: 6,033
Joined: May 2011
Reputation: 173
Post: #9
Solved: 9 Months, 3 Weeks, 4 Days, 12 Hours, 9 Minutes, 51 Seconds ago RE: Not starting

Ok, remove the run as administrator and leave only Windows XP SP2. I want to see the HPL.log after you get the second newer error. If you are using steam, check the integrity of the files.

[Image: L72ChX.png]
06-20-2011 08:59 PM
Find all posts by this user
Wiisper Offline
Junior Member

Posts: 21
Joined: Jun 2011
Reputation: 0
Post: #10
Solved: 9 Months, 3 Weeks, 4 Days, 12 Hours, 9 Minutes, 51 Seconds ago RE: Not starting

(06-20-2011 08:59 PM)Tanshaydar Wrote:  By any chance, is there a possibility you have another integrated graphic card like Intel?

Not that i know of, in my device manager it only shows one graphic card
(06-20-2011 08:59 PM)plutomaniac Wrote:  Ok, remove the run as administrator and leave only Windows XP SP2. I want to see the HPL.log after you get the second newer error. If you are using steam, check the integrity of the files.

I'm not using steam and i can't get the error reproduced, no matter what i do it keeps giving me a black screen and the black box error
(This post was last modified: 06-20-2011 09:17 PM by Wiisper.)
06-20-2011 09:16 PM
Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)