Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
 
Thread Rating:
  • 2 Votes - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't play Custom Story at all... :'(
Author Message
Neaflys Offline
Junior Member

Posts: 9
Joined: Mar 2012
Reputation: 0
Post: #1
Not Solved Information Can't play Custom Story at all... :'(

Hello everybody,
first ... I'm soooo sorry of my poor english but i'm french .. ^^' excuse me for that.

Well, I've got a problem with CUSTOM STORY ...
I've tried to create my own and it doesn't work, but, anyway ... That's not the most problematic.
I've got a MacBook Pro 13" intel core i5 2,4 Ghz (Maybe ?)
And Amnesia : The Dark Descent v1.2 (does the problem can be from here ?)
I bought the game on Frictional Game Store (NOT ON STEAM).

So, my problem is : I can't find any custom story in the launcher.
for exemple, I've download "Lost the Lights" ... I but the folder which contents all .lang/.cfg/others...
in the Custom Story folder in Amnesia's ressources. And I loading the game and I can't see the name of custom story. ANYTHING !
So ... Somebody to help me ? Maybe that came from 1.2 version or Mac os X (hope not :'( )

Thank you for your help and sorry for my english ^^'

Neaflys.

P.S : I made a screen to show you what I done.
[Image: capture-d-cran-20...18.50.40-3286b98.png] This is in Amnesia.app [right click => show the content of package (or something like that in english I don't know ^^')]


Did I just make something wrong ? :/
03-13-2012 06:48 PM
Find all posts by this user Quote this message in a reply
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #2
Not Solved RE: Can't play Custom Story at all... :'(

The custom stories do not appear in the launcher, but only in the in-game menu. After starting the game and picking your profile you will see a custom stores menu there...

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
03-13-2012 07:09 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Neaflys Offline
Junior Member

Posts: 9
Joined: Mar 2012
Reputation: 0
Post: #3
Not Solved RE: Can't play Custom Story at all... :'(

Oh well uh .. it's my english ... When I run the game
I've got "Profile" / "Continue" / "New Game" / "Custom Story" but nothing appear inside. This is what I mean.

EDIT :
"personnaliser l'histoire" means Custom Story :

http://img75.xooimage.com/files/5/7/b/ca...27e.png[hr]
Up ? :$
(This post was last modified: 03-13-2012 08:09 PM by Neaflys.)
03-13-2012 07:21 PM
Find all posts by this user Quote this message in a reply
Neaflys Offline
Junior Member

Posts: 9
Joined: Mar 2012
Reputation: 0
Post: #4
Not Solved RE: Can't play Custom Story at all... :'(

Really nobody to help me ? ...
03-13-2012 11:57 PM
Find all posts by this user Quote this message in a reply
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #5
Not Solved RE: Can't play Custom Story at all... :'(

Can you get your hpl.log from your home directory? it's in the Library/Application Support/Frictional Games/Amnesia/Main folder. get that file after you run amnesia once and open up that custom story window and then quit the game.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
03-14-2012 03:35 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Neaflys Offline
Junior Member

Posts: 9
Joined: Mar 2012
Reputation: 0
Post: #6
Not Solved RE: Can't play Custom Story at all... :'(

yes I've got "hpl.log" in home directory in main folder of Amnesia in the library/appli support/Frictional Games/
I run the game, open Custom STory window (always nothing ...) open "Hpl.log" in "terminal (console in french maybe)" and then quit the game. It's look like this :

[Version 1.20 - s951D5605-539
-------- THE HPL ENGINE LOG ------------
Engine build ID 20110502212112


Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------


Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------


Initializing Graphics Module
--------------------------------------------------------
Init lowlevel graphics: 1024x640 bpp:32 fs:0 ms:0 gpufmt:2 cap:'Amnesia - The Dark Descent - Loading...' posSad-1x-1)
Setting video mode: 1024 x 640 - 32 bpp
Init Glew...OK

Setting up OpenGL
Vendor: Intel Inc.
Renderer: Intel HD Graphics 3000 OpenGL Engine
Version: 2.1 APPLE-7.18.11
Max texture image units: 16
Max texture coord units: 8
Max user clip planes: 6
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 16
Multisampling: 1
Texture compression: 1
Texture compression S3TC: 1
Auto generate MipMaps: 1
Render to texture: 1

Max draw buffers: 8
Max color render targets: 8
Packed depth-stencil: 1
Texture float: 1
GLSL Version: 1.20
ShaderModel 2: 1
ShaderModel 3: 0
ShaderModel 4: 0
OGL ATIFragmentShader: 0
Setting up G-Bugger: type: 0 texturenum: 3

Adding engine materials
Initializing DevIL
Vendor String: Abysmal Software
Version String: Developer's Image Library (DevIL) 1.6.8pre Aug 22 2010
Version Number: 168
Adding engine post effects
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL

Available OpenAL devices:
0. Built-in Output(OpenAL default)
Trying to open device 'Built-in Output'... Success!
Number of mono sources: 32
Streaming setup: 4 Buffers x 262144 bytes each

--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions

--------------------------------------------------------

User Initialization
--------------------------------------------------------
--------------------------------------------------------

Game Running
--------------------------------------------------------
-------- Loading map 'menu_bg.map' ---------
Cache Loading: 466 ms
Entities: 93 ms
Compilation: 1 ms
Total: 568 ms
Meshes created: 26
Bodies created: 5
-------- Loading complete ---------
Setting profile: 'Florent' Path: '/Users/cynistro/Library/Application Support/Frictional Games/Amnesia/Main/Florent/'
--------------------------------------------------------

Statistics
--------------------------------------------------------
Medium framerate: 24.235113
--------------------------------------------------------


User Exit
--------------------------------------------------------
Saving main config.
Saving user config.
Deleting game modules.
'LuxInputHandler'
'LuxHelpFuncs'
'LuxSaveHandler'
'LuxScriptHandler'
'LuxProgressLogHandler'
'LuxMapHandler'
'LuxMapHelper'
'LuxPlayer'
'LuxInsanityHandler'
'LuxDebugHandler'
'LuxEffectRenderer'
'LuxMusicHandler'
'LuxMusicHandler'
'LuxEffectHandler'
'LuxCompletionCountHandler'
'LuxGlobalDataHandler'
'LuxHintHandler'
'LuxPostEffectHandler'
'LuxPreMenu'
'LuxDebugHandler'
'LuxInventory'
'LuxJournal'
'LuxCredits'
'LuxLoadScreenHandler'
Deleting config files.

--------------------------------------------------------

Exiting Gui Module
--------------------------------------------------------
Deleting all sets
Deleting all skins
Deleting all gfx elements
Deleting all materials
--------------------------------------------------------

Exiting Generate Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Scene Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Input Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Sound Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Graphics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Resources Module
--------------------------------------------------------
Done with fonts
Done with scripts
Done with particles
Done with sounds
Done with meshes
Done with materials
Done with Gpu programs
Done with images
Destroyed all textures
Done with sound entities
Done with animations
Done with ent files
All resources deleted
--------------------------------------------------------

Exiting Physics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting System Module
--------------------------------------------------------
--------------------------------------------------------

Deleting game setup provided by user
- Deleting lowlevel stuff.
Physics
Sound
Input
Resources
System
Graphics
Haptic
HPL Exit was successful!

|--Memory Manager Report-------------------------------|
|
| No memory leaks detected. Memory left: 0
|
|------------------------------------------------------|]

And then ... Always nothing in custom story window... :/
Sorry for the long post :/
03-14-2012 06:15 PM
Find all posts by this user Quote this message in a reply
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #7
Not Solved RE: Can't play Custom Story at all... :'(

ok.. can you check your main_init.cfg file? (it's in the resources folder under the config folder)

the only thing I can think of is that some mod you may have applied could have overwritten the main_init.cfg and changed the CustomStoryPath in the file (it's an xml file).

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
03-15-2012 04:41 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Neaflys Offline
Junior Member

Posts: 9
Joined: Mar 2012
Reputation: 0
Post: #8
Not Solved RE: Can't play Custom Story at all... :'(

about my main_init.cfg :

<ConfigFiles
Resources = "resources.cfg"
Materials = "materials.cfg"

Game = "config/game.cfg"
Menu = "config/menu.cfg"
PreMenu = "config/pre_menu.cfg"
Demo = "config/demo.cfg"

DefaultMainSettings = "config/default_main_settings.cfg"

DefaultMainSettingsLow = "launcher/default_main_settings_low.cfg"
DefaultMainSettingsMedium = "launcher/default_main_settings_medium.cfg"
DefaultMainSettingsHigh = "launcher/default_main_settings_high.cfg"


DefaultUserSettings = "config/default_user_settings.cfg"
DefaultUserKeys = "config/default_user_keys.cfg"

DefaultBaseLanguage = "base_english.lang"
DefaultGameLanguage = "english.lang"
/>

<Directories
MainSaveFolder = "Main"

BaseLanguageFolder = "config/"
GameLanguageFolder = "config/lang_main/"

CustomStoryPath = "custom_stories"
/>

<Variables
GameName = "Amnesia - The Dark Descent -"
/>

<StartMap
File = "00_rainy_hall.map"
Folder = "maps/main/"
Pos = "PlayerStartArea_1"
/>

I don't touch anything of mod or others files in Amnesia's folder.
I just create some maps and .hps and put it in custom_stories to play my own story, and I saw that not running at all, so I tried with Lost the Light and that doesn't work too... So ...
If I didn't change anything, what is the problem and were did he came from..
03-15-2012 06:35 PM
Find all posts by this user Quote this message in a reply
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #9
Not Solved RE: Can't play Custom Story at all... :'(

do you have a custom_story_settings.cfg file in your story folder?? As that is required for the interface to find the stories. It basically just iterates that folder and loads the custom_story_settings.cfg file.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
03-15-2012 06:39 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Neaflys Offline
Junior Member

Posts: 9
Joined: Mar 2012
Reputation: 0
Post: #10
Not Solved RE: Can't play Custom Story at all... :'(

[Image: capture-d-cran-20...18.50.37-3296106.png] The content of custom_story_settings.cfg for Lost the Light is :

<Main
Name="Lost The Lights 1.2"
Author="UnseenLegend_( NL )"
ImgFile="Amnesia Custom Story Lost The Lights_opt.jpg"

MapsFolder = "maps/"
StartMap="OutSide.map"
StartPos="PlayerStartArea_1"
/>
03-15-2012 06:48 PM
Find all posts by this user Quote this message in a reply
Post Reply 


[-]
Quick Reply
Message
Type your reply to this message here.

Image Verification
Please enter the text within the image on the left in to the text box below. This process is used to prevent automated posts.



User(s) browsing this thread: 1 Guest(s)