Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
laggy performance
Author Message
luxirom Offline
Junior Member

Posts: 5
Joined: Jan 2008
Reputation: 0
Post: #1
Not Solved laggy performance

hi!

i just bought your game and installed it on my G5 (dual 2Ghz)

the graphics-card is a ATI Radeon 9600 Pro with 64MB VRAM.

I know the VRAM is not much, so i turned off ALL features and used lowest setting possible. (troubleshooting)

the game looks just awkward of course. BUT the laggy parts remain!
it's not everywhere on the map, but mostly in bigger areas with 2 or 3 dogs patrolling. (in the area where you can get to chemlab, incinerator, etc.).

and it REALLY lags as hell. since i turned off totally every graphics feature and run on 640*480, i think there is really something wrong with the mac port of this game?

Other Sys-Specs:
RAM: 1.5 GB
OS 10.5


I then tried to run it on my MacBook Pro (2.2GHz Core 2 Duo, 2GB RAM and 128 MB GeForce 8600M GT).

Problem remains even on this Machine: turning around the Character kills framerate to a unusable state...

how can i improve this problem? or is there a way to get the PC-Version legally to run it on XP on my MAC Book Pro? Probably the PC Version is more fluent?

Many thanks for hints and help!
matt
01-13-2008 09:10 PM
Find all posts by this user Quote this message in a reply
jens Offline
Frictional Games

Posts: 3,555
Joined: Apr 2006
Reputation: 172
Post: #2
Not Solved RE: laggy performance

Are you running some sort of special application that could interfere with the game? Something that is always on and running in the background, not normally part of the OS?
01-13-2008 09:37 PM
Visit this user's website Find all posts by this user Quote this message in a reply
luxirom Offline
Junior Member

Posts: 5
Joined: Jan 2008
Reputation: 0
Post: #3
Not Solved RE: laggy performance

growlhelper and istatmenus are running on both systems. usually they dont take up much cpu power. other than that i don't know of anything and i cannot see anything in "top" in the terminal either.

what i could do is run the game on G5 and check with "top" from macbook over ssh, whats going on. will report back.

otherwise: just awesome gameplay!! (hope the forcefeedback thing works on macs?) Wink

greetings
01-13-2008 09:42 PM
Find all posts by this user Quote this message in a reply
luxirom Offline
Junior Member

Posts: 5
Joined: Jan 2008
Reputation: 0
Post: #4
Not Solved RE: laggy performance

other than system UI server at under 5% and obviously top Wink... nothing using cpu or ram.

penumbra running at 104% stable, even without user-input.

some additional thing i noticed: turning is only laggy the first full turn! if i turn again in a room (in the room with red's toilet for example) its fluent.

so maybe something to do with loading new graphic-elements or polygons?


"top" readout:
Processes: 75 total, 3 running, 72 sleeping... 266 threads 21:48:24
Load Avg: 1.32, 0.76, 0.40 CPU usage: 55.91% user, 2.27% sys, 41.82% idle
SharedLibs: num = 2, resident = 52M code, 0 data, 4112K linkedit.
MemRegions: num = 14809, resident = 239M + 14M private, 112M shared.
PhysMem: 245M wired, 439M active, 77M inactive, 761M used, 775M free.
VM: 5691M + 127M 239741(0) pageins, 161790(0) pageouts



of course i dont know in what programming environment you programmed your game and how you managed to compile it for different platforms (nor do i know about opengl, directx and its influence on performance).

or maybe 10.5 is the cause. (wouldnt be surprised, cause 10.5 is generally more unstable and unresponsive compared to 10.4).

best regards!
matt
01-13-2008 09:53 PM
Find all posts by this user Quote this message in a reply
jens Offline
Frictional Games

Posts: 3,555
Joined: Apr 2006
Reputation: 172
Post: #5
Not Solved RE: laggy performance

Hm, will have to wait for the mac porter(Urkle here on the forum) to check in and hopefully come with some sound advice.

The game has been tested on 10.5 systems, both faster and slower than your configuration so there must be something specific in this case and it should be something that can be solved.

Sorry for your troubles and hopefully you can get more help soon, perhaps not today as it is a sunday!
01-13-2008 10:01 PM
Visit this user's website Find all posts by this user Quote this message in a reply
luxirom Offline
Junior Member

Posts: 5
Joined: Jan 2008
Reputation: 0
Post: #6
Not Solved RE: laggy performance

no problem at all Smile
i was surprised to get an answer in such a short time!
(tnx again)

btw: what i read, this game is programmed by 2 persons?
an awesome accomplishment!

what i never found out: where are they? i mean: is frictional games a us company or european?

got it: sweden Wink
tnx for the game then, mr. nilsson and team!

good nite!
matt
(This post was last modified: 01-13-2008 10:27 PM by doomdoom.)
01-13-2008 10:24 PM
Find all posts by this user Quote this message in a reply
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #7
Not Solved RE: laggy performance

There is a possibility it is 10.5 being the cause.. As there have been many reports of 10.5 being slower than 10.4. A lot of it pointing to issues with Time Machine.

Though it does seem strange that it would run slow like that on your 2.2 Ghz macbook pro. the two systems I thoroughly tested on are a dual 2Ghz Mac Pro(10.4, Nvidia 7300 & ati X1900) and a 2.1Ghz macbook pro. (10.5, ati x1650)

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
01-15-2008 03:39 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Cougar Offline
Junior Member

Posts: 7
Joined: Feb 2007
Reputation: 0
Post: #8
Not Solved RE: laggy performance

The game was really laggy for my Powerbook with Safari and a few other apps open. Quit 'em, and the game ran fine. It's strange, though, I re-launched the apps and Penumbra still runs fine.
01-15-2008 05:57 AM
Find all posts by this user Quote this message in a reply
luxirom Offline
Junior Member

Posts: 5
Joined: Jan 2008
Reputation: 0
Post: #9
Not Solved RE: laggy performance

well. thanx for the info from all of you!

since i am not running any apps, it might be the system ^^
or the graphics drivers. (since it really only appears to happen the first time i turn my view in a new room).

i will try on windows on mac on same machine later on and try to compare performance Wink

best regards!
matt
01-15-2008 09:52 AM
Find all posts by this user Quote this message in a reply
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #10
Not Solved RE: laggy performance

Cougar Wrote:The game was really laggy for my Powerbook with Safari and a few other apps open. Quit 'em, and the game ran fine. It's strange, though, I re-launched the apps and Penumbra still runs fine.

Hmm.. It could be you had a website open that used a high amount of Javascript or a flash site.. those at times can hog a LOT of CPU. (Especially flash)

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
01-15-2008 03:27 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


[-]
Quick Reply
Message
Type your reply to this message here.

Image Verification
Please enter the text within the image on the left in to the text box below. This process is used to prevent automated posts.



User(s) browsing this thread: 1 Guest(s)