Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Thread Closed 
64-bit Archlinux using 32-bit chrooted environment, game fails to start
Author Message
DigitalPioneer
Unregistered

 
Post: #1
Not Solved 64-bit Archlinux using 32-bit chrooted environment, game fails to start

Hi.

As I said in the subject, I'm on 64-bit ArchLinux and I'm trying to run Penumbra Overture in a 32-bit chroot environment. The game fails to start. hpl.log contains:

Check serial!
FATAL ERROR: Error Initializing Display: Unable to open a console terminal

It looks like it doesn't like my serial number, which is BS because I just bought the game with the $5 deal and gave it the serial number at installation where it said it looked valid. The real problem, though, seems to be that it can't open a console terminal. Don't know what it's looking for. Can someone help please? :)
07-19-2009 01:59 AM
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #2
Not Solved RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start

Why are you running it in a chroot?? Can you run other 3d games in a chroot like that? Personally I've never tried, but that may be the source of your issues. Most likely the socket for X11 is not accessible inside the chroot and/or the DISPLAY variable isn't accessible.

you should be able to just install the 32bit libraries along side the 64bit libs.

Also that "Check serial!" can be ignored. your serial is fine.. it just spits that out as it's checking it.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
07-19-2009 04:29 AM
Visit this user's website Find all posts by this user
DigitalPioneer
Unregistered

 
Post: #3
Not Solved RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start

About the check serial: Ahh, thanks for clearing that up. I was worried. :P Nothing worse than when anti-piracy goes wrong (see: WGA) as it tends to do frequently.

As to the chroot: I have 32-bit libs installed, but it doesn't seem to find them. It tries to use the 64-bit libs, and fails. That said, I just tried again, and got this:

##### TERMINAL OUTPUT #####
X Error of failed request: GLXUnsupportedPrivateRequest
Major opcode of failed request: 138 (GLX)
Minor opcode of failed request: 16 (X_GLXVendorPrivate)
Serial number of failed request: 29
Current serial number in output stream: 35
X Error of failed request: GLXUnsupportedPrivateRequest
Major opcode of failed request: 138 (GLX)
Minor opcode of failed request: 16 (X_GLXVendorPrivate)
Serial number of failed request: 30
Current serial number in output stream: 36
.Penumbra/PenumbraCollection/Overture/penumbra: line 9: 24648 Segmentation fault ./penumbra.bin "$@"
Penumbra: Overture exited unexpectedly, please check
/home/digitalpioneer//.frictionalgames/Penumbra/Overture/hpl.log
for any error messages
Also try running
ulimit -c unlimited
And re-running Penumbra and try and recreate the error
then submit the generated core file or stack trace
##### END TERMINAL OUTPUT #####

Note that ulimit is unlimited.

##### hpl.log #####
Check serial!
-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 800 x 600 - 32 bpp
Init Glee...OK
Setting up OpenGL
##### END hpl.log #####

So... It looks like it's working now. Can't say I'm sorry. chroots are nasty anyways. :)

After it goes black for a second, and screws my resolution up, it segfaults and I have to set it back to normal. Is there a way to use it at full resolution? Running a program at 800x600 on my 1920x1080 monitor makes me hurt inside... :P It also makes my desktop REALLY difficult to use when it segfaults. Hahah
07-19-2009 05:41 AM
jens Offline
Frictional Games

Posts: 3,593
Joined: Apr 2006
Reputation: 174
Post: #4
Not Solved RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start

You can edit the settings.cfg file that is created in a .frictionalgames or .penumbra folder in your home directory. There is a line for the screen resolution, set it to 1920 and 1080.
07-19-2009 09:33 AM
Visit this user's website Find all posts by this user
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #5
Not Solved RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start

Can you run
ulimit -c unlimited
./penumbra
Do what ever you did to make it crash (seems like just starting up)
then run
gdb ./penumbra.bin core.342423
(the # is the process ID so it WILL be different)
from within GDB run the following
thread apply add bt
and past all of the output (there are going to be multiple pages)

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
07-19-2009 07:21 PM
Visit this user's website Find all posts by this user
DigitalPioneer
Unregistered

 
Post: #6
Not Solved RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start

Jens: No file named settings.cfg in ~/.Penumbra (my install path) or ~/.frictionalgames. Maybe the game doesn't get far enough to create it?

Urkle: Not sure what you need the PID of there, so I just ran `gdb ./penumbra.bin`. Annoyingly enough, though, it blacks out my screen and leaves it that way until I go to a terminal and kill gdb, so I can't get the backtrace. Sad
07-19-2009 08:09 PM
vivaelamor Offline
Junior Member

Posts: 7
Joined: Jul 2009
Reputation: 0
Post: #7
Not Solved RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start

Hi, I just spent a while getting the Penumbra collection working with Arch64 and thought I'd see if anything I've done would work for you. I apologise if any of this is obvious, if you already have catalyst drivers installed from the AUR then most of this may seem oversimplified.

I haven't got a chroot set up, I found that if you install the right lib32 packages you do not need it. You may have to do things a bit differently depending whether you have an ATI card like me or an Nvidia card. Some of the lib32 packages I used are from the AUR.

First you need the basic lib32 collection from the community repository, if you have the community repository enabled just run:
pacman -S lib32

Then you may need to get some packages from AUR, you can do this manually or use yaourt like me.

You probably need lib32-libogg and lib32-libvorbis.
- On second thoughts, this step is probably redundant as the game has these libs built in.

If you also have an ati card like me then you will need some further steps. Firstly make sure you remove any potential conflicts with
pacman -Rd lib32-libgl nvidia-utils
Then install lib32-catalyst-utils as well.

If you have any problems after trying the above please let me know the details as I can probably help further.
07-19-2009 11:53 PM
Find all posts by this user
quadrox Offline
Junior Member

Posts: 2
Joined: Jul 2009
Reputation: 0
Post: #8
Not Solved RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start

(07-19-2009 11:53 PM)vivaelamor Wrote:  If you have any problems after trying the above please let me know the details as I can probably help further.

Hi, I too am using Arch64. I have installed the same things as you, but I get the following console output:

./penumbra
./penumbra.bin: ./lib/libCgGL.so: no version information available (required by ./penumbra.bin)
./penumbra.bin: ./lib/libCg.so: no version information available (required by ./penumbra.bin)
ALSA lib pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
ALSA lib pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
AL lib: alsa.c:344: Could not open playback device 'default': No such file or directory
AL lib: oss.c:179: Could not open /dev/dsp: Invalid argument
./penumbra: line 9: 21415 Segmentation fault      ./penumbra.bin "$@"
Penumbra: Overture exited unexpectedly, please check
/home/corner/.frictionalgames/Penumbra/Overture/hpl.log
for any error messages
Also try running
ulimit -c unlimited
And re-running Penumbra and try and recreate the error
then submit the generated core file or stack trace

I am now trying to fix it by running "yaourt -Syu" but I somehow doubt that it will help...

Edit: Ah, after a reboot it's all working now.
07-23-2009 07:04 AM
Find all posts by this user
DigitalPioneer
Unregistered

 
Post: #9
Not Solved RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start

Ahh! I've got it working! :D Just needed lib32-catalyst-utils.
07-26-2009 05:40 AM
DigitalPioneer
Unregistered

 
Post: #10
Not Solved RE: 64-bit Archlinux using 32-bit chrooted environment, game fails to start

OK, I got it working, but I've got textures disappearing like no-one's business. Walls just disappear randomly and I see what's behind them, objects suddenly become invisible... Really annoying.

And, to add insult to injury, I can't figure out how to open the blocked door in the bunker or whatever it is, after getting out of the blizzard. :P
07-26-2009 06:47 AM
Thread Closed 




User(s) browsing this thread: 1 Guest(s)