Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Thread Closed 
[Solved] Black screen then desktop with a Penumbra Ilegal operation!
Author Message
digx5 Offline
Junior Member

Posts: 3
Joined: Mar 2007
Reputation: 0
Post: #1
Solved: 7 Months, 3 Days, 5 Hours, 45 Minutes, 51 Seconds ago [Solved] Black screen then desktop with a Penumbra Ilegal operation!

Hello guys im here to ask for help on penumbra... sorry for my bad english im Br! So.. here is the thing.. i've downloaded the latest drivers and installed sucessfully, and when i hit penumbra.exe it goes to a black screen then back to desktop on 800x600 (i use in 1024x768) and then appears that message "send to microsoft and dont send" and then it shuts.. i 'll post the HPL:

-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 800 x 600 - 32 bpp
Init Glee...OK
Setting up OpenGL
Max texture image units: 6
Max texture coord units: 6
Two sided stencil: 0
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 16
Multisampling: 0
Vertex Program: 1
Fragment Program: 0
NV Register Combiners: 0
NV Register Combiners Stages: 11
ATI Fragment Shader: 1
Creating graphic systems
Creating Renderer2D
Renderer2D created
Creating Renderer3D
Load Renderer3D gpu programs:
Extrude
Diffuse
Fog
Creating fog textures: Solid Additive Alpha
init sky box
Renderer3D created
Creating screen buffers size 800.000000 : 600.000000
Creating programs
Could not find a working profile for cg file ''!
CG ERROR : The profile is not supported.
ERROR: Couldn't create program 'PostEffect_Blur_Rect_fp.cg'
Could not find a working profile for cg file ''!
CG ERROR : The profile is not supported.
ERROR: Couldn't create program 'PostEffect_Blur_2D_fp.cg'
Could not find a working profile for cg file ''!
CG ERROR : The profile is not supported.
ERROR: Couldn't create program 'PostEffect_Bloom_fp.cg'
ERROR: Couldn't load 'PostEffect_Bloom_fp.cg'!
Could not find a working profile for cg file ''!
CG ERROR : The profile is not supported.
ERROR: Couldn't create program 'PostEffect_Motion_fp.cg'
ERROR: Couldn't load 'PostEffect_Motion_fp.cg'!
Could not find a working profile for cg file ''!
CG ERROR : The profile is not supported.
ERROR: Couldn't create program 'PostEffect_DoF_fp.cg'
ERROR: Couldn't load 'PostEffect_DoF_fp.cg'!
RendererPostEffects created
Adding engine materials
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL.
Trying to open software device...



***Aparently there's something to do with posteffects rendering.... help me pls!
(This post was last modified: 03-28-2007 10:17 PM by jens.)
03-28-2007 06:36 PM
Find all posts by this user
Thomas Offline
Frictional Games

Posts: 2,456
Joined: Apr 2006
Reputation: 44
Post: #2
Solved: 7 Months, 3 Days, 5 Hours, 45 Minutes, 51 Seconds ago RE: Black screen then desktop with a Penumbra Ilegal operation!

Did you install OpenAL?
What soundcard do you have?
Do you have the lastest drivers for your soundcard?
03-28-2007 06:59 PM
Find all posts by this user
digx5 Offline
Junior Member

Posts: 3
Joined: Mar 2007
Reputation: 0
Post: #3
Solved: 7 Months, 3 Days, 5 Hours, 45 Minutes, 51 Seconds ago RE: Black screen then desktop with a Penumbra Ilegal operation!

Thomas Wrote:Did you install OpenAL?
What soundcard do you have?
Do you have the lastest drivers for your soundcard?

yeah i've installed the openAL , my soundcard is onboard nvidia Nforce not sure if it is the latest but i think it is i'll check!
03-28-2007 09:26 PM
Find all posts by this user
digx5 Offline
Junior Member

Posts: 3
Joined: Mar 2007
Reputation: 0
Post: #4
Solved: 7 Months, 3 Days, 5 Hours, 45 Minutes, 51 Seconds ago RE: Black screen then desktop with a Penumbra Ilegal operation!

Heyy man!! its working..!!! it was the audio driver!! it was like: mine version 2.2 and the new one 2.3 ! thx a lot!
03-28-2007 10:12 PM
Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)