Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
HPL wont compile
Author Message
keen Offline
Junior Member

Posts: 6
Joined: Aug 2010
Reputation: 0
Post: #1
HPL wont compile

urgg. I'm having a bit of trouble compiling the HPL.

Here's a snippet of the problems. If you need more info, i can post the whole thing.

/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10012: error: ‘Display’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10012: error: ‘dpy’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10012: error: expected primary-expression before ‘int’
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10012: error: expected primary-expression before ‘int’
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10012: error: expected primary-expression before ‘int’
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10012: error: expected primary-expression before ‘void’
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10013: error: ‘PFNGLXQUERYHYPERPIPENETWORKSGIXPROC’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10014: error: ‘PFNGLXHYPERPIPECONFIGSGIXPROC’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10015: error: ‘PFNGLXQUERYHYPERPIPECONFIGSGIXPROC’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10016: error: ‘PFNGLXDESTROYHYPERPIPECONFIGSGIXPROC’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10017: error: ‘PFNGLXBINDHYPERPIPESGIXPROC’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10018: error: ‘PFNGLXQUERYHYPERPIPEBESTATTRIBSGIXPROC’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10019: error: ‘PFNGLXHYPERPIPEATTRIBSGIXPROC’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10020: error: ‘PFNGLXQUERYHYPERPIPEATTRIBSGIXPROC’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10055: error: ‘GLboolean’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10056: error: ‘GLint’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/../dependencies/include/GL/GLee.h:10059: error: ‘GLboolean’ does not name a type
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp: In member function ‘virtual void hpl::cGLStateTwoUnits_ATIDiffuse::InitData()’:
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:70: error: ‘pglGenFragmentShadersATI’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:73: error: ‘pglBindFragmentShaderATI’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:77: error: ‘pglSampleMapATI’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:82: error: ‘pglSetFragmentShaderConstantATI’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:83: error: ‘GL_NONE’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:85: error: ‘pglColorFragmentOp2ATI’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:88: error: ‘pglAlphaFragmentOp2ATI’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp: In destructor ‘virtual hpl::cGLStateTwoUnits_ATIDiffuse::~cGLStateTwoUnits_ATIDiffuse()’:
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:101: error: ‘pglDeleteFragmentShaderATI’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp: In member function ‘virtual void hpl::cGLStateTwoUnits_ATIDiffuse::Bind()’:
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:106: error: ‘glEnable’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:107: error: ‘pglBindFragmentShaderATI’ was not declared in this scope
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp: In member function ‘virtual void hpl::cGLStateTwoUnits_ATIDiffuse::UnBind()’:
/home/andrew/Desktop/source/HPL1Engine/sources/graphics/Material_Fallback02_BaseLight.cpp:112: error: ‘glDisable’ was not declared in this scope
make[2]: *** [CMakeFiles/HPL.dir/sources/graphics/Material_Fallback02_BaseLight.cpp.o] Error 1
make[1]: *** [CMakeFiles/HPL.dir/all] Error 2
make: *** [all] Error 2
andrew@andrew-desktop:~/Desktop/source/HPL1Engine$

I have a sneaking suspicion that it might be the same problem that steviebob had with the GLee.h file. But, I'm not sure. And even more clueless on how to fix it. I tried replacing the GLee.h file and recompiling, but i didnt seem to help.

Any insight would be helpful and appreciated. Smile thanks.
08-07-2010 11:04 AM
Find all posts by this user Quote this message in a reply
Post Reply 


Messages In This Thread
HPL wont compile - keen - 08-07-2010 11:04 AM
RE: HPL wont compile - keen - 08-07-2010, 07:37 PM



User(s) browsing this thread: 1 Guest(s)