Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
[Arch64] Problem running Penumbra Collection (Any game)
Author Message
Whoracle Offline
Junior Member

Posts: 5
Joined: Dec 2010
Reputation: 0
Post: #1
Not Solved [Arch64] Problem running Penumbra Collection (Any game)

Originally, I did not want to make a new thread for this so fast after making my earlier one, but since the forum software attaches new posts rather than updating the whole thread, here it goes:

First, the output:

[anthrax@lynxcore PenumbraCollection]$ ./blackplague
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  138 (GLX)
  Minor opcode of failed request:  182 ()
  Serial number of failed request:  36
  Current serial number in output stream:  39
Penumbra: Black Plague exited unexpectedly, please check
/home/anthrax/.frictionalgames/Penumbra/Black Plague/hpl.log
for any error messages
Also try running
ulimit -c unlimited
And re-running Penumbra and try and recreate the error
then submit the generated core file or stack trace

Contents of hpl.log:
[anthrax@lynxcore PenumbraCollection]$ cat /home/anthrax/.frictionalgames/Penumbra/Black\ Plague/hpl.log
-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 800 x 600 - 32 bpp
Init Glee...OK
Setting up OpenGL

ulimit is set to unlimited.
Error persists for Black Plague, Requiem and Overture.

I see a small window popping up and dying, and that's it.
Had a xinerama multidisplay setup, disabled one monitor so I am now running on 1680x1050 on an NVIDIA GeForce 9600 GT (driver version 260.19.29)

Output of df:
[anthrax@lynxcore ~]$ df -h
Filesystem                          Size  Used Avail  Use% Mounted on
udev                                 10M  164K  9.9M   2%    /dev
/dev/disk/by-label/archroot   7.3G  6.1G  801M  89%  /
none                                 1.5G      0   1.5G   0%   /dev/shm
/dev/sdc1                           99M   16M   79M  17%  /boot
/dev/sdc4                          141G  100G   35G  75% /home

I suspect this is a problem with the graphics system, but since neither log nor console gives any useful information, I'm stumped.

Also, I don't know what the game means by "then submit the generated core file or stack trace", since I haven't found any.
12-29-2010 08:56 PM
Find all posts by this user Quote this message in a reply
Post Reply 


Messages In This Thread
[Arch64] Problem running Penumbra Collection (Any game) - Whoracle - 12-29-2010 08:56 PM



User(s) browsing this thread: 1 Guest(s)