Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
[Arch64] Problem running Penumbra Collection (Any game)
Author Message
Urkle Offline
FG - Associate

Posts: 1,153
Joined: Jul 2006
Reputation: 19
Post: #2
Not Solved RE: [Arch64] Problem running Penumbra Collection (Any game)

ldd blackblague.bin

First look it seems as though you don't have the 32 nvidia libraries installed correctly.

the output of LDD will tell us which version of libGL is being used. Then make sure that is the one FROM the 32bit nvidia libs.

If that is correct, then try removing libraries from the "libs" folder in the game installation that you already have on your system.

As for the coredump.. That requires a little bit of extra work.
Make sure that the core dumps are named with a PID

(as Root)
sysctl -w kernel.core_users_pid=1

Next,enable core dumping
ulimit -c unlimited

Now make sure you can write to the penumbra game directory (if you installed this under your user account, then no issue). then run the game and when it bombs run
gdb ./blackblague.bin ./core.####
replace #### with actual PID the core was created from.. Tab completion, or ls core.* to see what it is.
(and BTW.. this whole fiasco is handled soo much better in Amnesia)

Developing away on one of
Mac Pro Dual 2Ghz, 14GB RAM, 10.6 (still), nVidia 8800 512MB.
Linux, 8-core AMD, 8GB RAM, Fedora 17, nVidia 450 1GB
(This post was last modified: 12-29-2010 09:11 PM by Urkle.)
12-29-2010 09:10 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 


Messages In This Thread
RE: [Arch64] Problem running Penumbra Collection (Any game) - Urkle - 12-29-2010 09:10 PM



User(s) browsing this thread: 1 Guest(s)