Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
 
Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Loading screens
Author Message
zeravia Offline
Member

Posts: 228
Joined: Jul 2011
Reputation: 1
Post: #11
RE: Loading screens

(08-27-2011 07:56 PM)Juby Wrote:  
(08-27-2011 07:51 PM)zeravia Wrote:  @x@

now my game crashes when i try to load the level the loading screen is on... where do i put the SetupLoadScreen script? in the level HPS?

You can put it in the OnStart, OnEnter, OnLeave, and any other function in a .hps file.

i did that, and i even took it out once... my map keeps crashing the game and i don't know why. DX

it says this...

----
Amneisa.exe caused an EXEPTION_ACCESS_VIOLATION in module
<UNKNOWN> at 001B:02AAFCE9

i have no idea where that is. @x@

Diary of a madman -Onhold

New - [Image: at_1374739.png]
08-27-2011 08:08 PM
Visit this user's website Find all posts by this user Quote this message in a reply
zeravia Offline
Member

Posts: 228
Joined: Jul 2011
Reputation: 1
Post: #12
RE: Loading screens

no Really. I don't know what I am doing wrong, Several hours later I am still Fighting with it, it either crashes right before loading the level, or will not show the picture,. when i remove the picture no text appears. I have no idea why this is happening... ;___;

Diary of a madman -Onhold

New - [Image: at_1374739.png]
08-28-2011 04:26 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Your Computer Offline
SCAN ME!

Posts: 3,475
Joined: Jul 2011
Reputation: 234
Post: #13
RE: Loading screens

(08-28-2011 04:26 AM)zeravia Wrote:  I have no idea why this is happening... ;___;

Neither do we. Try posting some code.

Tutorials: From Noob to Pro
08-28-2011 06:32 AM
Visit this user's website Find all posts by this user Quote this message in a reply
zeravia Offline
Member

Posts: 228
Joined: Jul 2011
Reputation: 1
Post: #14
RE: Loading screens

(08-28-2011 06:32 AM)Your Computer Wrote:  
(08-28-2011 04:26 AM)zeravia Wrote:  I have no idea why this is happening... ;___;

Neither do we. Try posting some code.

in my extra_english

<CATEGORY Name="LoadingText">
<Entry Name="level_01">The carriage ride to the village more then made up for the horrable flight.</Entry>
</CATEGORY>

in my map file

void OnLeave()
{
SetupLoadScreen("LoadingText", "level_01", 1, "LS01.jpg");
}


does anyone see what is wrong with it?

Diary of a madman -Onhold

New - [Image: at_1374739.png]
08-28-2011 08:40 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Elven Offline
Posting Freak

Posts: 859
Joined: Aug 2011
Reputation: 26
Post: #15
RE: Loading screens

quick question. Move your extra somewhere else. Test if your game crashes without extra. If it does, kill that script too. This way you will get idea where might be cause of the crash.

The Interrogation
Chapter 1

My tutorials
08-28-2011 08:52 PM
Find all posts by this user Quote this message in a reply
zeravia Offline
Member

Posts: 228
Joined: Jul 2011
Reputation: 1
Post: #16
RE: Loading screens

(08-28-2011 08:52 PM)Elven Wrote:  quick question. Move your extra somewhere else. Test if your game crashes without extra. If it does, kill that script too. This way you will get idea where might be cause of the crash.

i already know where it is. it's in the .hps, something about that setuploadingscreen script is wrong...

Diary of a madman -Onhold

New - [Image: at_1374739.png]
08-28-2011 09:12 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Elven Offline
Posting Freak

Posts: 859
Joined: Aug 2011
Reputation: 26
Post: #17
RE: Loading screens

Its probably in wrong place. Put it into OnStart instead or create area before the change of map and make it false so it wont delete when player goes in and make the loading stuff over there instead Smile. Maybe that helps Smile

Maybe that helps and gives you idea: http://www.youtube.com/watch?v=Pv9GK5Gh4Bw

The Interrogation
Chapter 1

My tutorials
(This post was last modified: 08-28-2011 09:30 PM by Elven.)
08-28-2011 09:28 PM
Find all posts by this user Quote this message in a reply
zeravia Offline
Member

Posts: 228
Joined: Jul 2011
Reputation: 1
Post: #18
RE: Loading screens

(08-28-2011 09:28 PM)Elven Wrote:  Its probably in wrong place. Put it into OnStart instead or create area before the change of map and make it false so it wont delete when player goes in and make the loading stuff over there instead Smile. Maybe that helps Smile

Maybe that helps and gives you idea: http://www.youtube.com/watch?v=Pv9GK5Gh4Bw

no one elce does that, and i got it to work once... that's what i'm trying to tell people... I don't know why it worked once and now won't.

Diary of a madman -Onhold

New - [Image: at_1374739.png]
08-28-2011 09:34 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Elven Offline
Posting Freak

Posts: 859
Joined: Aug 2011
Reputation: 26
Post: #19
RE: Loading screens

Because no-one else doesn't use that doesn't mean you have to be like everyone else ^^.

I would do that, as long it works. For me it doesn't matter how I script in most cases, as long it works!

Well, that's all I can help with. I hope someone else can help you Smile

The Interrogation
Chapter 1

My tutorials
(This post was last modified: 08-28-2011 09:36 PM by Elven.)
08-28-2011 09:35 PM
Find all posts by this user Quote this message in a reply
zeravia Offline
Member

Posts: 228
Joined: Jul 2011
Reputation: 1
Post: #20
RE: Loading screens

(08-27-2011 07:56 PM)Juby Wrote:  
(08-27-2011 07:51 PM)zeravia Wrote:  @x@

now my game crashes when i try to load the level the loading screen is on... where do i put the SetupLoadScreen script? in the level HPS?

You can put it in the OnStart, OnEnter, OnLeave, and any other function in a .hps file.

ive tried everything. even re-copying and pasting, and nothing works...

Diary of a madman -Onhold

New - [Image: at_1374739.png]
08-29-2011 12:07 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)