Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support | Gametee


Thread Closed 
OpenAL Audio Update: Use 1.0.2553 Patch instead!
Author Message
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #1
Solved: 1 Year, 7 Months, 3 Weeks, 7 Hours, 58 Minutes, 2 Seconds ago OpenAL Audio Update: Use 1.0.2553 Patch instead!

Quote:This patch is no longer applicable and SHOULD NOT BE USED!

Please use the official 1.0.2553 update for linux located:
http://support.frictionalgames.com/entry/65/

I have an update to OpenAL that I would like users to test. Use this update if you encounter crackly sound or other sound artifacts. This can be applied over Penumbra: Overture Episode 1 Demo OR Full Version. If you have the full version (you do don't you??) Please make sure you install the 1.0.679 patch.

This patch will install a libopenal.so.1.0.0 into the Penumbra "lib" directory. This will NOT overwrite the old libopenal.so.0.0.0. It will only update the symbolic link libopenal.so.0 to point to the new file.

If you need to revert back to the old openal lib run this from within the Penumbra Overture install directory.
cd libs
ln -sf libopenal.so.0.0.0 libopenal.so.0
cd -

And to use the new lib again run
cd libs
ln -sf libopenal.so.1.0.0 libopenal.so.0
cd -

Please put any feedback you have about this patch to this thread.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
06-28-2007 05:08 PM
Visit this user's website Find all posts by this user
GFree Offline
Junior Member

Posts: 44
Joined: Mar 2007
Reputation: 0
Post: #2
Solved: 1 Year, 7 Months, 3 Weeks, 7 Hours, 58 Minutes, 2 Seconds ago RE: OpenAL Audio Update / Feedback

I tried the replacement lib. Started a new game, but when the initial boat map loaded there was a fairly loud screeching noise, I think it was one of the game SFX but messed up. I could still hear other audio like the boat's horn, and interestingly enough the menu/intro all sounded fine, but I didn't bother with it and reverted back to the original lib.

I use an AC97 integrated audio chipset.
(This post was last modified: 07-02-2007 10:59 AM by thechef.)
07-02-2007 10:58 AM
Find all posts by this user
MIT_Service Offline
Junior Member

Posts: 6
Joined: Apr 2007
Reputation: 0
Post: #3
Solved: 1 Year, 7 Months, 3 Weeks, 7 Hours, 58 Minutes, 2 Seconds ago RE: OpenAL Audio Update / Feedback

I can confirm that "screeching sound".
All sounds ingame (not menu and intro) sound crappy. Just like the bitrate was reduced or something was badly encoded.

I also use an AC97 compatible sound card (but not an integrated one).
07-02-2007 12:51 PM
Find all posts by this user
Thib_G Offline
Junior Member

Posts: 35
Joined: Mar 2007
Reputation: 0
Post: #4
Solved: 1 Year, 7 Months, 3 Weeks, 7 Hours, 58 Minutes, 2 Seconds ago RE: OpenAL Audio Update / Feedback

I've not bought the game yet, and I didn't download this patch.
I've always got creepy sound with OpenAL before I make a little modification in /etc/openalrc :
For KDE users ( I'm not, so, I'm not sure it works ) :
(define devices '(artsd))
(define alsa-out-device "default")
For GNOME users :
(define devices '(esd))
(define alsa-out-device "default")
07-02-2007 05:52 PM
Find all posts by this user
Linux.Blue Offline
Senior Member

Posts: 615
Joined: Jun 2007
Reputation: 0
Post: #5
Solved: 1 Year, 7 Months, 3 Weeks, 7 Hours, 58 Minutes, 2 Seconds ago RE: OpenAL Audio Update / Feedback

after using this patch, I get no sound at all
07-24-2007 12:21 PM
Find all posts by this user
mjs Offline
Junior Member

Posts: 1
Joined: Dec 2006
Reputation: 0
Post: #6
Solved: 1 Year, 7 Months, 3 Weeks, 7 Hours, 58 Minutes, 2 Seconds ago RE: OpenAL Audio Update / Feedback

Penumbra crashes on startup after using this patch. I had to revert to the libopenal.so.0.0.0 library. I use Ubuntu Gutsy Gibbon. The last message I see in the hpa.log was: "Trying to open audio device".
09-23-2007 11:39 PM
Find all posts by this user
thetargos Offline
Junior Member

Posts: 30
Joined: Apr 2007
Reputation: 0
Post: #7
Solved: 1 Year, 7 Months, 3 Weeks, 7 Hours, 58 Minutes, 2 Seconds ago RE: OpenAL Audio Update / Feedback

The game also crashes on my setup. I'm running 64-bit Linux and running an ldd on the library gives:

[gianni@Blackhawk lib]$ ldd libopenal.so.1.0.0
        linux-gate.so.1 =>  (0xffffe000)
        libm.so.6 => /lib/libm.so.6 (0xf7f45000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf7f2d000)
        libdl.so.2 => /lib/libdl.so.2 (0xf7f28000)
        libc.so.6 => /lib/libc.so.6 (0xf7dd4000)
        /lib/ld-linux.so.2 (0x56555000)

All deps are covered, and I'm not sure what is causing the crash. I ran the game with ulimit -c unlimit so that it would generate a core dump, which I'm trying to attach (hopefully it does attach this time)

I don't seem able to attach the core dump file, maybe because it is a .bz2 file? (it also is of 4.3Mb down from an original of over 42Mb!!)
(This post was last modified: 09-26-2007 09:32 AM by sensei2007.)
09-26-2007 09:30 AM
Find all posts by this user
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #8
Solved: 1 Year, 7 Months, 3 Weeks, 7 Hours, 58 Minutes, 2 Seconds ago RE: OpenAL Audio Update / Feedback

Follow the directions in this post on how to get a backtrace. Then just attach the output.

Also, please include your hpl.log file as well from the run where it crashed.

How to get a backtrace

thetargos Wrote:The game also crashes on my setup. I'm running 64-bit Linux and running an ldd on the library gives:

[gianni@Blackhawk lib]$ ldd libopenal.so.1.0.0
        linux-gate.so.1 =>  (0xffffe000)
        libm.so.6 => /lib/libm.so.6 (0xf7f45000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf7f2d000)
        libdl.so.2 => /lib/libdl.so.2 (0xf7f28000)
        libc.so.6 => /lib/libc.so.6 (0xf7dd4000)
        /lib/ld-linux.so.2 (0x56555000)

All deps are covered, and I'm not sure what is causing the crash. I ran the game with ulimit -c unlimit so that it would generate a core dump, which I'm trying to attach (hopefully it does attach this time)

I don't seem able to attach the core dump file, maybe because it is a .bz2 file? (it also is of 4.3Mb down from an original of over 42Mb!!)

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-26-2007 02:23 PM
Visit this user's website Find all posts by this user
thetargos Offline
Junior Member

Posts: 30
Joined: Apr 2007
Reputation: 0
Post: #9
Solved: 1 Year, 7 Months, 3 Weeks, 7 Hours, 58 Minutes, 2 Seconds ago RE: OpenAL Audio Update / Feedback

I think that what you need to know and want to see is the following:

Core was generated by `./penumbra.bin'.
Program terminated with signal 11, Segmentation fault.
#0  0xf79e9f7a in alcCloseDevice () from ./lib/libopenal.so.0
(gdb) thread apply all bt full

Thread 1 (process 14644):
#0  0xf79e9f7a in alcCloseDevice () from ./lib/libopenal.so.0
No symbol table info available.
#1  0x009c7650 in _r_debug ()
No symbol table info available.
#2  0x08c8e518 in ?? ()
No symbol table info available.
#3  0x08327e2b in ?? ()
No symbol table info available.
#4  0x0831f496 in ?? ()
No symbol table info available.
#5  0x0831f5b6 in ?? ()
No symbol table info available.
#6  0x082bef1f in ?? ()
No symbol table info available.
#7  0x08289174 in ?? ()
No symbol table info available.
#8  0x0826c9d0 in ?? ()
No symbol table info available.
#9  0x080ef285 in ?? ()
No symbol table info available.
#10 0x0810e530 in ?? ()

Hope that helps.

System:
Fedora 7 x86_64
Kernel: 2.6.22.5-76.fc7
ALSA: 1.0.14

Edit
Forgot the hpl.log file... DONE

Just to see if might also help, here are the contents of my /etc/openalrc file:
;;(define devices '(alsa native))

;; uncomment this to output via the 2nd soundcard
;;(define alsa-device "plughw:2,0")
(This post was last modified: 09-27-2007 12:58 AM by sensei2007.)
09-27-2007 12:53 AM
Find all posts by this user
Gemini Offline
Junior Member

Posts: 8
Joined: Sep 2007
Reputation: 0
Post: #10
Solved: 1 Year, 7 Months, 3 Weeks, 7 Hours, 58 Minutes, 2 Seconds ago RE: OpenAL Audio Update / Feedback

Hi,

I tried the patch, and it just ended in making the game segfault at startup.

I use Mandriva 2007.1 Spring with a 64 bits environment and a 2.6.17-15mdv kernel.
09-28-2007 05:04 PM
Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)