Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Thread Closed 
I CAN NOT PLAY :(
Author Message
Develslilangel Offline
Junior Member

Posts: 1
Joined: Mar 2012
Reputation: 0
Post: #1
Solved: 7 Months, 2 Weeks, 1 Day, 22 Hours, 23 Minutes, 6 Seconds ago I CAN NOT PLAY :(

Hi,
I just download the Penumbra Black Plague Demo, and when I went to go and play it the menu/main title screen worked just fine. but I started that game on Easy mode, and when the graphics tried to load it was just a completely white fuzzy screen.

I set my graphics setting to low and I'v tried everything in my mind.


Here are my system details:
Windows 7 Professional
Intel® Core™ i3-2310M CPU @ 2.10GHz 2.10 GHz
4.00 GB RAM
64-bit Operating System
---------------------------------------------------
Please help ASAP .
04-01-2012 12:07 AM
Find all posts by this user
Tanshaydar Offline
From Beyond

Posts: 3,085
Joined: Mar 2009
Reputation: 66
Post: #2
Solved: 7 Months, 2 Weeks, 1 Day, 22 Hours, 23 Minutes, 6 Seconds ago RE: I CAN NOT PLAY :(

Do you have graphic card details?

04-01-2012 04:58 PM
Visit this user's website Find all posts by this user
heinoushippo Offline
Junior Member

Posts: 1
Joined: Apr 2012
Reputation: 0
Post: #3
Solved: 7 Months, 2 Weeks, 1 Day, 22 Hours, 23 Minutes, 6 Seconds ago RE: I CAN NOT PLAY :(

i have the same problem

windows 7 64bit
i5 2.3 ghz
6gb ram
geforce 555m 1gb video card
04-07-2012 04:06 PM
Find all posts by this user
brute360 Offline
Junior Member

Posts: 31
Joined: Apr 2012
Reputation: 0
Post: #4
Solved: 7 Months, 2 Weeks, 1 Day, 22 Hours, 23 Minutes, 6 Seconds ago RE: I CAN NOT PLAY :(

Have you tried updating videodrivers?
04-07-2012 04:12 PM
Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)