Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Multiple problems
Author Message
Saren Offline
Member

Posts: 196
Joined: Jan 2012
Reputation: 1
Post: #1
Multiple problems

Alright, been some time guys, I was.... I guess you can call it an accident and get really messed.... lotsa wounds.... anyway, I'm back and I reeeeaaalllly don't have the energy right now to try and keep fixing these mistakes myself.... which I have in a long time....
First is that a monster should spawn after you pick up a key, but he dose'nt spawn.... tried with diffrent ones, same resault. And yes, I watched Your computer's tutorial...... still same.. here's is da script:
//Spawn brute
void ActivateMonster(string &in AsEntity)
{
SetEntityActive("servant_brute", true);
AddEnemyPatrolNode("servant_brute", "PathNodeArea_1", 2, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_2", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_3", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_4", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_5", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_6", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_7", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_8", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_9", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_10", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_11", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_12", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_13", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_14", 0, "");
}
void Despawnservant_brute(string &in asParent , string &in asChild , int alState)
{
SetEntityActive("servant_brute", false);
}

void OnLeave()
{
}

Second is that the key does not work in a different map where it should. Script:
void OnStart()
{
AddUseItemCallback("", "Upperfloorkey", "upperfloordoor", "UsedKeyOnDoor", true);
}

void UsedKeyOnDoor(string &in asItem, string &in asEntity)
{
SetSwingDoorLocked("upperfloordoor", false, true);
PlaySoundAtEntity("", "unlock_door", "upperfloordoor", 0, false);
PlaySoundAtEntity("", "03_puzzle_secret", "Player", 0, false);
RemoveItem("Upperfloorkey");
}

void OnLeave()
{
}

04-15-2012 01:14 AM
Find all posts by this user Quote this message in a reply
SilentStriker Offline
Posting Freak

Posts: 950
Joined: Jul 2011
Reputation: 42
Post: #2
RE: Multiple problems

First problem: I would guess it's a PlayerInteractCallback by the looks of the syntax so try this
void ActivateMonster(string &in asEntity)
{
SetEntityActive("servant_brute", true);
AddEnemyPatrolNode("servant_brute", "PathNodeArea_1", 2, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_2", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_3", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_4", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_5", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_6", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_7", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_8", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_9", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_10", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_11", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_12", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_13", 0, "");
AddEnemyPatrolNode("servant_brute", "PathNodeArea_14", 0, "");
}

void Despawnservant_brute(string &in asParent , string &in asChild , int alState)
{
SetEntityActive("servant_brute", false);
}

void OnLeave()
{

}

Problem 2: Check so the naming is correct on both the door and the key

(This post was last modified: 04-15-2012 01:21 AM by SilentStriker.)
04-15-2012 01:18 AM
Find all posts by this user Quote this message in a reply
Saren Offline
Member

Posts: 196
Joined: Jan 2012
Reputation: 1
Post: #3
RE: Multiple problems

(04-15-2012 01:18 AM)SilentStriker Wrote:  First problem: I would guess it's a PlayerInteractCallback by the looks of the syntax so try this
void ActivateMonster(string &in asEntity)

{

SetEntityActive("servant_brute", true);

AddEnemyPatrolNode("servant_brute", "PathNodeArea_1", 2, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_2", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_3", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_4", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_5", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_6", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_7", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_8", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_9", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_10", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_11", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_12", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_13", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_14", 0, "");

}

void Despawnservant_brute(string &in asParent , string &in asChild , int alState)

{

SetEntityActive("servant_brute", false);

}



void OnLeave()

{

}

Problem 2: Check so the naming is correct on both the door and the key
You quick yo... lol, anyway, alright, gonna see if this 1 works

04-15-2012 01:20 AM
Find all posts by this user Quote this message in a reply
SilentStriker Offline
Posting Freak

Posts: 950
Joined: Jul 2011
Reputation: 42
Post: #4
RE: Multiple problems

(04-15-2012 01:20 AM)Saren Wrote:  
(04-15-2012 01:18 AM)SilentStriker Wrote:  First problem: I would guess it's a PlayerInteractCallback by the looks of the syntax so try this
void ActivateMonster(string &in asEntity)

{

SetEntityActive("servant_brute", true);

AddEnemyPatrolNode("servant_brute", "PathNodeArea_1", 2, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_2", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_3", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_4", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_5", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_6", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_7", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_8", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_9", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_10", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_11", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_12", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_13", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_14", 0, "");

}

void Despawnservant_brute(string &in asParent , string &in asChild , int alState)

{

SetEntityActive("servant_brute", false);

}



void OnLeave()

{

}

Problem 2: Check so the naming is correct on both the door and the key
You quick yo... lol, anyway, alright, gonna see if this 1 works
haha yea I'm bored and it's late I should get to bed x)

04-15-2012 01:21 AM
Find all posts by this user Quote this message in a reply
Saren Offline
Member

Posts: 196
Joined: Jan 2012
Reputation: 1
Post: #5
RE: Multiple problems

(04-15-2012 01:21 AM)SilentStriker Wrote:  
(04-15-2012 01:20 AM)Saren Wrote:  
(04-15-2012 01:18 AM)SilentStriker Wrote:  First problem: I would guess it's a PlayerInteractCallback by the looks of the syntax so try this
void ActivateMonster(string &in asEntity)

{

SetEntityActive("servant_brute", true);

AddEnemyPatrolNode("servant_brute", "PathNodeArea_1", 2, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_2", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_3", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_4", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_5", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_6", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_7", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_8", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_9", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_10", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_11", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_12", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_13", 0, "");

AddEnemyPatrolNode("servant_brute", "PathNodeArea_14", 0, "");

}

void Despawnservant_brute(string &in asParent , string &in asChild , int alState)

{

SetEntityActive("servant_brute", false);

}



void OnLeave()

{

}

Problem 2: Check so the naming is correct on both the door and the key
You quick yo... lol, anyway, alright, gonna see if this 1 works
haha yea I'm bored and it's late I should get to bed x)
Hahaha yea ditto.... xD
What time is it where you live?

04-15-2012 01:22 AM
Find all posts by this user Quote this message in a reply
SilentStriker Offline
Posting Freak

Posts: 950
Joined: Jul 2011
Reputation: 42
Post: #6
RE: Multiple problems

It was around 2:18 am when I replied Smile

04-15-2012 09:02 AM
Find all posts by this user Quote this message in a reply
Saren Offline
Member

Posts: 196
Joined: Jan 2012
Reputation: 1
Post: #7
RE: Multiple problems

(04-15-2012 09:02 AM)SilentStriker Wrote:  It was around 2:18 am when I replied Smile
Lol dayum, was around the same here..... you not from USA then, hahaha, nice to see not everyone is xD

EDIT: Yea I tried it.... no, not working at all..

(This post was last modified: 04-15-2012 03:36 PM by Saren.)
04-15-2012 03:20 PM
Find all posts by this user Quote this message in a reply
SilentStriker Offline
Posting Freak

Posts: 950
Joined: Jul 2011
Reputation: 42
Post: #8
RE: Multiple problems

I'm from Sweden ^^ Check so everything is named right, since I believe you don't get any errors? just not working right?

04-15-2012 04:13 PM
Find all posts by this user Quote this message in a reply
Saren Offline
Member

Posts: 196
Joined: Jan 2012
Reputation: 1
Post: #9
RE: Multiple problems

(04-15-2012 04:13 PM)SilentStriker Wrote:  I'm from Sweden ^^ Check so everything is named right, since I believe you don't get any errors? just not working right?
Nice we are neighbours, I'm from DK =) Well I originally come from Russia but I live in DK... haha
And yea, the stuff just don't work.... no FATAL ERRORS xD

04-16-2012 03:01 AM
Find all posts by this user Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)