Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support | Gametee


Thread Closed 
Crash after the intro in demo version
Author Message
merlok1436 Offline
Junior Member

Posts: 4
Joined: Mar 2008
Reputation: 0
Post: #1
Solved: 1 Year, 9 Months, 2 Weeks, 3 Days, 22 Hours, 16 Minutes, 45 Seconds ago Crash after the intro in demo version

The game will crash after the intro when loading.
There is the hpl.log
Quote:-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 1280 x 800 - 32 bpp
Init Glee...OK
Setting up OpenGL
Max texture image units: 16
Max texture coord units: 8
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 16
Multisampling: 1
Vertex Program: 1
Fragment Program: 1
NV Register Combiners: 0
NV Register Combiners Stages: 140488584
ATI Fragment Shader: 1
Creating graphic systems
Creating Renderer2D
Renderer2D created
Creating Renderer3D
Load Renderer3D gpu programs:
Extrude
Diffuse
Fog
Creating fog textures: Solid Additive Alpha
init sky box
Renderer3D created
Creating screen buffers size 1280.000000 : 800.000000
Creating programs
RendererPostEffects created
Adding engine materials
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL.
Trying to open audio device... Success!
Device name:
OpenAL Version Supported: 1.0
Number of channels: 32
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
Trying to load vertex program!
Success!
--------------------------------------------------------

Game Running
--------------------------------------------------------
WARNING: Could not find language file entry 'Show Crosshair:'
Loading collada for 'data/level00_01_boat_cabin.dae' took: 236 ms
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Bone 'joint1' is not attached to skin!
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
ERROR: Child body 'joint1' for joint 'sjoint2' in mesh 'boat_dynamicparaffin.dae' does not exist!
ERROR: Cannot find sub entity 'parrafinlight_joint1' in mesh 'boat_dynamicparaffin.dae'
Start Num Of: 82
Start Num Of: 1
Loading map 'level00_01_boat_cabin.dae' took: 6717 ms

How can i fix it??
03-12-2008 05:26 PM
Find all posts by this user
jens Offline
Frictional Games

Posts: 4,095
Joined: Apr 2006
Reputation: 202
Post: #2
Solved: 1 Year, 9 Months, 2 Weeks, 3 Days, 22 Hours, 16 Minutes, 45 Seconds ago RE: Crash after the intro in demo version

What graphics card do you have?
03-12-2008 05:40 PM
Visit this user's website Find all posts by this user
merlok1436 Offline
Junior Member

Posts: 4
Joined: Mar 2008
Reputation: 0
Post: #3
Solved: 1 Year, 9 Months, 2 Weeks, 3 Days, 22 Hours, 16 Minutes, 45 Seconds ago RE: Crash after the intro in demo version

jens Wrote:What graphics card do you have?

Ati HD 2400 with 128mb of ram for notebook(toshiba satellite a200)
03-13-2008 02:43 PM
Find all posts by this user
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 21
Post: #4
Solved: 1 Year, 9 Months, 2 Weeks, 3 Days, 22 Hours, 16 Minutes, 45 Seconds ago RE: Crash after the intro in demo version

Have you tried it at a lower resolution?

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
03-14-2008 02:38 AM
Visit this user's website Find all posts by this user
merlok1436 Offline
Junior Member

Posts: 4
Joined: Mar 2008
Reputation: 0
Post: #5
Solved: 1 Year, 9 Months, 2 Weeks, 3 Days, 22 Hours, 16 Minutes, 45 Seconds ago RE: Crash after the intro in demo version

Urkle Wrote:Have you tried it at a lower resolution?

Yes i tried but the problem persists
03-14-2008 01:20 PM
Find all posts by this user
bulletxt Offline
Junior Member

Posts: 3
Joined: Feb 2008
Reputation: 0
Post: #6
Solved: 1 Year, 9 Months, 2 Weeks, 3 Days, 22 Hours, 16 Minutes, 45 Seconds ago RE: Crash after the intro in demo version

disable compiz in case it is enabled.

then be sure to have the latest ati fglrx 8.3 correctly installed.

delete ~./frictionalgames ecc folder and retry.

hope it helps.

ps: are you on a 64bit OS?
(This post was last modified: 03-15-2008 07:18 PM by steelpenguin.)
03-15-2008 07:16 PM
Find all posts by this user
merlok1436 Offline
Junior Member

Posts: 4
Joined: Mar 2008
Reputation: 0
Post: #7
Solved: 1 Year, 9 Months, 2 Weeks, 3 Days, 22 Hours, 16 Minutes, 45 Seconds ago RE: Crash after the intro in demo version

yes i have a 64bit O/S(OpenSuse 10.3).Now i try your tips...
03-17-2008 12:29 PM
Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)