Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support | Gametee


Thread Closed 
Segfault on installation
Author Message
wari Offline
Junior Member

Posts: 8
Joined: Apr 2008
Reputation: 0
Post: #1
Solved: 1 Year, 7 Months, 3 Weeks, 6 Hours, 32 Minutes, 8 Seconds ago Segfault on installation

Just discovered this game and I thought of giving it a try before I buy, unfortunately, I can't install it.

System: Core 2 Duo 2.4Ghz
RAM: 8GB
GPU: Nvidia 8600
OS: Ubuntu Hardy 64bit

Installation Results:
$ ./PenumbraOvertureDemo-2553.sh
Verifying archive integrity... All good.
Uncompressing nixstaller.........................................................
Collecting info for this system...
Operating system: linux
CPU Arch: x86_64
Warning: No installer for "x86_64" found, defaulting to x86...
Segmentation fault


Further details:
+ cd /tmp/selfgz16589
+ res=0
+ test xsh != x
+ test xn = xy
+ eval sh ./startupinstaller.sh
+ sh ./startupinstaller.sh
Collecting info for this system...
Operating system: linux
CPU Arch: x86_64
Warning: No installer for "x86_64" found, defaulting to x86...
Segmentation fault
+ res=139
+ test 139 -ne 0
+ test xn = xy
+ test n = n
+ cd /tmp
+ /bin/rm -rf /tmp/selfgz16589
+ eval true
+ true
+ exit 139
04-29-2008 01:50 AM
Find all posts by this user
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #2
Solved: 1 Year, 7 Months, 3 Weeks, 6 Hours, 32 Minutes, 8 Seconds ago RE: Segfault on installation

When did you download the demo, and which mirror did you use. It seems like you got the old demo installer (we pushed an update to the installer to fix that segfault)

The filesize should be 118645058 with an md5sum of dfd6d958c3ef8360577767f320059b76

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
04-29-2008 02:03 AM
Visit this user's website Find all posts by this user
wari Offline
Junior Member

Posts: 8
Joined: Apr 2008
Reputation: 0
Post: #3
Solved: 1 Year, 7 Months, 3 Weeks, 6 Hours, 32 Minutes, 8 Seconds ago RE: Segfault on installation

Urkle Wrote:When did you download the demo, and which mirror did you use. It seems like you got the old demo installer (we pushed an update to the installer to fix that segfault)

The filesize should be 118645058 with an md5sum of dfd6d958c3ef8360577767f320059b76


I downloaded the demo yesterday from http://www.penumbra-overture.com/demo.php and clicked on the Atomic Gamer link. I'll try to download from elsewhere later today and report.
04-29-2008 02:26 AM
Find all posts by this user
wari Offline
Junior Member

Posts: 8
Joined: Apr 2008
Reputation: 0
Post: #4
Solved: 1 Year, 7 Months, 3 Weeks, 6 Hours, 32 Minutes, 8 Seconds ago RE: Segfault on installation

Sigh, the one I downloaded from http://www.gameupdates.org/details.php?id=2430 is also an older version. Is there somewhere I can download from that will not give me the old version?
04-29-2008 02:33 AM
Find all posts by this user
wari Offline
Junior Member

Posts: 8
Joined: Apr 2008
Reputation: 0
Post: #5
Solved: 1 Year, 7 Months, 3 Weeks, 6 Hours, 32 Minutes, 8 Seconds ago RE: Segfault on installation

Ok, I'm now downloading from the same site, http://www.gameupdates.org/details.php?id=2429 and the file is 2567 instead of 2553. Can you guys please update your links?
04-29-2008 02:38 AM
Find all posts by this user
wari Offline
Junior Member

Posts: 8
Joined: Apr 2008
Reputation: 0
Post: #6
Solved: 1 Year, 7 Months, 3 Weeks, 6 Hours, 32 Minutes, 8 Seconds ago RE: Segfault on installation

Hmm, that's a Black Plague link, not the Overture. Oh well.
04-29-2008 02:40 AM
Find all posts by this user
wari Offline
Junior Member

Posts: 8
Joined: Apr 2008
Reputation: 0
Post: #7
Solved: 1 Year, 7 Months, 3 Weeks, 6 Hours, 32 Minutes, 8 Seconds ago RE: Segfault on installation

As with the Black Plague:

$ sh PenumbraBlackPlagueDemo-2567.sh
Verifying archive integrity... All good.
Uncompressing nixstaller.........................................................
Collecting info for this system...
Operating system: linux
CPU Arch: x86_64
Warning: No installer for "x86_64" found, defaulting to x86...
Segmentation fault
04-29-2008 02:41 AM
Find all posts by this user
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #8
Solved: 1 Year, 7 Months, 3 Weeks, 6 Hours, 32 Minutes, 8 Seconds ago RE: Segfault on installation

We are bugging the mirrors to get them to put out the updated version.. (not sure why they haven't updated it)

A workaround is to run
sh ./PenumbraOvertureDemo-2553.sh --target PenumbraInstall --noexec
cd PenumbraInstall
rm ./bin/linux/x86/linux.so.6/libstdc++.so.6/gtk.lzma
./starupinstaller.sh

Or for a "less work" workaround.. just run
DISPLAY= sh ./PenumbraOvertureDemo-2553.sh
Though this will run in text mode only.

This issue does NOT exist with the full version installer that you receive when you purchase the game.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
04-29-2008 02:41 AM
Visit this user's website Find all posts by this user
wari Offline
Junior Member

Posts: 8
Joined: Apr 2008
Reputation: 0
Post: #9
Solved: 1 Year, 7 Months, 3 Weeks, 6 Hours, 32 Minutes, 8 Seconds ago RE: Segfault on installation

Thanks, it works now. If only it worked as nice as the Mac version though. Sometimes the demo would run in Window Mode at the full resolution of my monitor, and stops my mouse from working. I have to kill X (ctrl-alt-Backspace) to get my mouse working again. Run it after that, things worked perfectly, run it a second time, have to kill X again.

A similar thing happened when I run the demo on my Compaq Presario F500 laptop with Ubuntu Hardy 32bit installed.
04-30-2008 05:56 AM
Find all posts by this user
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 20
Post: #10
Solved: 1 Year, 7 Months, 3 Weeks, 6 Hours, 32 Minutes, 8 Seconds ago RE: Segfault on installation

hmm.. interesting.. Are you running anything like Compiz? (3d effects) I've noticed it will compiz will sometimes cause those results.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
04-30-2008 01:21 PM
Visit this user's website Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)