Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support | Gametee


Thread Closed 
Installation help
Author Message
xeriouxi Offline
Junior Member

Posts: 1
Joined: Aug 2008
Reputation: 0
Post: #1
Solved: 1 Year, 9 Months, 2 Weeks, 1 Day, 5 Hours, 5 Minutes, 31 Seconds ago Installation help

Hi there!

I would like to say that from what I played of the demo this looks a great game... I'm looking forward to getting the next one after playing this. However I have a query about the installation of the game if I may.

I have the retail installer here and I make sure all my games go into /usr/local/games (I run Ubuntu 8.04) and so I ran the installer using the sudo command.

The game seemed to install just fine, but when I go into the directory it's empty. I assume this is somehow related to root owning the folder maybe, even though it doesn't hide the contents in any other folders from me.

My question is how can I get this working? I know I have to apparently run the game using 'sh penumbra' but do I have to do something like chmod/chown (I'm really new to the commands so I don't know what I'm doing) on the folder, and is this recommended/safe to do? I won't have any issues in the future with this or anything? And I'm stumped on how I do all this if it's the way to do it that is...

Many thanks in advance! =)
08-05-2008 09:06 PM
Find all posts by this user
Urkle Offline
FG - Associate

Posts: 1,172
Joined: Jul 2006
Reputation: 21
Post: #2
Solved: 1 Year, 9 Months, 2 Weeks, 1 Day, 5 Hours, 5 Minutes, 31 Seconds ago RE: Installation help

hmm.. the installer should autodetect if root is needed and ask for the root password when installing. do you have enough free disk space??? You should have at least 2-3 gig free. that is my only thought, as the retail installer is the same as the demo installer.

It still seems odd that it would not show the contents of the directory. Does root see the contents of the directory?? If so just chmod it to fix.

The "chmod" command for the install directory should be (run as root of course)
chmod -R u+rwX,g+rX,o+rX PenumbraOverture

If the directory is really empty, try running the installer not via sudo (the installer will auto detect and switch using sudo if necessary) and if that fails do a full switch to root (su -) and run the installer.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
08-14-2008 03:13 PM
Visit this user's website Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)