Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support | Gametee


Thread Closed 
BlackPlagueDemo crashes on X3100
Author Message
erikderzweite Offline
Junior Member

Posts: 2
Joined: Oct 2008
Reputation: 0
Post: #1
Solved: 1 Year, 9 Months, 2 Weeks, 2 Days, 9 Hours, 43 Minutes, 42 Seconds ago BlackPlagueDemo crashes on X3100

I have some problems starting Black Plague demo on my 64-bit system. Upon start I see disorted white strips as if my monitor doesn't support the resolution. I hear the typing, but after starting logos the game hangs my X along with the keyboard. No errors are reported in the terminal. Tried to change the resolution in config — no effect. Screenshot provided.
[Image: 200810080011531280x800sur6.th.png][Image: thpix.gif]

I use kernel 2.6.26, xorg-x11-7.4, xorg-server-1.5.1, mesa-7.2 and intel drivers-2.4.2-r2 (latest available for my distro atm). All needed 32-bits compatibility libs are installed, tried to start the game in 32-bit chroot — same effect. Other 3D apps work fine. What is the known working configuration for penumbra?
10-07-2008 11:16 PM
Find all posts by this user
Lysius Offline
Junior Member

Posts: 21
Joined: May 2008
Reputation: 0
Post: #2
Solved: 1 Year, 9 Months, 2 Weeks, 2 Days, 9 Hours, 43 Minutes, 42 Seconds ago RE: BlackPlagueDemo crashes on X3100

Can you test it on a pure 32-bit system?
Did you have success with Overture?
At least under Windows there are lots of Problems with Intel graphics accelerators (I have not heard of one that is working, but I may have missed something), so it is likely that Black Plague will not work on your system.
(This post was last modified: 10-10-2008 10:56 PM by sonci.)
10-10-2008 10:55 PM
Find all posts by this user
erikderzweite Offline
Junior Member

Posts: 2
Joined: Oct 2008
Reputation: 0
Post: #3
Solved: 1 Year, 9 Months, 2 Weeks, 2 Days, 9 Hours, 43 Minutes, 42 Seconds ago RE: BlackPlagueDemo crashes on X3100

Lysius Wrote:Can you test it on a pure 32-bit system?
Did you have success with Overture?
At least under Windows there are lots of Problems with Intel graphics accelerators (I have not heard of one that is working, but I may have missed something), so it is likely that Black Plague will not work on your system.

It has worked for me wich ubuntu 8.04 32-bit LiveCD. Didn't test it with 64-bit Ubuntu though. Ouverture Demo — same thing.

The problem might be driver-xorg_server-mesa combination, I wanted to know what is the working configuration. I don't get disorted screen on older driver versions, but I get freezes instead of start menu.

I've read somewhere else in the forum that X3100 works, that's why I ask.
10-11-2008 01:00 AM
Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)