Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support | Gametee


Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Level Editor Help Saved map does not reflect changes
Author Message
PatPeter Offline
Junior Member

Posts: 11
Joined: Mar 2014
Reputation: 0
Post: #1
Saved map does not reflect changes

I edited my user_settings.cfg to automatically load me into a copied 00_rainy_hall.map inside the maps directory of my custom_story. I'm using this map as a sort of sandbox to become better at using the level editor.

The problem is that when I save my map and load it, changes are not reflected. For instance, I am deleting the table, candle, and pot in the starting area. I save the map, load it, and they are still there. Am I doing something wrong in just deleting them? I also deleted my map_cache before loading.

View my master list of Amnesia custom stories: https://docs.google.com/spreadsheets/d/1...2lX6w/edit
03-18-2014 04:19 AM
Find all posts by this user Quote this message in a reply
PutraenusAlivius Offline
Posting Freak

Posts: 4,712
Joined: Dec 2012
Reputation: 119
Post: #2
RE: Saved map does not reflect changes

Well you're probably opening the original 00_rainy_hall map rather than your copied one.

"Veni, vidi, vici."
"I came, I saw, I conquered."
03-18-2014 04:33 AM
Find all posts by this user Quote this message in a reply
Mudbill Offline
Posting Freak

Posts: 3,560
Joined: Apr 2013
Reputation: 167
Post: #3
RE: Saved map does not reflect changes

Yeah, you should rename it or it might just load the one you actually copied.

03-18-2014 10:11 AM
Find all posts by this user Quote this message in a reply
PatPeter Offline
Junior Member

Posts: 11
Joined: Mar 2014
Reputation: 0
Post: #4
RE: Saved map does not reflect changes

You guys were right; it's loading the default map. I renamed my test map but now I am receiving:

FATAL ERROR
FATAL ERROR: Could not load world file 'custom_stories/Test Story/maps/main/ch01/00_test_rainy_hall.map'

My user_settings.cfg has:

<Map File="00_test_rainy_hall.map" Folder="custom_stories/Test Story/maps/main/ch01/" StartPos="" />

I tried using an absolute path:

<Map File="00_test_rainy_hall.map" Folder="C:\Program Files (x86)\Steam\SteamApps\common\Amnesia The Dark Descent\custom_stories\Test Story\maps\main\ch01\" StartPos="" />

And that didn't work.

View my master list of Amnesia custom stories: https://docs.google.com/spreadsheets/d/1...2lX6w/edit
(This post was last modified: 03-19-2014 12:30 AM by PatPeter.)
03-19-2014 12:27 AM
Find all posts by this user Quote this message in a reply
Mudbill Offline
Posting Freak

Posts: 3,560
Joined: Apr 2013
Reputation: 167
Post: #5
RE: Saved map does not reflect changes

Why is it crashing? Post your hpl.log from Documents\Amnesia.

03-19-2014 01:10 AM
Find all posts by this user Quote this message in a reply
PatPeter Offline
Junior Member

Posts: 11
Joined: Mar 2014
Reputation: 0
Post: #6
RE: Saved map does not reflect changes

I figured it out...

http://wiki.frictionalgames.com/hpl2/amn...evenvguide
Quote:In user_settings.cfg, inside the Map element set Folder=”“ to the root folder for your maps (eg Folder=“MyMaps/”), this folder MUST be located inside the maps folder in the game directory (where you put the tools).

I needed to move it into the root maps directory. What's the point of a Folder attribute if it can't point anywhere?

View my master list of Amnesia custom stories: https://docs.google.com/spreadsheets/d/1...2lX6w/edit
03-19-2014 01:23 AM
Find all posts by this user Quote this message in a reply
PutraenusAlivius Offline
Posting Freak

Posts: 4,712
Joined: Dec 2012
Reputation: 119
Post: #7
RE: Saved map does not reflect changes

(03-19-2014 01:23 AM)PatPeter Wrote:  I figured it out...

http://wiki.frictionalgames.com/hpl2/amn...evenvguide
Quote:In user_settings.cfg, inside the Map element set Folder=”“ to the root folder for your maps (eg Folder=“MyMaps/”), this folder MUST be located inside the maps folder in the game directory (where you put the tools).

I needed to move it into the root maps directory. What's the point of a Folder attribute if it can't point anywhere?

You can make it point anywhere you want.

"Veni, vidi, vici."
"I came, I saw, I conquered."
03-19-2014 01:41 AM
Find all posts by this user Quote this message in a reply
PatPeter Offline
Junior Member

Posts: 11
Joined: Mar 2014
Reputation: 0
Post: #8
RE: Saved map does not reflect changes

The wiki says it has to be located in the maps directory in the root of Amnesia. I just moved all the maps to a folder called "test" and it worked perfectly. The gatherer I added is spinning around in circles...

View my master list of Amnesia custom stories: https://docs.google.com/spreadsheets/d/1...2lX6w/edit
(This post was last modified: 03-19-2014 02:19 AM by PatPeter.)
03-19-2014 02:19 AM
Find all posts by this user Quote this message in a reply
PatPeter Offline
Junior Member

Posts: 11
Joined: Mar 2014
Reputation: 0
Post: #9
RE: Saved map does not reflect changes

In case someone really doesn't want to move their custom_story entities back and forth between the custom_story directory and the maps directory, create a symbolic link:

MKLINK /D "D:\Program Files (x86)\Steam\steamapps\common\Amnesia The Dark Descent\maps\brutal" "D:\Program Files (x86)\Steam\SteamApps\common\Amnesia The Dark Descent\custom_stories\Amnesia The Brutal Descent\maps\main"

And set the Folder to the symlink:

<Map File="\ch01\00_rainy_hall.map" Folder="D:\Program Files (x86)\Steam\SteamApps\common\Amnesia The Dark Descent\maps\brutal" StartPos="" />

View my master list of Amnesia custom stories: https://docs.google.com/spreadsheets/d/1...2lX6w/edit
07-18-2015 05:24 PM
Find all posts by this user Quote this message in a reply
Daemian Offline
Posting Freak

Posts: 1,130
Joined: Dec 2012
Reputation: 49
Post: #10
RE: Saved map does not reflect changes

I think you're missing /custom_stories entry from resources.cfg.
That could explain why it's not finding your maps.

PHP Code: (Select All)
<Directory Path="/custom_stories" AddSubDirs="true" /> 

Did you check that?

07-19-2015 05:53 AM
Find all posts by this user Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)