Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
open windows get resized to full height after exiting game
Author Message
myfg Offline
Junior Member

Posts: 5
Joined: Jul 2009
Reputation: 0
Post: #1
Not Solved open windows get resized to full height after exiting game

I normally run 12 virtual desktops and keep a window open on each of them for different purposes. I do not normally keep any of them open to full height of the desktop so i can see icons, widgets, etc. After exiting the game the windows on all my virtual desktops get resized to the full height of the desktop. The width of them does not appear to change. I can change the height on the windows back to smaller size and then start the game and immediately exit it and again they get resized back to the full height of the screen.

i am running kubuntu 9.04 x86_64 with the latest ati catalyst 9.6 fglrx driver. I am using dual radeon hd4550 in crossfirex mode.
07-19-2009 08:39 PM
Find all posts by this user Quote this message in a reply
Urkle Offline
FG - Associate

Posts: 1,154
Joined: Jul 2006
Reputation: 19
Post: #2
Not Solved RE: open windows get resized to full height after exiting game

My guess is this is an issue with the window manager you are using, as i've never encountered that issue before (running 4 virtual desktops myself) Although I use either Compiz or metacity (gnome).

Do you have any strange configuration for KDE that would be causing this and your other issue??

Developing away on one of
Mac Pro Dual 2Ghz, 14GB RAM, 10.6 (still), nVidia 8800 512MB.
Linux, 8-core AMD, 8GB RAM, Fedora 17, nVidia 450 1GB
07-20-2009 02:22 PM
Visit this user's website Find all posts by this user Quote this message in a reply
myfg Offline
Junior Member

Posts: 5
Joined: Jul 2009
Reputation: 0
Post: #3
Not Solved RE: open windows get resized to full height after exiting game

(07-20-2009 02:22 PM)Urkle Wrote:  Do you have any strange configuration for KDE that would be causing this and your other issue??

the only kde related changes i think i made was increased the virtual desktops to 12, added a few widgets on the desktop and added a few additional application icons on the panel. i don't have desktop effects enabled. Unless this problem is maybe something to do with the ati drivers and the dual radeon cards setup in crossfirex with an lcd running at the default 2560x1600 dual link dvi lcd resolution. if anything that would be the "strange" configuration i have done for my install. the game is set to run at a different resolution (the max game resolution 1920x1200) so when exiting the game it initially shows the desktop compressed on the screen (ie the panel which i keep at the bottom appears at around the 3/4 down the screen) within what appears to be the same resolution as the game and then a few seconds later is goes back to the default 2560x1600 resolution.

I am also running a 64bit OS with 32bit libs (my catalyst 9.6 driver is 64bit), so maybe that could be causing some problems. I see another post from today in this forum with problems, but much worse than my situation, running jaunty 64bit with ati graphics.
07-20-2009 03:45 PM
Find all posts by this user Quote this message in a reply
Urkle Offline
FG - Associate

Posts: 1,154
Joined: Jul 2006
Reputation: 19
Post: #4
Not Solved RE: open windows get resized to full height after exiting game

the 64bit drivers w/ the 32bit libs is fine, as that's how those are supposed to work.

You can alter the resolution by editing the settings.cfg that is created in the .frictionalgames/Penumbra/Overture directory and set it to something that more matches your desktop resolution.

Developing away on one of
Mac Pro Dual 2Ghz, 14GB RAM, 10.6 (still), nVidia 8800 512MB.
Linux, 8-core AMD, 8GB RAM, Fedora 17, nVidia 450 1GB
07-20-2009 03:58 PM
Visit this user's website Find all posts by this user Quote this message in a reply
myfg Offline
Junior Member

Posts: 5
Joined: Jul 2009
Reputation: 0
Post: #5
Not Solved RE: open windows get resized to full height after exiting game

(07-20-2009 03:58 PM)Urkle Wrote:  You can alter the resolution by editing the settings.cfg that is created in the .frictionalgames/Penumbra/Overture directory and set it to something that more matches your desktop resolution.

changing the resolution in the settings.cfg to 2560x1600 to match my desktop resolution solved that problem. the game movement still seems fast enough at the higher resolution, so I can leave it set at that resolution. if there is ever an update release, it should include a graphics resolution setting for the current desktop resolution.

thanks!
07-20-2009 07:44 PM
Find all posts by this user Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)