Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support | Gametee


Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with primitives
Author Message
alex3165 Offline
Junior Member

Posts: 3
Joined: Jul 2015
Reputation: 0
Post: #1
Problem with primitives

Hi, I try to make a custom story but I have a weird problem that I can't solve. All the textures have disappeared from level editor and I can't create primitives. What should I do? I have all .mat files in their directories. I can open them with material editor.

Please help me! Smile


Attached File(s)
.jpg  level editor.JPG (Size: 89.71 KB / Downloads: 21)
07-02-2015 07:04 PM
Find all posts by this user Quote this message in a reply
A.M Team Offline
Banned

Posts: 811
Joined: Sep 2014
Post: #2
RE: Problem with primitives

Have you tried editing the admin rights on the redist folder to have it public?
07-02-2015 08:36 PM
Find all posts by this user Quote this message in a reply
DnALANGE Offline
Banned

Posts: 1,550
Joined: Jan 2012
Post: #3
RE: Problem with primitives

Where are the .mat files stored?
Most likely the best thing to do is stoer them in a folder (Textures, just create a new folder for it.)
Put all your .mat files in there WITH the .dds , .tga... or what ever you are using.
-
You can make sub folders, like
Snow_Textures
Rocky_Textures
IjustWantToShowYouHowThisWOrks_Textures Wink
-
Also, did you have your mods name (if isolated Full Conversion) into the Redist/Resources?
The Custom storys has to be in there too for loading your files.
->
PHP Code: (Select All)
<Directory Path="/custom_stories" AddSubDirs="true" /> 
(This post was last modified: 07-02-2015 09:30 PM by DnALANGE.)
07-02-2015 09:29 PM
Find all posts by this user Quote this message in a reply
Slanderous Offline
Posting Freak

Posts: 1,608
Joined: Dec 2012
Reputation: 62
Post: #4
RE: Problem with primitives

I had this issue on my old computer for some time, and to this day I don't know what was it caused by.

I've got a temporary fix for you, though. What you can do, just like I used to do is going to the folder with the texture you wish to select, copy its name, and paste it into "material" text field in the primitives tab.

Made a quick sloppy image for explaining purposes, in case you didn't get what I was rambling about

Spoiler below!
[Image: 4wTsnJg.png]
07-03-2015 01:28 AM
Find all posts by this user Quote this message in a reply
Romulator Offline
G'day mate! :3

Posts: 3,457
Joined: Jan 2013
Reputation: 191
Post: #5
RE: Problem with primitives

(07-02-2015 09:29 PM)DnALANGE Wrote:  
PHP Code: (Select All)
<Directory Path="/custom_stories" AddSubDirs="true" /> 
You may also need this: that is, if your primitives are not in the custom_stories folder.
PHP Code: (Select All)
<Directory Path="/<where_your_textures_are>" AddSubDirs="true" /> 

Just replace "<where_your_textures_are>" with the main directory of where your primitive textures are located if resources.cfg doesn't have them.

Discord: Romulator#4942
07-03-2015 02:23 AM
Find all posts by this user Quote this message in a reply
alex3165 Offline
Junior Member

Posts: 3
Joined: Jul 2015
Reputation: 0
Post: #6
RE: Problem with primitives

Thanks for advices but nothing works... Holy crap!
I've made 3 custom stories and one full conversion mod so far and had no problems with level editor. It started after I formatted my computer.
All I can do now is to copy file names and paste them into "material" text field, as Lazzer said Tongue
Well, it's time to work Big Grin
07-03-2015 09:18 AM
Find all posts by this user Quote this message in a reply
alex3165 Offline
Junior Member

Posts: 3
Joined: Jul 2015
Reputation: 0
Post: #7
RE: Problem with primitives

Solved!

I uninstalled Amnesia TDD and installed it again on C drive, where I have Windows. Then I gave admin rights to the game folder. Now it works. It also solved problem with "Could not load vertex buffer from mesh 'core_box.dae'" in Map View.
07-20-2015 10:05 AM
Find all posts by this user Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)