Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support | Gametee


Thread Closed 
Penumbra Collection installed just fine, won't run
Author Message
EABonney Offline
Junior Member

Posts: 1
Joined: Sep 2015
Reputation: 0
Post: #1
Solved: 1 Year, 7 Months, 3 Weeks, 1 Day, 58 Minutes, 34 Seconds ago Penumbra Collection installed just fine, won't run

I recently installed Penumbra Collection on my Asus Republic of Gamers 15" laptop, which is running the latest version of Kubuntu 14.04 on it. It installed just fine but none of the games will start.

Here is the message I get when I try to run it from the command line:

./penumbra.bin: error while loading shared libraries: libXft.so.2: cannot open shared object file: No such file or directory
Penumbra: Overture exited unexpectedly, please check
/home/eric/.frictionalgames/Penumbra/Overture/hpl.log
for any error messages
Also try running
ulimit -c unlimited
And re-running Penumbra and try and recreate the error
then submit the generated core file or stack trace

I have tried to google the libXft.so.2 library but I can't find anything that seems to work. I am pretty sure this is because I am running the 64bit OS and the game was designed for 32, but I can't get anything more than that.

Anyone have any suggestions?

Thanks,
Eric
09-07-2015 10:51 PM
Find all posts by this user
jens Offline
Frictional Games

Posts: 4,095
Joined: Apr 2006
Reputation: 202
Post: #2
Solved: 1 Year, 7 Months, 3 Weeks, 1 Day, 58 Minutes, 34 Seconds ago RE: Penumbra Collection installed just fine, won't run

You probably need to install 32 bit libraries to make it work. libxft2:i386 as package should do this. There used to be a single 32bit lib package with all needed libs you could install, but I think debian/ubuntu deprecated it. Now you need to install the needed libs one by one.
09-08-2015 06:27 AM
Visit this user's website Find all posts by this user
Googolplex Offline
Banned

Posts: 2,340
Joined: Oct 2008
Post: #3
Solved: 1 Year, 7 Months, 3 Weeks, 1 Day, 58 Minutes, 34 Seconds ago RE: Penumbra Collection installed just fine, won't run

You have latest version (1.1.1) of the collection? That improves compatibility with actual Mac & Linux releases. From where did you get it?
(This post was last modified: 09-08-2015 02:35 PM by Googolplex.)
09-08-2015 02:32 PM
Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)