Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support | Gametee


Thread Closed 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Demo Startup error
Author Message
Helpplz Offline
Junior Member

Posts: 8
Joined: Sep 2010
Reputation: 0
Post: #1
Solved: 1 Year, 8 Months, 2 Weeks, 4 Days, 2 Hours, 31 Minutes, 50 Seconds ago Demo Startup error

Alright so I open the Demo up in steam and i get the settings menu. I choose my settings and then the screen goes black and blackbox or whatever pops up with a message saying

Amnesia.exe started an EXCEPTION_ACCESS_VIOLATION in module <UNKNOWN> at 001B:00000000

Then when i open it up again it says

Last settings crashed the game, falling back to defaults.

Here is the log

-------- THE HPL ENGINE LOG ------------
Engine build ID 20100819012504

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL
Available OpenAL devices:
0. Generic Software on Speakers (Realtek High Definition Audio)(OpenAL default)
Trying to open device 'Generic Software on Speakers (Realtek High Definition Audio)'... Success!
Number of mono sources: 32
Streaming setup: 2 Buffers x 524288 bytes each
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
--------------------------------------------------------

Exiting Gui Module
--------------------------------------------------------
Deleting all sets
Deleting all skins
Deleting all gfx elements
Deleting all materials
--------------------------------------------------------

Exiting Generate Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Scene Module

I want to play so bad Sad
09-04-2010 01:10 AM
Find all posts by this user
Thomas Offline
Frictional Games

Posts: 2,634
Joined: Apr 2006
Reputation: 68
Post: #2
Solved: 1 Year, 8 Months, 2 Weeks, 4 Days, 2 Hours, 31 Minutes, 50 Seconds ago RE: Demo Startup error

The is the wrong hpl.log file. Look in "My Documents/Amnesia/MainDemo"
09-04-2010 01:23 AM
Find all posts by this user
Helpplz Offline
Junior Member

Posts: 8
Joined: Sep 2010
Reputation: 0
Post: #3
Solved: 1 Year, 8 Months, 2 Weeks, 4 Days, 2 Hours, 31 Minutes, 50 Seconds ago RE: Demo Startup error

-------- THE HPL ENGINE LOG ------------
Engine build ID 20100818114615

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Setting video mode: 1024 x 768 - 32 bpp
Init Glew...OK
Setting up OpenGL
Vendor: Intel
Renderer: Intel Cantiga
Version: 1.5.0 - Build 7.15.10.1527
Max texture image units: 16
Max texture coord units: 8
Max user clip planes: 6
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 2
Multisampling: 1
Texture compression: 1
Texture compression S3TC: 1
Auto generate MipMaps: 1
Render to texture: 0
Max draw buffers: 13
Max color render targets: 21
Packed depth-stencil: 0
Texture float: 0
GLSL Version: (null)
ShaderModel 2: 1
ShaderModel 3: 1
ShaderModel 4: 0
OGL ATIFragmentShader: 0
09-04-2010 01:28 AM
Find all posts by this user
Thomas Offline
Frictional Games

Posts: 2,634
Joined: Apr 2006
Reputation: 68
Post: #4
Solved: 1 Year, 8 Months, 2 Weeks, 4 Days, 2 Hours, 31 Minutes, 50 Seconds ago RE: Demo Startup error

See A1:
http://frictionalgames.com/forum/thread-3754.html
09-04-2010 01:29 AM
Find all posts by this user
Helpplz Offline
Junior Member

Posts: 8
Joined: Sep 2010
Reputation: 0
Post: #5
Solved: 1 Year, 8 Months, 2 Weeks, 4 Days, 2 Hours, 31 Minutes, 50 Seconds ago RE: Demo Startup error

Thanks! I had viewed that before but i wanted to make sure it wan the problem before i did all that. Thanks a lot.
Great now I when i start up i get a

FATAL ERROR renderer #0 could not be initialized. Make sure you grahpics drivers are up to date.

I just updated them a moment a go.

Here is the log

-------- THE HPL ENGINE LOG ------------
Engine build ID 20100818114615

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Setting video mode: 1024 x 768 - 32 bpp
Init Glew...OK
Setting up OpenGL
Vendor: Intel
Renderer: Mobile Intel® 4 Series Express Chipset Family
Version: 2.1.0 - Build 8.15.10.2182
Max texture image units: 16
Max texture coord units: 8
Max user clip planes: 6
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 2
Multisampling: 1
Texture compression: 1
Texture compression S3TC: 1
Auto generate MipMaps: 1
Render to texture: 1
Max draw buffers: 8
Max color render targets: 8
Packed depth-stencil: 1
Texture float: 1
GLSL Version: 1.20 - Intel Build 8.15.10.2182
ShaderModel 2: 1
ShaderModel 3: 1
ShaderModel 4: 0
OGL ATIFragmentShader: 0
ATTENTION: System does not support const arrays in glsl!
ERROR: Frame buffer 'Deferred_GBuffer_Main' is not complete! Format is unsupported!
ERROR: Could not create frame buffer for Deferred renderer type: 0!
FATAL ERROR: Renderer #0 could not be initialized! Make sure your graphic card drivers are up to date. Check log file for more information.

Can I not run the game?!
Thanks! I had viewed that before but i wanted to make sure it wan the problem before i did all that. Thanks a lot.
Great now I when i start up i get a

FATAL ERROR renderer #0 could not be initialized. Make sure you grahpics drivers are up to date.

I just updated them a moment a go.

Here is the log

-------- THE HPL ENGINE LOG ------------
Engine build ID 20100818114615

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Setting video mode: 1024 x 768 - 32 bpp
Init Glew...OK
Setting up OpenGL
Vendor: Intel
Renderer: Mobile IntelĀ® 4 Series Express Chipset Family
Version: 2.1.0 - Build 8.15.10.2182
Max texture image units: 16
Max texture coord units: 8
Max user clip planes: 6
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 2
Multisampling: 1
Texture compression: 1
Texture compression S3TC: 1
Auto generate MipMaps: 1
Render to texture: 1
Max draw buffers: 8
Max color render targets: 8
Packed depth-stencil: 1
Texture float: 1
GLSL Version: 1.20 - Intel Build 8.15.10.2182
ShaderModel 2: 1
ShaderModel 3: 1
ShaderModel 4: 0
OGL ATIFragmentShader: 0
ATTENTION: System does not support const arrays in glsl!
ERROR: Frame buffer 'Deferred_GBuffer_Main' is not complete! Format is unsupported!
ERROR: Could not create frame buffer for Deferred renderer type: 0!
FATAL ERROR: Renderer #0 could not be initialized! Make sure your graphic card drivers are up to date. Check log file for more information.

Can I not run the game?!

(It said i didnt made a new post so im trying it again.
(This post was last modified: 09-04-2010 02:19 AM by Helpplz.)
09-04-2010 01:32 AM
Find all posts by this user
Helpplz Offline
Junior Member

Posts: 8
Joined: Sep 2010
Reputation: 0
Post: #6
Solved: 1 Year, 8 Months, 2 Weeks, 4 Days, 2 Hours, 31 Minutes, 50 Seconds ago RE: Demo Startup error

I've reinstalled the driver again. Still, its the exact same story.
09-04-2010 02:57 AM
Find all posts by this user
iral Offline
Junior Member

Posts: 14
Joined: Sep 2010
Reputation: 0
Post: #7
Solved: 1 Year, 8 Months, 2 Weeks, 4 Days, 2 Hours, 31 Minutes, 50 Seconds ago RE: Demo Startup error

The problem is " Mobile IntelĀ® 4 Series Express Chipset Family".

This chipset is too weak to run the game.
09-04-2010 07:53 AM
Find all posts by this user
Jellyfush Offline
Junior Member

Posts: 1
Joined: Nov 2010
Reputation: 0
Post: #8
Solved: 1 Year, 8 Months, 2 Weeks, 4 Days, 2 Hours, 31 Minutes, 50 Seconds ago RE: Demo Startup error

i have the same problem Sad is there a way to fix it?
11-08-2010 06:19 AM
Find all posts by this user
jens Offline
Frictional Games

Posts: 4,095
Joined: Apr 2006
Reputation: 202
Post: #9
Solved: 1 Year, 8 Months, 2 Weeks, 4 Days, 2 Hours, 31 Minutes, 50 Seconds ago RE: Demo Startup error

No sorry, that Intel chip is below minimum requirements.
11-08-2010 06:55 AM
Visit this user's website Find all posts by this user
Lioner5 Offline
Junior Member

Posts: 2
Joined: Dec 2010
Reputation: 0
Post: #10
Solved: 1 Year, 8 Months, 2 Weeks, 4 Days, 2 Hours, 31 Minutes, 50 Seconds ago RE: Demo Startup error

I have the same problem except mine is with the actual game.


Version 1.10
-------- THE HPL ENGINE LOG ------------
Engine build ID 20100818114615

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init lowlevel graphics: 1366x768 bpp:32 fs:1 ms:0 gpufmt:2 cap:'Amnesia - The Dark Descent - Loading...' posSad-1x-1)
Setting video mode: 1366 x 768 - 32 bpp
Init Glew...OK
Setting up OpenGL
Vendor: Intel
Renderer: Intel® HD Graphics
Version: 2.1.0 - Build 8.15.10.2189
Max texture image units: 16
Max texture coord units: 8
Max user clip planes: 6
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 2
Multisampling: 1
Texture compression: 1
Texture compression S3TC: 1
Auto generate MipMaps: 1
Render to texture: 1
Max draw buffers: 8
Max color render targets: 8
Packed depth-stencil: 1
Texture float: 1
GLSL Version: 1.20 - Intel Build 8.15.10.2189
ShaderModel 2: 1
ShaderModel 3: 1
ShaderModel 4: 0
OGL ATIFragmentShader: 0
ATTENTION: System does not support const arrays in glsl!
Setting up G-Bugger: type: 0 texturenum: 3
ERROR: Frame buffer 'Deferred_GBuffer_Main' is not complete! Format is unsupported!
ERROR: Could not create frame buffer for Deferred renderer type: 0!
FATAL ERROR: Renderer #0 could not be initialized! Make sure your graphic card drivers are up to date. Check log file for more information.
12-17-2010 02:33 AM
Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)