Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Thread Closed 
 
Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Annoying Amnesia The Dark Descent graphics glitch
Author Message
caseystryker Offline
Junior Member

Posts: 15
Joined: Sep 2010
Reputation: 0
Post: #1
Solved: 9 Months, 2 Weeks, 6 Days, 15 Hours, 13 Minutes, 10 Seconds ago Annoying Amnesia The Dark Descent graphics glitch

I'm running Windows 7 64bit with a ATI Radeon 5830.

When I play I can see candle light emitting through the walls. I've done everything I can think of. I've updated drivers, reinstalled the game and turned all graphics options off and lowered the resolution but still can't seem to fix it. I've even gone into the Catalyst Control Center and set all options to application settings controlled. Anybody else experience this issue?

Here is a short clip of what I'm experiencing.
Video
09-05-2010 07:47 AM
Find all posts by this user
jens Offline
Frictional Games

Posts: 3,593
Joined: Apr 2006
Reputation: 174
Post: #2
Solved: 9 Months, 2 Weeks, 6 Days, 15 Hours, 13 Minutes, 10 Seconds ago RE: Annoying Amnesia The Dark Descent graphics glitch

When updating the drivers, did you first uninstall, reboot the computer and then install the new drivers? If not, please try that as it is crucial in order to make sure all files are replaced.
09-05-2010 10:16 AM
Visit this user's website Find all posts by this user
caseystryker Offline
Junior Member

Posts: 15
Joined: Sep 2010
Reputation: 0
Post: #3
Solved: 9 Months, 2 Weeks, 6 Days, 15 Hours, 13 Minutes, 10 Seconds ago RE: Annoying Amnesia The Dark Descent graphics glitch

Yes, I even ran Driver Sweeper to delete any missed files.
09-05-2010 10:32 AM
Find all posts by this user
membrain Offline
Junior Member

Posts: 40
Joined: Sep 2010
Reputation: 0
Post: #4
Solved: 9 Months, 2 Weeks, 6 Days, 15 Hours, 13 Minutes, 10 Seconds ago RE: Annoying Amnesia The Dark Descent graphics glitch

Hi caseystryker,

Did you install Direct X 9 and 10 after installing Win 7? Usually you have to do so because Win 7 only has DX11 preinstalled. That's why some games don't work at all on a fresh 7 system.
Another way to fix the glitch could be a modded driver. They are available at http://downloads.guru3d.com/Videocards--...9_c24.html. And if this doesn't help, try setting all Catalyst-Settings to high.

And if the glith still remains update the drivers for your mainboard too.

membrain
09-05-2010 11:53 AM
Find all posts by this user
Thomas Offline
Frictional Games

Posts: 2,456
Joined: Apr 2006
Reputation: 44
Post: #5
Solved: 9 Months, 2 Weeks, 6 Days, 15 Hours, 13 Minutes, 10 Seconds ago RE: Annoying Amnesia The Dark Descent graphics glitch

This must be a driver bug of some sort and the problem is that occlusion queries does not seem to work. This is very serious as it is a central part of the engine.

Have you tried turning off Windows Aeon in case you have that?

Also, when updating drivers, did you download them from the ATI site?

Could you please also try the compatibility test here:
http://frictionalgames.com/forum/thread-3656.html

And post a link to the post you made. This will be very helpful for any debugging.
(This post was last modified: 09-05-2010 02:41 PM by Thomas.)
09-05-2010 02:39 PM
Find all posts by this user
caseystryker Offline
Junior Member

Posts: 15
Joined: Sep 2010
Reputation: 0
Post: #6
Solved: 9 Months, 2 Weeks, 6 Days, 15 Hours, 13 Minutes, 10 Seconds ago RE: Annoying Amnesia The Dark Descent graphics glitch

Yep, I've turned off all special Windows effects and I'm currently using the Windows classic theme. The drivers are the official AMD/ATI Catalyst 10.8 drivers downloaded straight from their site.

Heres a link

http://frictionalgames.com/forum/thread-...l#pid31920

@membrain: Thanks for the suggestions, but I've got DX9 and 10 on my system already. Also, I'm somewhat leery about using anything but the official drivers. What are some of the advantages these modded drivers offer over the official release drivers?
09-05-2010 06:33 PM
Find all posts by this user
Thomas Offline
Frictional Games

Posts: 2,456
Joined: Apr 2006
Reputation: 44
Post: #7
Solved: 9 Months, 2 Weeks, 6 Days, 15 Hours, 13 Minutes, 10 Seconds ago RE: Annoying Amnesia The Dark Descent graphics glitch

Hmm, how strange...The compatibility test seems to be working (I checked log and halo rendering output is as it should)...

Just to check:
Do you get the problem when fullscreen is off?
Try turning off all post effects (ingame in graphics/advanced) and ssao and see what happens.
(This post was last modified: 09-05-2010 11:49 PM by Thomas.)
09-05-2010 11:48 PM
Find all posts by this user
caseystryker Offline
Junior Member

Posts: 15
Joined: Sep 2010
Reputation: 0
Post: #8
Solved: 9 Months, 2 Weeks, 6 Days, 15 Hours, 13 Minutes, 10 Seconds ago RE: Annoying Amnesia The Dark Descent graphics glitch

I still have the problem with fullscreen turned off. I've turned off all post effects and cycled through all the resolutions but still have the problem.
09-06-2010 05:25 AM
Find all posts by this user
Thomas Offline
Frictional Games

Posts: 2,456
Joined: Apr 2006
Reputation: 44
Post: #9
Solved: 9 Months, 2 Weeks, 6 Days, 15 Hours, 13 Minutes, 10 Seconds ago RE: Annoying Amnesia The Dark Descent graphics glitch

Very strange... especially since the test seem to work!!

Do you have a laptop btw?

The only other strange thing is that your driver version is 4.0, whereas my is 3.3 when using 10.8 drivers.
09-06-2010 06:48 AM
Find all posts by this user
caseystryker Offline
Junior Member

Posts: 15
Joined: Sep 2010
Reputation: 0
Post: #10
Solved: 9 Months, 2 Weeks, 6 Days, 15 Hours, 13 Minutes, 10 Seconds ago RE: Annoying Amnesia The Dark Descent graphics glitch

Nope, it's a desktop. These are the specs.

AMD Phenom II X4 965 Black Edition @3.4GHz
Corsair H50 Cooler
ASRock M3A770DE AM3 Motherboard
G.Skill Ripjaws Series 4GB DDR3 1600 Memory
Sapphire Radeon HD 5830 1GB OC@970MHz/1250MHz
Windows 7 Home Premium 64Bit

I even tried lowering my gpu to stock speeds but still have the same issue. I'm at a loss. And yeah, that driver version is a bit strange.
09-06-2010 07:06 AM
Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)