Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Thread Closed 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[split] Running game on cards only supporting GLSL 1.1
Author Message
NeonMan Offline
Junior Member

Posts: 1
Joined: Nov 2010
Reputation: 0
Post: #1
Solved: 8 Months, 3 Weeks, 2 Days, 6 Hours, 9 Minutes, 44 Seconds ago [split] Running game on cards only supporting GLSL 1.1

I've bought the Amnesia game a few days ago, too good to miss it Tongue, but I'm having problems with one of my computers.

It works flawlessly on a Radeon HD 4290 but it fails to load on an old x1200

Taking a look at the shaders' code, they're coded on GLSL 1.2 BUT some ATI x1??? only support OpenGL 2.0 with GLSL 1.1

To test wether your card suppor GLSL 1.2 (most cards should) you could do as I did. From the opengl.org wiki, download GPU Caps to get all the info from your GPU. (http://www.opengl.org/wiki/Getting_start...GL_Viewers)

As a workarround, is it possible to run a on a 'shaderless' mode?
would it change the gameplay too much?
<edit>
Using windows, on linux I get a segment violation error but I use it mostly for (headless) programming
</edit>
(This post was last modified: 11-05-2010 03:45 PM by NeonMan.)
11-05-2010 03:28 PM
Find all posts by this user
Thread Closed 




User(s) browsing this thread: 1 Guest(s)