Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] Error: Couldn't find any suitable frontend for your system
Author Message
CowardlyLion Offline
Junior Member

Posts: 2
Joined: Apr 2011
Reputation: 0
Post: #1
Not Solved [Solved] Error: Couldn't find any suitable frontend for your system

I've been running the three Penumbra games without problems since the $5 special offer so I didn't hesitate to buy Amnesia the moment I heard about it. However, it won't install on my computer. I'm running Fedora 14, KDE, proprietary NVidia drivers, RPMFusion enabled but nothing unusual installed, on a 32-bit machine: dual-core 3GHz Pentium 4 with 4GB RAM (3.3G available) and about 450GB disk.

Running the installer results in:

/home/chris/Downloads/amnesia_tdd_1.0.1.sh
Verifying archive integrity... All good.
Uncompressing Installer for Amnesia - The Dark Descent.............
Uncompressing sub archive.........................................................................​......................................................................
Collecting info for this system...
Operating system: linux
CPU Arch: x86
lddlibc4: cannot read header from `bin/linux/x86/libc.so.6/gtk'
lddlibc4: cannot read header from `bin/linux/x86/libc.so.6/fltk'
lddlibc4: cannot read header from `bin/linux/x86/libc.so.6/ncurs'
Error: Couldn't find any suitable frontend for your system



I can't find any reports of exactly this situation, but the most similar suggest checking for a 32-bit libc 6. I am certain that I have that, it's a 32-bit machine and Fedora 14 has libc 6.

file -L /usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped


I tried running the installer with the --unattended flag to tell it not to bother with any of the front ends, but that also failed.

Wondering whether the archive was somehow damaged (unlikely, given the "verifying integrity" message) I downloaded it from Frictional anew. I get exactly the same result with the new copy.

Any help would be gratefully received!

Many thanks.
Chris R.
(This post was last modified: 04-27-2011 02:20 PM by Urkle.)
04-27-2011 07:46 AM
Find all posts by this user Quote this message in a reply
CowardlyLion Offline
Junior Member

Posts: 2
Joined: Apr 2011
Reputation: 0
Post: #2
Not Solved Solved: RE: Error: Couldn't find any suitable frontend for your system

Just to follow up my own post for anyone else searching this, the problem was not enough free space in /tmp (had only 1.7GB, installer needed 1.9GB). Telling it to use /var/tmp instead allowed it to install.

TMPDIR=/var/tmp /home/chris/Downloads/amnesia_tdd_1.0.1.sh

Regards,
Chris R.
04-27-2011 09:15 AM
Find all posts by this user Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)