Facebook Twitter YouTube Frictional Games | Forum | Newsletter | Dev Blog | Dev Wiki | Support


Post Reply 
 
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Custom Story Gone Missing
Author Message
WatzUpzPeepz Offline
Member

Posts: 106
Joined: May 2011
Reputation: 0
Post: #11
RE: Custom Story Gone Missing

(06-10-2011 02:43 AM)palistov Wrote:  Here's a thread I found regarding the .map extension: here

Basically, the .map file is really just a text file that explicitly details the position and attributes of every object in your level. You can even open it up in your text editor and modify it, as I often do to edit multiple objects at once.

As for your missing map files, I am clueless. Sorry Sad

Wow,thats mind bending lol.

06-10-2011 06:47 PM
Find all posts by this user Quote this message in a reply
xtron Offline
Senior Member

Posts: 402
Joined: May 2011
Reputation: 2
Post: #12
RE: Custom Story Gone Missing

I don't know if it's solved but I if I got you right...here's how to fix so you can see your map file in your maps folder.

1: go to the controlpanel

2: make sure your in the "category" view then click on the "Appearance and Personalization" link

3: Under the Folder Options category, click on Show Hidden Files or Folders.

4: Under the Hidden files and folders section select the radio button labeled Show hidden files,
folders, or drives.

5: Remove the checkmark from the checkbox labeled Hide extensions for known file types.

6: Remove the checkmark from the checkbox labeled Hide protected operating system files
(Recommended).

7: Press the Apply button and then the OK button..

[Image: 44917299.jpg]Dubstep <3
06-10-2011 10:47 PM
Find all posts by this user Quote this message in a reply
JenniferOrange Offline
Senior Member

Posts: 424
Joined: Jun 2011
Reputation: 33
Post: #13
RE: Custom Story Gone Missing

(06-10-2011 10:47 PM)xtron Wrote:  I don't know if it's solved but I if I got you right...here's how to fix so you can see your map file in your maps folder.

1: go to the controlpanel

2: make sure your in the "category" view then click on the "Appearance and Personalization" link

3: Under the Folder Options category, click on Show Hidden Files or Folders.

4: Under the Hidden files and folders section select the radio button labeled Show hidden files,
folders, or drives.

5: Remove the checkmark from the checkbox labeled Hide extensions for known file types.

6: Remove the checkmark from the checkbox labeled Hide protected operating system files
(Recommended).

7: Press the Apply button and then the OK button..

Thankyou for the tip, I'm happy to say I just turned my UAC (User Account Control) off because Vista was being really.. mean. Tongue I can now see my maps, though they're still unplayable.
For everyone trying to help me through this thankyou, and I have some new information ...
This morning I logged onto my computer and found an error text document on my desktop. It's named 'hpl.log'. Opening it, it says:
'ERROR: Unable to open config file 'MainEditorSettings.cfg'! Invalid filepointer returned!'
I have no idea what this means.. after a little researched I managed to dig up what 'invalid filepointer returned' means. It says this problem came up with a few Steam users, except it was a different file that was messing up. Pretty much repliers said the person could have a corrupted game. Is it possible that my Level Editor is corrupted?
I also want to add that I've been having problems downloading custom stories. Last time I tried I got a message that said it couldn't download the file. Maybe I'm running out of drive space..
Last thing, my brother the techwizard and I are going to upgrade my laptop to Windows 7, and I'm going to uninstall any big applications I have. I'll keep you posted. Thanks for the help. Heart
I have a request for anyone who can get their own custom_stories working properly..
could you post whats inside your MainEditorSettings.cfg? I have a feeling there's something wrong with mine and I'd like to see what everyone else has. It should be in your redist folder. For Steam users I believe it's just in the main folder? Not sure.
Thank you so much.

Ba-da bing, ba-da boom.
(This post was last modified: 06-11-2011 12:42 AM by JenniferOrange.)
06-11-2011 12:09 AM
Find all posts by this user Quote this message in a reply
Russ Money Offline
Senior Member

Posts: 360
Joined: Dec 2010
Reputation: 4
Post: #14
RE: Custom Story Gone Missing

<Directories EditorHomeDir="HPL2" EditorTempDir="Temp" ThumbnailsDir="Thumbnails" MapsDir="maps" StaticObjectsDir="static_objects" EntitiesDir="entities" LightsDir="lights" BillboardsDir="billboards" ParticlesDir="particles" SoundsDir="sounds" />

06-11-2011 01:25 AM
Find all posts by this user Quote this message in a reply
JenniferOrange Offline
Senior Member

Posts: 424
Joined: Jun 2011
Reputation: 33
Post: #15
RE: Custom Story Gone Missing

(06-11-2011 01:25 AM)Russ Money Wrote:  
<Directories EditorHomeDir="HPL2" EditorTempDir="Temp" ThumbnailsDir="Thumbnails" MapsDir="maps" StaticObjectsDir="static_objects" EntitiesDir="entities" LightsDir="lights" BillboardsDir="billboards" ParticlesDir="particles" SoundsDir="sounds" />

Thank you very much! Smile I'm assuming this is what's in your folder. I don't have my laptop with me currently as I'm on vacation but thank you so so much, I'll check this out when I get home!

Ba-da bing, ba-da boom.
06-16-2011 12:25 AM
Find all posts by this user Quote this message in a reply
fesoj1337 Offline
Junior Member

Posts: 11
Joined: Mar 2011
Reputation: 0
Post: #16
RE: Custom Story Gone Missing

(06-10-2011 03:36 AM)JenniferOrange Wrote:  
(06-10-2011 03:29 AM)palistov Wrote:  Yep that's correct. I guess that's not the issue. What exactly is the error you get when you open your map?

So first I get multiple errors that say:
Could not find data folder: maps/
Could not find data folder: static_objects/
Could not find data folder: entities/
Could not find data folder: lights/
Could not find data folder: billboards/
Could not find data folder: particles/
Could not find data folder: sounds/
Could not find data folder: textures/decals/

Then my Level Editor opens with another error message that says:
FATAL ERROR: Could not load vertex buffer from mesh 'core_box.dae'
and then it crashes.
Note: I tried changing the program the map opens to to Amnesia.exe, and this error comes up every time I attempt to change it back to Level Editor.

i had alot of problems with level editor aswell, im on windows 7 ultimate 64bit, and this worked for me, try reinstalling the game, get the HPL suite and then update the game, try and update every driver

that worked for me so good luck

and to get the map to show up in the actual game, i suggest you follow this guys 3 tutorials
http://www.youtube.com/watch?v=mmgPJ2Hf-...re=related
thats part 1, 2 and 3 are in the right bar
06-28-2011 12:41 PM
Find all posts by this user Quote this message in a reply
JenniferOrange Offline
Senior Member

Posts: 424
Joined: Jun 2011
Reputation: 33
Post: #17
RE: Custom Story Gone Missing

-SOLVED-
If you're experiencing this problem, download someone else's custom story and re-configure it to your own stuff. Don't forget to delete the mapcache file if it's there. Good luck!

Ba-da bing, ba-da boom.
06-28-2011 10:54 PM
Find all posts by this user Quote this message in a reply
fickledorf Offline
Junior Member

Posts: 3
Joined: Jul 2012
Reputation: 0
Post: #18
RE: Custom Story Gone Missing

(06-28-2011 10:54 PM)JenniferOrange Wrote:  -SOLVED-
If you're experiencing this problem, download someone else's custom story and re-configure it to your own stuff. Don't forget to delete the mapcache file if it's there. Good luck!
Sorry, I'm having the same problem, I know this is solved, but what do you mean to "re-configure it to your own stuff?" Also, what's the mapcache file?
07-23-2012 03:13 AM
Find all posts by this user Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)