Frictional Games Forum

Full Version: FATAL ERROR - Could not load world file 'maps/main/owed'
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm using a Mac OS X Version 10.8.5 laptop. Processor is 2.5 GHz Intel Core i5. Graphics card is Intel HD Graphics 4000 512 M.

Got my game on Steam. I click Play or click the game shortcut on my desktop to start it. I get to the main menu of the game and click Start New Game. It fades to black, then quits and gives me the fatal error message.

I've seen lots of topics like this, but they all seem to be for Microsoft users only. I could be mistaken, though. I read through the steps of those topics and am not sure how they're done on a Mac. I could use some help.
Try this

- Turn off cloud sync in Steam. Right-click the game and select
Properties -> Updates -> Enable Steam Cloud synchronization and
untick it

- Delete main_config.cfg from "~/Library/Application Support/Frictional Games/Amnesia/Pig" and start the game from Steam, make sure to select running the launcher and not the game directly.
Can you also check the properties of the game in steam and ensure there are no extra command line parameters specified? As any command line argument is interpreted as a map name for starting a new game.
jens - Did the first step. Not sure what you mean with the second step. Where do I do that at? On Steam? My computer? Could you be more specific about how to do that?

Urkle - Could you explain in detail where and how that's done?
I'm referring to the "Game Launch Options" in steam itself.. As it sounds like somehow the launch options got set..

  1. Right-click on the game title under the Library in Steam and select Properties.
  2. Under the General tab click the Set launch options... button.
And as for the "~/Library/blah blah" that jens mentioned.. on OS X (and Linux) ~ refers to "my home directory".. So.. basically open up finder and press "apple-shift-G" a box will appear asking you to "goto". enter the path Jens mentioned. (Lion and higher apple hides the Library folder by default).
Cool, cool. Okay, I got to where JENS told me to go. I have "first_start_flag", "hpl.log", "main_settings.cfg", and three folders which are profiles I tried in the main menu of the game (two contain "user_keys.cfg" and "user_settings.cfg". I don't see "main_config.cfg".

Meanwhile, I did just as you said and went to Set Launch Options. It says "-windowed" in the type box (which may be my fault when I was trying to figure out how to window the game rather than have it full screen). So, there's that.

What should I do next? (thank you for taking the time to help, btw. it means so much to me.)
I meant main_settings.cfg sorry Smile

Removed the -windowed and try launching the game without it. You can use the launcher (the second launch option in Steam) to configure the game before starting it, it has a FullScreen option you can turn off.
Omigosh. It worked! It at least got past the main menu and started the game. I won't be playing it through just yet, but I'll let you know how it functions. THANK YOU SO MUCH!