Frictional Games Forum

Full Version: Model viewer won't create .msh file
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
It has been a while since I last implemented anything new into Amnesia.
Today I tried converting a custom model for a mod I'm working on. I managed to create .png textures in binary sizes and exported the model as Collada 1.4 .dae format.

As you can see, the model opens up fine within the model viewer:
[Image: BR1wip.jpg]

As soon as the model is opened, the .mtl files are created as supposed, but for some unknown reason the viewer won't create any .msh file of the object.
I tried using different texture sizes or export settings but that changes nothing.

Can anyone help me with this?
I think msh files are created when the model is opened in-game.
(12-24-2013, 11:47 PM)JustAnotherPlayer Wrote: [ -> ]I think msh files are created when the model is opened in-game.

No they are created by the model viewer, though in-game might do it as well
The game might not create .msh files if there are problems with the model. Is there any complaints listed in your hpl.log or modelview.log?
I think .msh are created every time any amnesia tool reads the .dae
Only if there's no .msh or dates with the .dae are different.
You should check what Acies said.
I didn't notice the viewer log before. When I opened it there was a long lists of bad normals. These were so small that I didn't notice them on the model. Once I simply used the modeling tool's optimization function, all bad normals were gone and the .msh file has been created!

The model now works fine:
[Image: 2013-12-25_00002.jpg]

Thanks a lot for the help. you guys are great!