Frictional Games Forum

Full Version: Crash when loading saved game and new maps
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I was experiencing crashes when entering the archives, and am now experiencing them when loading a saved game. Occasionally I'm able to load game, and then I proceed to the archives and haven't gotten further than that without crashing Sad. hpl.log attached.

Amnesia is installed to my home directory, and I've tried running it with sudo. So I'm pretty sure its not read/write permissions, as it is in other people's issues.

I'm on 64 bit Ubuntu 10.04 with the ATI proprietary driver for a Radeon HD 4350. The driver is slightly newer than the one in the standard repositories, its from the 'x-updates' ppa and is fglrx version 2:8.672. I would think that any difference due to that would be a positive one, but hey.

Game saved and loaded fine before I got to the archives, now no love.

I would appreciate any suggestions anyone might have.

[attachment=470]
it seems others are also encountering crashes when running the 64bit version of the game.. Can you send me a saved game and instructions to recreate the issue?

Afterwards, you can run the 32bit version of the game as that doesn't seems to have the crash bug. (linux32 ./amnesia_tdd_1.0.sh to install)

If you install it overtop your existing install you will have both the 32bit and 64bit binaries installedSmile
(09-09-2010, 03:28 PM)Urkle Wrote: [ -> ]it seems others are also encountering crashes when running the 64bit version of the game.. Can you send me a saved game and instructions to recreate the issue?
I will send you mine too :-). Eh, if I know how... 1.7MB

X_ChangeProperty: BadValue (integer parameter out of range for operation) 0x0
is the last thing I see :-(.
Loading the save game in my case crashes before entering the map. So it's after the magnification of the normal screen, and then just right after the showing that circle thing.
Unfortunately now I'm unable to get even that far. I uninstalled and reinstalled and now get a crash when the first map loads (new profile - having deleted .frictional/Amnesia prior to reinstall).

I could give you a save file but I now don't think it's relevant, it's just crashing during maps loading full stop. But if you still want it give me an email address and I'll send it, since its too big to upload here.

I'll try to recreate the problem in a fresh Ubuntu install/live session and see if it still exists. I can't think why the game ran previously and then got crashy despite reinstalling, unless it is something specific to my computer.
I'm also having the same problem with the 64bit version Dodgy
Strangely, the 32bit version works great... Exclamation
(09-09-2010, 03:28 PM)Urkle Wrote: [ -> ]it seems others are also encountering crashes when running the 64bit version of the game.. Can you send me a saved game and instructions to recreate the issue?
I'm a me too (64 bit):
* Start game,
* select profile
* Load savegame
Result: segfault (hpl.log).
I've also attached the user settings, just in case.

Unfortunately, the 32 bit version crashes instantaneously (launcher.log attached) even after moving the .frictionalgames/Amnesia directory of the 64 bit version out of the way. Starting the Amnesia.bin executable directly also crashes.

System: Gentoo Linux 64 bit
Graphics: ATI 4850, driver frglx 10.8
The game is installed in my home directory.

best
Gert
Here, Ubuntu 10.04 AMD64 + Nvidia 9800M GTX + 195.36.24 drivers.
It turned out Amnesia frequently crashes when loading a savegame (for instance, when choosing the first option - resume game - in the main menu. Also once in a while when quitting and saving the game. I had no such crash in the demo version. I think I had similar issues when I was running the 32 bits version under the Maverick beta.

I'll try to send you a log as well :-)
Cheers & thanks for this amazing game !
The backtraces I get with above savegame ...