Frictional Games Forum

Full Version: the penumbra collection won't launch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there!

I played overture, now I'm trying to finish black plague. The game was running fine until today: It doesn't launch anymore!

I tried overture and requiem, same problem. Launching them trough the terminal is not more succesfull as the terminal suddenly close as fast as it open...

I tried to install the whole collection again, but no luck the problem is the same. I really don't know what happended and what should I do to correct it!

Please I'm completly mad about that game, hope I can finish it!
open up a terminal and goto the game install directory and run the "./penumbra" or "./blackplague" script from the terminal.

And tell me what it does there? Also provide copies of your hpl.log files from the ~/.frictionalgames/Penumbra/Overture and ~/.frictionalgames/Penumbra/BlackPlague folders.
So, here what I got:


Segmentation fault
Penumbra: Black Plague exited unexpectedly, please check
/home/olivier/.frictionalgames/Penumbra/Black Plague/hpl.log
for any error messages
Also try running
ulimit -c unlimited
And re-running Penumbra and try and recreate the error
then submit the generated core file or stack trace

And here is my hpl.Log:

-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 1360 x 768 - 32 bpp
ERROR: Could not set display mode setting a lower one!
FATAL ERROR: Unable to initialize display!


Seems like I've got some video troubles.... Just need to figure out what's wrong!

Thanks for the support, It's a big help.
Okay, I found the problem. My nvidia driver are messed up.

Thanks for your help, you can close the topic!