Frictional Games Forum

Full Version: Penumbra: Black Plague Mental State bug
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm playing the latest version of Penumbra: Black Plague, the windows version, using Wine. I'm using PlayOnLinux with Wine 3.0, I can't remember which libraries I installed but I'm pretty sure there are no problems there as I played through Overture successfully and Black Plague was working perfectly until the bug I ran into.

Anyways, the game was working great (and Overture gave me no problems) until I got to the sewers and the game forced me into the "mental state" sublevel. After rearranging the room, putting the egg on the table and then the dog corpse onto the hands the game glitches up when it's supposed to show the hands and the dog being sucked into the wall and you have to run through the door to get to the hallway with the hands you interact with. Instead as the dog starts to be sucked away, the screen flashes white and you're teleported inside the doorway, stuck inside the wall unable to move and the game starts making loud sounds, collision sounds I believe and the game just gets laggier and laggier as it tries to resolve this situation unsucessfully. I managed to bypass this problem by installing the game on a windows computer, copying my save over and continuing, however I ran into a bug on windows aswell. After the section with the moving platforms you have to jump across, there is a section where there are several barricades and a hallway you need to run down. After running down that hallway the game transports me back to the ship cabin room and forced the camera to look at the ceiling. Any mouse movement briefly moves the camera, but then it always centers itself on the ceiling, making the game unplayable. I copied my save file back to my linux computer and redid the section with the barricades, which then takes me back to the ship cabin and doesn't force the camera to the ceiling, however the only thing I can do is to change the room so it's not like the photo and then put it back, which causes a glitched up scene in the cabin room and a hole in the wall that you can fall into oblivion. I looked up a video walkthrough and it seems that after the section with the two barricades you're supposed to be transported to a room with water and crates and not the ship cabin, yet on both windows and linux it is taking me back to the ship cabin. I'm really not sure how to solve this issue as the game isn't taking me to the next section properly, does anyone have any suggestions?

Btw I found a review for the game on steam that mentions the game is unplayable on Wine due to the mental state being incompletable, but they didn't elaborate on their issue.
Where did you get the game ? Seems like a script bug rather than an engine/hardware issue.
My wife bought it from
I brought up the issue somewhere else, unfortunately noone really has any idea how to help you - Penumbra is really old, not customer-friendly at all and not many from the FG community members are fans of the Penumbra games.

In my opinion, the best thing you could do is download a save from after the place you bugged out at.
I found this page, maybe it's ok, maybe you will need to dig deeper:

As I said, not the perfect solution, but at least you will be able to play the rest of the game.
If anyone has more ideas, I'll make sure to keep you posted.
I'll get this forwarded off to the FG community manager and see if they can get in touch with one of the Penumbra peeps.
Thanks for tagging me, Rom!

It sounds like it's a Wine issue indeed. Darkfire's suggestion to get a previous save sounds like the most plausible solution.
Thanks for looking into it! It probably is a wine issue, but it's so strange since I was having no issues at all up until that point, maybe there is some obscure thing in the scripting that wine doesn't like for some reason.

Darkfire, that is a great idea, I hadn't thought of that. I'll see if I can get a save after that part and just watch what I missed on a youtube walkthrough and hopefully the rest of the game is playable. Thanks for the suggestion! As long as I can continue on, I'm happy Smile
Hello chanser69,

It's sad that GOG doesn't offer the GNU/Linux release.
If you have some kind of proof of the order, i'm sure that someone at Frictional Games can give you access the native release Cool

It's better then playing the Windows release on Wine Tongue  

On topic, you had any other issue so far ?
Yeah, I'm not sure if my wife can dig it up, she bought it quite a while ago, but I'll see what I can do. I pretty much play everything on Wine Big Grin I've had very little problems getting games to work using PlayOnLinux Smile.

But back on topic, I did have more issues unfortunately. I downloaded a save that was just past where I got stuck, at the end of the sewers and it worked great. I was able to progress into the next area after it and everything seemed to be going great until the part where you give a guy behind a door a saw through a drawer. The door burst open and the game froze, repeating some sort of explosion/bang sound effect over and over very loudly and I had to Alt-F4. I tried again several times and the same thing kept happening. I could try to get another save to progress but I'm getting pretty discouraged to be honest, probably run into another issue down the road after that Sad