Frictional Games Forum

Full Version: Level Editor loading crash after changeover to win 10
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Mostly .map data can be loaded in win 10. But not everyone.

Mostly time I made a mod with win 7. With some serious reason I have to change to windows 10. Reinstall amnesia and tools. The new level editor doesnt load some specific map files anymore and starting to crash. And Im thinking there are many ways for a simple fix.

And I wish to hear in the forum what you guys gonna do with this situation.
(04-12-2019, 08:29 AM)AFSStudio Wrote: [ -> ]Mostly .map data can be loaded in win 10. But not everyone.

Mostly time I made a mod with win 7. With some serious reason I have to change to windows 10. Reinstall amnesia and tools. The new level editor doesnt load some specific map files anymore and starting to crash. And Im thinking there are many ways for a simple fix.

And I wish to hear in the forum what you guys gonna do with this situation.

Load up a map that crashes through the Level Editor and post the LevelEditor.log file here. You can find the LevelEditor.log file at C:\Users\Lachlan\Documents\HPL2

My best guess is that there is some assets missing or there is an issue with your DPI settings - DPI settings, at least when upgrading to Windows 10, sometimes are set to 125% by default. Amnesia cannot run properly (and tends to crash) when DPI settings aren't 100%.
(04-13-2019, 12:14 PM)Romulator Wrote: [ -> ]Load up a map that crashes through the Level Editor and post the LevelEditor.log file here. You can find the LevelEditor.log file at C:\Users\Lachlan\Documents\HPL2

My best guess is that there is some assets missing or there is an issue with your DPI settings - DPI settings, at least when upgrading to Windows 10, sometimes are set to 125% by default. Amnesia cannot run properly (and tends to crash) when DPI settings aren't 100%.

I really wish to find the 125 in the display setting. Unfortunately It looks 100% fine. So. Hope to find the issue in this log file.
It looks like you might have been using custom assets in your maps. When you reinstalled the game and tools, you might have forgotten those entities. What's "silent_suitor_1" ?

I would suggest you also do a steam integrity check if you have Amnesia through Steam. Could fix some broken files.
(04-17-2019, 11:44 PM)Mudbill Wrote: [ -> ]It looks like you might have been using custom assets in your maps. When you reinstalled the game and tools, you might have forgotten those entities. What's "silent_suitor_1" ?

I would suggest you also do a steam integrity check if you have Amnesia through Steam. Could fix some broken files.

Yes. This files was missing. I just forgotten to put the specific files in the entity folder.
All this tiny things I forgot to do. Makes the editor blind and crush.

And windows 10 was not the reason. But the last installation.

Silent Suitor is the remodeld suitor. Little bit change in the model editor. To mention about this custom files was a good help.
Thank you.