Frictional Games Forum
[LVL ED] FATAL ERROR plz help - Printable Version

+- Frictional Games Forum (https://www.frictionalgames.com/forum)
+-- Forum: Amnesia: The Dark Descent (https://www.frictionalgames.com/forum/forum-6.html)
+--- Forum: Custom Stories, TCs & Mods - Development (https://www.frictionalgames.com/forum/forum-38.html)
+---- Forum: Development Support (https://www.frictionalgames.com/forum/forum-39.html)
+---- Thread: [LVL ED] FATAL ERROR plz help (/thread-14311.html)



FATAL ERROR plz help - zombiehacker595 - 03-28-2012

help my amnesia custom story scripting is not working
this is my script so far
void OnStart()
{
SetEntityPlayerInteractCallback("key_study_1", "ActivateMonster", true);
}
void OnEnter()
{
}
void OnLeave()
{
}
void ActivateMonster(string &in item)
{
SetentityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1". 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2". 0, "Idle");
}
and i get this message
FATAL ERROR could not load script file
custom_stories/test/maps/intro.hps
main 19,60 : ERR: expected identifier
main 20,60 : ERR: expected indentifier
how can i fix this i did it before and it worked than i added level doors or something now its fucked little help plz Smile?



RE: FATAL ERROR plz help - Robby - 03-28-2012

(03-28-2012, 03:26 PM)zombiehacker595 Wrote: help my amnesia custom story scripting is not working
this is my script so far
void OnStart()
{
SetEntityPlayerInteractCallback("key_study_1", "ActivateMonster", true);
}
void OnEnter()
{
}
void OnLeave()
{
}
void ActivateMonster(string &in item)
{
SetentityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1". 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2". 0, "Idle");
}
and i get this message
FATAL ERROR could not load script file
custom_stories/test/maps/intro.hps
main 19,60 : ERR: expected identifier
main 20,60 : ERR: expected indentifier
how can i fix this i did it before and it worked than i added level doors or something now its fucked little help plz Smile?

There is this part of the script.

Code:
SetentityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1". 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2". 0, "Idle");

There are wrong pieces here. It should be like this...

Code:
SetEntityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1", 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2", 0, "Idle");

At the AddEnemyPatrolNode, at "PathNodeArea_1" and PathNodeArea_2", you placed ".", which is wrong. Just copy the code I gave you. It should work.



RE: FATAL ERROR plz help - zombiehacker595 - 03-29-2012

(03-28-2012, 03:40 PM)Nemet Robert Wrote:
(03-28-2012, 03:26 PM)zombiehacker595 Wrote: help my amnesia custom story scripting is not working
this is my script so far
void OnStart()
{
SetEntityPlayerInteractCallback("key_study_1", "ActivateMonster", true);
}
void OnEnter()
{
}
void OnLeave()
{
}
void ActivateMonster(string &in item)
{
SetentityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1". 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2". 0, "Idle");
}
and i get this message
FATAL ERROR could not load script file
custom_stories/test/maps/intro.hps
main 19,60 : ERR: expected identifier
main 20,60 : ERR: expected indentifier
how can i fix this i did it before and it worked than i added level doors or something now its fucked little help plz Smile?

There is this part of the script.

Code:
SetentityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1". 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2". 0, "Idle");

There are wrong pieces here. It should be like this...

Code:
SetEntityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1", 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2", 0, "Idle");

At the AddEnemyPatrolNode, at "PathNodeArea_1" and PathNodeArea_2", you placed ".", which is wrong. Just copy the code I gave you. It should work.
thank you so much i was actually going spaztic but i cant beleive i missed that dot thanks dude Smile