Frictional Games Forum
[SOLVED]unable to bind additional mouse buttons - Printable Version

+- Frictional Games Forum (https://www.frictionalgames.com/forum)
+-- Forum: Technical Support (https://www.frictionalgames.com/forum/forum-57.html)
+--- Forum: Technical Support - SOMA (https://www.frictionalgames.com/forum/forum-74.html)
+---- Forum: Linux - SOMA (https://www.frictionalgames.com/forum/forum-75.html)
+---- Thread: [SOLVED]unable to bind additional mouse buttons (/thread-31055.html)



[SOLVED]unable to bind additional mouse buttons - tin - 09-29-2015

Hi there
For some reason it is not possible for me to bind 4th and other additional buttons in the game.
I want to use it for running.
Mouse should be working if i test it with :
"xinput test x"
command, the button does indeed work.

I tried mapping it as a keystroke for the "n" key with xbindkeys script

"xte 'key n'"
b:8
(and similar)

it works for OS but not for the game.
-game not recognizes it at all (according to keyboard binding menu)

Next i tried utility Easystroke (yes it is for gestures, but you can use it for this too) utility
- game recognizes the click as said button but still not working.

And in both cases this 4th mouse (for the os it is 8th) button causes the movement in the game to act weird.

Hard to explain but with this button pressed down the every mouse movement gets heavily strengthened resulting in crazy fast spins with slightest move of the mouse.

os: Mint 17.2
mouse: old Razer diamondback


RE: unable to bind additional mouse buttons - tin - 09-29-2015

Never mind it is fixed in recent patch :-)
It just does not show the name of the button when you bind it.
It binds it but the field for letter is empty.
But the button works.

Thank you Frictional your awesome