Frictional Games Forum
Overture crashes on launch - Printable Version

+- Frictional Games Forum (https://www.frictionalgames.com/forum)
+-- Forum: Technical Support (https://www.frictionalgames.com/forum/forum-57.html)
+--- Forum: Technical Support - Penumbra Series (https://www.frictionalgames.com/forum/forum-22.html)
+---- Forum: Mac - Penumbra (https://www.frictionalgames.com/forum/forum-26.html)
+---- Thread: Overture crashes on launch (/thread-56722.html)



Overture crashes on launch - mangoduck - 02-15-2020

When I open the application, the screen goes black momentarily, then the game immediately crashes.

I downloaded penumbra_collection_1.1.1.dmg today from shelf.frictionalgames.com

My MacBook:

Quote:macOS Mojave
Version 10.14.6

MacBook Pro (Retina, 15-inch, Mid 2015)
Processor 2.5 GHz Intel Core i7
Memory 16 GB 1600 MHz DDR3
Graphics Intel Iris Pro 1536 MB


hpl.log:

Quote:-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
 Creating graphics module
 Creating system module
 Creating resource module
 Creating input module
 Creating sound module
 Creating physics module
 Creating ai module
 Creating gui module
 Creating haptic module
 Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
 Creating resource managers
 Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
 Init low level graphics
 Setting video mode: 800 x 600
 Init Glee...OK
 Setting up OpenGL
  Max texture image units: 16
  Max texture coord units: 8
  Two sided stencil: 1
  Vertex Buffer Object: 1
  Anisotropic filtering: 1
  Max Anisotropic degree: 16
  Multisampling: 1
  Vertex Program: 1
  Fragment Program: 1
  NV Register Combiners: 0
  NV Register Combiners Stages: 0
  ATI Fragment Shader: 0
 Creating graphic systems
  Creating Renderer2D
ERROR: Couldn't texture 'PointLight2D.bmp'
FATAL ERROR: Couldn't load PointLight2DDeleting ATI shader to 0
Deleting ATI shader to 0
Deleting ATI shader to 0
Deleting ATI shader to 0

Any help appreciated. Thank you.