Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[split] [SOLVED] Could not load main config file?
jgilberw Offline
Junior Member

Posts: 2
Threads: 1
Joined: Mar 2012
Reputation: 0
Solved: 2 Years, 3 Months, 3 Weeks ago [split] [SOLVED] Could not load main config file?

I'm not sure whether I should add to this thread or start a new one. I'm experiencing the same problem as the person who started this thread: Amnesia worked for a few days on my Mac; but then, suddenly, I would get the following message when I tried to launch it:

Error Loading Configuration File!

Could not load main config
file: config/default_main_settings.cfg

I followed this thread's suggestion and renamed the "Frictional Games" file something else. This worked for a while; but then the problem recurred. I will now try renaming it again; but I'm worried that the problem will just recur again before I finish the game. I would greatly appreciate any suggestions you could give me to fix this. I really like the game and would like to finish it! Incidentally, I purchased the game through STEAM and have already asked their tech support for help (they weren't able to help). I will add my correspondence with STEAM support, in case it helps clarify my issue for you. Thanks, in advance, for your help!

Here is my correspondence with STEAM support:

1 Message by
you on Mon, 26th Mar 2012 11:09 am


I downloaded "Amnesia: Dark Descent" from you several
days ago (for Mac); and it worked fine up until recently. Now, when I try to
launch the game, I get the following error message:

Error Loading Configuration File!

Could not load main config file:

I went to your support site, under the "errors and
crashes" section (sub-heading: "games do not run after preparing to
launch"). I followed the instructions there, first making sure my Mac
software was fully updated, then verifying the integrity of the game cache, as
per your instructions (this verification process revealed no problems).

Could you please help me to fix this as soon as you can. I
bought this game from you only a few days ago; and I've already invested too
much time into this problem.

Thank you, in advance, for your help.


2 Message by
you on Mon, 26th Mar 2012 11:48 am

Hi again,

One more quick point: I went to the Frictional website, to see what
kind of technical support they offer. There are links to forums; but I did not
find a way to contact tech support directly, in order to ask about my problem.
In short, Steam technical support seems to be my only option, in trying to fix
my problem.

Thanks again,


3 Message by
Support Tech Arnold on Wed, 28th Mar 2012 12:57 pm


Thank you for contacting Steam Support.

Please exit Steam and go to the folder
Users/[username]/Library/Application Support/Steam

Delete all of the files in this folder except for SteamApps.

Restart your computer.

Launch Steam and re-test the issue.

Note: This process will not affect your currently installed

Note: If you are using Lion please do the following to access
your Steam folder:

1. Click "Go" in the menu bar

2. Click "Go to Folder..."

3. Type "~/Library/Application Support/Steam"

4. Click "Go"

This will take you directly to the folder.

If the issue persists, make sure your network is optimized for

Title: Troubleshooting Network Connectivity

Link: http://support.steampowered.com/kb_artic...-EUDN-2493

If you have any further questions, please let us know.

4 Message by
you on Wed, 28th Mar 2012 6:21 pm

Thank you for this suggestion. I tried what you recommended, but
it didn't work. After I deleted the files you indicated, restarted my computer,
and restarted Steam, the same error message came up when I tried to start
Amnesia. (Note: I am not using Lion. Also, I went to the "Troubleshooting
Network Connectivity" link you sent; but t was not clear to me what I
should do here, or whether/how it is relevant to my problem).

One thing I forgot to mention: at an online forum, someone who
had the problem I'm having was given this suggestion: to go to
"Library/Application Support/Frictional Games" and to rename the
"Frictional Games" file something else. I tried this and it worked
for a while (though it erased all of my saved-game data, so I had to start
over); however, after a day or two, the same error-message problem happened

What should I try next? I'm happy to try erasing the game and
re-installing it, or whatever you think would work.

5 Message by
Support Tech Arnold on Fri, 30th Mar 2012 3:02 pm


Please try the following:

Exit Steam entirely.

Open Finder and navigate to the folder containing your SteamApps
folder (/Users/[username]/Library/Application Support/Steam/)

Rename the "SteamApps" folder to

Re-launch Steam and re-install the game.

Once the installation is complete, test the issue.

Note: If you are using Lion please do the following to enable
your Library folder:

1. Open Terminal

2. Type chflags nohidden ~/Library

3. Close Terminal

You should see the Library folder available through the Go menu
on the menu bar while holding the option key.

If this resolves the issue, you may copy the new files into the
"old_steamapps" folder and rename it to "steamapps" to
restore your other games without re-downloading.

If the issue is not resolved, you can rename the folder back to
avoid having to re-install other games.

If you continue to experience this issue, please contact the
game manufacturer for support.

Please follow the link below for instructions to contact the
support provider for this title:

Title: Amnesia: The Dark Descent

Link: http://support.steampowered.com/kb_artic...-OPFH-6104

Let us know if you encounter any difficulty contacting the
support provider for this title, or if you have any further questions.

6 Message by
you on Sat, 31st Mar 2012 5:21 am

I tried your suggestion; but the same error recurrs. As I
mentioned in my earlier message, Frictional Games seems not to have a direct
contact for tech support; but I will post this problem on one of their forums,
to see if someone can help me. If you have any other suggestions, please let me

(This post was last modified: 03-31-2012, 02:38 PM by jgilberw.)
03-31-2012, 02:37 PM
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
Solved: 2 Years, 3 Months, 3 Weeks ago RE: [split] [SOLVED] Could not load main config file?

Did you check how much free disk space you have on your system? Thus far this seems to be related to running out of free disk space and the config files being zero byte.

When you "move/remove" the frictional games folder did you check the size of the config files in the folder???

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
03-31-2012, 06:54 PM
Website Find
jgilberw Offline
Junior Member

Posts: 2
Threads: 1
Joined: Mar 2012
Reputation: 0
Solved: 2 Years, 3 Months, 3 Weeks ago RE: [split] [SOLVED] Could not load main config file?

Yes, I was running low on disk-space when I first encountered this problem! (the problem continued after I deleted files and increased my disk-space; but perhaps increasing the disk-space was not, by itself, enough to fix the problem, once it arose).

Anyway, I've made the 'fix' recommended on this thread; and everything seems to be working fine. If I run into any further problems, I'll let you know.

Thanks for your help!
04-05-2012, 06:23 PM

Users browsing this thread: 1 Guest(s)