Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Demo crashes - audio problem [ubuntu]
zk123 Offline
Junior Member

Posts: 4
Threads: 1
Joined: May 2012
Reputation: 0
#1
Solved: 2 Years, 3 Months, 3 Weeks ago Demo crashes - audio problem [ubuntu]

When I try to play the
Amnesia demo, it first starts normally, tells me the normal stuff, asks
for gamma setting (which all look the same to me, btw), I get to the first
loading screen and then it's just gone.


The terminal output is at http://paste.ubuntu.com/952375/, seems to be some kind of audio problem.
The sound in the menu works fine.
(This post was last modified: 05-05-2012, 02:52 PM by zk123.)
05-05-2012, 02:39 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#2
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Demo crashes - audio problem [ubuntu]

The audio errors tend to be misleading. Really that is the openAL library detecting what is on your system. Can you post your hpl.log file? ~/.frictionalgames/Amnesia/Demo/hpl.log and the launcher.log as well.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
05-05-2012, 02:56 PM
Website Find
zk123 Offline
Junior Member

Posts: 4
Threads: 1
Joined: May 2012
Reputation: 0
#3
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Demo crashes - audio problem [ubuntu]

(05-05-2012, 02:56 PM)Urkle Wrote: The audio errors tend to be misleading. Really that is the openAL library detecting what is on your system. Can you post your hpl.log file? ~/.frictionalgames/Amnesia/Demo/hpl.log and the launcher.log as well.
http://paste.ubuntu.com/969210/ ← hpl.log
http://paste.ubuntu.com/969212/ ← launcher.log
05-05-2012, 03:08 PM
Find
plutomaniac Offline
Super Moderator

Posts: 6,369
Threads: 45
Joined: May 2011
Reputation: 183
#4
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Demo crashes - audio problem [ubuntu]

I don't know about Linux but as far as I understand you have Intel HD 2000 and a driver from Q1 2011 (7.10.2). The latest is from Q1 2012 (8.0.1) and you can find it here:

http://intellinuxgraphics.org/2012.02.html

Again, I'm a Windows helper so I might be wrong...
(This post was last modified: 05-06-2012, 07:45 PM by plutomaniac.)
05-06-2012, 07:44 PM
Find
zk123 Offline
Junior Member

Posts: 4
Threads: 1
Joined: May 2012
Reputation: 0
#5
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Demo crashes - audio problem [ubuntu]

(05-06-2012, 07:44 PM)plutomaniac Wrote: I don't know about Linux but as far as I understand you have Intel HD 2000 and a driver from Q1 2011 (7.10.2). The latest is from Q1 2012 (8.0.1) and you can find it here:

http://intellinuxgraphics.org/2012.02.html

Again, I'm a Windows helper so I might be wrong...

Could that be it? The website says "If you are not experienced doing this, we recommend that you get precompiled packages from one of the many Linux distributions." - where do I get one?
05-07-2012, 09:35 AM
Find
plutomaniac Offline
Super Moderator

Posts: 6,369
Threads: 45
Joined: May 2011
Reputation: 183
#6
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Demo crashes - audio problem [ubuntu]

I don't know how Linux works. I think there is a search place where you can find all linux applications. Search there I guess...
05-07-2012, 10:53 AM
Find
Your Computer Offline
SCAN ME!

Posts: 3,456
Threads: 32
Joined: Jul 2011
Reputation: 235
#7
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Demo crashes - audio problem [ubuntu]

(05-07-2012, 09:35 AM)zk123 Wrote: Could that be it? The website says "If you are not experienced doing this, we recommend that you get precompiled packages from one of the many Linux distributions." - where do I get one?

According to the hpl.log you already have the Mesa drivers installed, but it's not version 8.0.1. Configuring the X server is not a fun task. If you're not used to doing it, i wouldn't mess with it.

Tutorials: From Noob to Pro
05-07-2012, 11:51 AM
Website Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#8
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Demo crashes - audio problem [ubuntu]

The reason is this line from the logs.

Texture compression S3TC: 0

You have no S3TC. You have to either compiled & install the libdxt_txcn library or (for more recent distributions) do some mojo to enable S3TC in the open source driver

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
05-07-2012, 03:17 PM
Website Find
zk123 Offline
Junior Member

Posts: 4
Threads: 1
Joined: May 2012
Reputation: 0
#9
Solved: 2 Years, 3 Months, 3 Weeks ago RE: Demo crashes - audio problem [ubuntu]

(05-07-2012, 11:51 AM)Your Computer Wrote:
(05-07-2012, 09:35 AM)zk123 Wrote: Could that be it? The website says "If you are not experienced doing this, we recommend that you get precompiled packages from one of the many Linux distributions." - where do I get one?

According to the hpl.log you already have the Mesa drivers installed, but it's not version 8.0.1. Configuring the X server is not a fun task. If you're not used to doing it, i wouldn't mess with it.
I remember having some issues with the X server on my desktop once, that was a royal pain in the ass. I'd like to not have to do that ever again...


(05-07-2012, 03:17 PM)Urkle Wrote: The reason is this line from the logs.

Texture compression S3TC: 0

You have no S3TC. You have to either compiled & install the libdxt_txcn library or (for more recent distributions) do some mojo to enable S3TC in the open source driver

Is there any (sort of) simple way to get this done?
(This post was last modified: 05-07-2012, 05:31 PM by zk123.)
05-07-2012, 05:30 PM
Find




Users browsing this thread: 1 Guest(s)