Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Menu entries
Soulsuke Offline
Junior Member

Posts: 1
Threads: 1
Joined: Sep 2010
Reputation: 0
Solved: 4 Years, 6 Months, 3 Weeks ago Menu entries

I've installed Amnesia on Ubuntu 10.04 64 bit, and I've found a curious bug: if the game's installed as a super user (sudo/su) the .desktop files are placed in /usr/share/applications as usual, but they won't appear in gnome's menu because the lack of a ';' at the end of the second line ("Categories=Game" should be changed in "Categories=Game;", of course it's also needed to give them read permissions for all users [sudo chmod a+r /usr/share/applications/Amnesia*]).
They do appear in gnome's menu if they are placed in user's $HOME/.local/share/applications folder without any correction, but I don't know if this is a gnome's bug or anything...

By the way, just as quick workaround to make the game work if it's installed in a system directory (in my case /opt/Amnesia):
sudo find /opt/Amnesia -type d -exec sudo chmod 755 '{}' \;
sudo find /opt/Amnesia -type f -exec sudo chmod a+r,a-w,u+w '{}' \;
09-08-2010, 07:59 PM
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
Solved: 4 Years, 6 Months, 3 Weeks ago RE: Menu entries

That is curious. Also strange that it doesn't show up under gnome on Fedora. I'll look into that for future installers/patches

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-08-2010, 10:26 PM
Website Find

Users browsing this thread: 1 Guest(s)