Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Soma gets an application error whenever I try to launch
namelessdread Offline
Junior Member

Posts: 3
Threads: 1
Joined: Feb 2020
Reputation: 0
#1
Not Solved Soma gets an application error whenever I try to launch

I got this game from Epic Games Store when it was free and recently downloaded, installed, and tried to run it. But when I do I get the pop-up: "Soma.exe - Application Error: The application was unable to start correctly (0x000007b). Click OK to close the application". I've tried reading several threads on several forums but nothing seems to work. I've tried reinstalling all the Microsoft Redistributable packages, etc. I'm running Windows 10 x64 system. Do you think it's possible everything didn't download right from Epic? It seems like the download "jumped" near the end. When it was near 90% it just sort of finished. But verifying integrity of the files completes 100% so I don't know.
02-23-2020, 05:59 PM
Find Reply
Romulator Offline
Not Tech Support ;-)

Posts: 3,627
Threads: 63
Joined: Jan 2013
Reputation: 195
#2
Not Solved RE: Soma gets an application error whenever I try to launch

Generally speaking, 0x000007b refers to an application being unable to start because it could not load a file it depends on. The most common problem for this may mean you have 64-bit drivers in your 32-bit folder, and/or 32-bit drivers in your 64 bit folder. It has to be fixed manually. I can't walk you through the steps as it could be any number of DLLs which are causing problems, but I would have a read of this thread to get Dependancy Walker installed on your computer: https://stackoverflow.com/questions/1049...0xc000007b

SOMA is a 64-bit application, so you want the x64 build of Dependancy Walker. There should still be a profiling option in the application; use that to run SOMA.exe (or SOMA_NoSteam.exe if that is there) from the Epic Games Store directory it was installed to. It should stop at the problematic .dll, which you will need to replace with either the 32-bit or 64-bit .dll.

Your 64-bit DLLs should be located at C:\Windows\system32, and your 32-bit DLLs in C:\Windows\SYSWOW64\

Discord: Romulator#0001
[Image: 3f6f01a904.png]
02-24-2020, 01:23 PM
Find Reply
namelessdread Offline
Junior Member

Posts: 3
Threads: 1
Joined: Feb 2020
Reputation: 0
#3
Not Solved RE: Soma gets an application error whenever I try to launch

Hmm. When I run the profiler it just shows this

https://i.imgur.com/r8TVXCc.png

Running Dependancy Walker just regular shows this

https://i.imgur.com/imvVG21.png

No idea what any of this means.
02-27-2020, 11:11 AM
Find Reply
namelessdread Offline
Junior Member

Posts: 3
Threads: 1
Joined: Feb 2020
Reputation: 0
#4
Not Solved RE: Soma gets an application error whenever I try to launch

I'm actually wondering if this msvcp100.dll might be the issue since it's listed as x86 (32 bit) when it should be x64? Since application errors occur when there are conflicts with running 64 bit application on 32 bit architecture or whatever

https://i.imgur.com/nC0Pm21.png
02-27-2020, 11:38 AM
Find Reply




Users browsing this thread: 1 Guest(s)