Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
*Solved* So I guess Im retarded
monkeyfoahead Offline
Junior Member

Posts: 4
Threads: 1
Joined: Feb 2011
Reputation: 0
Bug  *Solved* So I guess Im retarded

So I want to enter my first map i have ever made. I set up a dev_user and everytime i try and start by clicking new game, it crashes. My log says this:
Version 1.10 - sCAC73D1-539
-------- THE HPL ENGINE LOG ------------
Engine build ID 20101002081729

Creating Engine Modules
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module

Initializing Resources Module
Creating loader handlers
Creating resource managers
Adding loaders to handlers

Initializing Graphics Module
Init lowlevel graphics: 1920x1080 bpp:32 fs:1 ms:0 gpufmt:2 cap:'Amnesia - The Dark Descent - Loading...' pos:(-1x-1)
Setting video mode: 1920 x 1080 - 32 bpp
Init Glew...OK
Setting up OpenGL
  Vendor: ATI Technologies Inc.
  Renderer: ATI Radeon HD 5870 OpenGL Engine
  Version: 2.1 ATI-1.6.26
  Max texture image units: 16
  Max texture coord units: 8
  Max user clip planes: 6
  Two sided stencil: 1
  Vertex Buffer Object: 1
  Anisotropic filtering: 1
  Max Anisotropic degree: 16
  Multisampling: 1
  Texture compression: 1
  Texture compression S3TC: 1
  Auto generate MipMaps: 1
  Render to texture: 1
  Max draw buffers: 8
  Max color render targets: 8
  Packed depth-stencil: 1
  Texture float: 1
  GLSL Version: 1.20
  ShaderModel 2: 1
  ShaderModel 3: 0
  ShaderModel 4: 0
  OGL ATIFragmentShader: 0
ATTENTION: System does not support const arrays in glsl!
Setting up G-Bugger: type: 0 texturenum: 3
Adding engine materials
Initializing DevIL
  Vendor String: Abysmal Software
  Version String: Developer's Image Library (DevIL) 1.6.8pre Aug 22 2010
  Version Number: 168
Adding engine post effects

Initializing Sound Module
Initializing OpenAL
  Available OpenAL devices:
   0. Built-in Line Output(OpenAL default)
  Trying to open device 'Built-in Line Output'... Success!
  Number of mono sources: 32
  Streaming setup: 4 Buffers x 262144 bytes each

Initializing Game Module
Adding engine updates
Initializing script functions

User Initialization

Game Running
-------- Loading map 'menu_bg.map' ---------
    Cache Loading: 1169 ms
  Entities: 398 ms
  Compilation: 1 ms
  Total: 1820 ms
  Meshes created: 26
  Bodies created: 5
-------- Loading complete ---------
Setting profile: 'dev_user' Path: '/Users/monkeyfoahead/Library/Application Support/Frictional Games/Amnesia/Main/dev_user/'
ERROR: Couldn't create script '/Applications/Amnesia.app/Contents/Resources/mymapsglobal.hps'
ERROR: Global script '/Applications/Amnesia.app/Contents/Resources/mymapsglobal.hps' could not be created!
ERROR: Script file /Applications/Amnesia.app/Contents/Resources/mymapsmyfirstmap.hps does not exist!
ERROR: World '/Applications/Amnesia.app/Contents/Resources/mymapsmyfirstmap.map' doesn't exist
FATAL ERROR: Could not load world file '/Applications/Amnesia.app/Contents/Resources/mymapsmyfirstmap.map'

I am on a mac. Did I edit user_settings.cfg wrong? Here is my user_settings.cfg
<Game ShowCommentary="false" ShowCrossHair="true" FocusIconStyle="Default" ShowDeathHints="true" ShowSubtitles="true" ShowEffectSubtitles="false" ShowHints="true" />
<Debug ShowFPS="false" ShowSoundPlaying="false" ShowPlayerInfo="false" ShowEntityInfo="false" SaveCheckPointOnMapLoad="false" ShowDebugMessages="false" UseProgLog="false" ScriptDebugOn="false" InspectionMode="false" DisableFlashBacks="false" DrawPhysics="false" ReloadFromCurrentPosition="true" AllowQuickSave="false" />
<Input InvertMouse="false" SmoothMouse="true" MouseSensitivity="1.000000" />
<Map File="myfirstmap.map" Folder="/Applications/Amnesia.app/Contents/Resources/mymaps" StartPos="" />

I read the wikis and stuff on creating your own maps. So is there something I am doing wrong?

(This post was last modified: 02-24-2011, 03:04 PM by monkeyfoahead.)
02-19-2011, 05:46 PM
Find Reply

Messages In This Thread
*Solved* So I guess Im retarded - by monkeyfoahead - 02-19-2011, 05:46 PM
RE: So I guess Im retarded - by Oscar House - 02-19-2011, 07:22 PM
RE: So I guess Im retarded - by monkeyfoahead - 02-19-2011, 08:10 PM
RE: So I guess Im retarded - by Oscar House - 02-19-2011, 08:15 PM
RE: So I guess Im retarded - by monkeyfoahead - 02-19-2011, 10:45 PM

Users browsing this thread: 1 Guest(s)