Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Error caused by a version of a function that shouldn't be compiled
jorgeas80 Offline
Junior Member

Posts: 21
Threads: 7
Joined: Jan 2014
Reputation: 0
#3
RE: Error caused by a version of a function that shouldn't be compiled

Thanks for the response, Urkle.

I actually compiled everything in Ubuntu 12.04. I used gcc 4.5 instead of gcc 4.6 (default in Ubuntu, lots of errors) and cmake 2.8.12 instead of cmake 2.8.7 (default in Ubuntu 12.04, didn't recognize a directive used in CMakeList.txt). I'd need to compile it under Mac and Windows too, but I'll left the Windows part for the end. I'm a Mac and Linux developer.

The problem in Mac, I think, is with the gcc provided by Apple. Which compiler do you use in Mac? Is there any chance to use the official gcc instead of the wrapped by Apple? (I guess that MacPorts, Fink, Homebrew or even manual compiling the sources would work)

Many thanks
01-14-2014, 01:23 PM
Website Find Reply


Messages In This Thread
RE: Error caused by a version of a function that shouldn't be compiled - by jorgeas80 - 01-14-2014, 01:23 PM



Users browsing this thread: 1 Guest(s)