Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Error caused by a version of a function that shouldn't be compiled
jorgeas80 Offline
Junior Member

Posts: 21
Threads: 7
Joined: Jan 2014
Reputation: 0
#5
RE: Error caused by a version of a function that shouldn't be compiled

Thanks for your response Urkle. Updated status:

As HPL1Engine and Penumbra's last commits are from 2010, I've downloaded the last OALWrapper version from 2010. By doing that, I can now compile, run and debug Penumbra in Windows 7 with Visual Studio 2010 (also thanks to JKO for his/her great guide).

I also can compile it in Linux, with Ubuntu 12.04 and GCC 4.5.0 + cmake 2.8.12. Be careful, because Ubuntu 12.04 comes along with GCC 4.6.0 and cmake 2.8.7. It won't compile with those versions. You need to get the right ones. GCC 4.5 can be installed with apt-get, and default version changed from 4.6.0 to 4.5.0 via update-alternatives. About cmake 2.8.12, I had to compile it manually. Not a big deal. I had some other minor problems with dependencies too. Check this issue in my fork from HPL1Engine

Regarding Mac, I installed XCode 3.6.2, and it caused a kernel (and personal) panic. It's a known problem with Lion and Mountain Lion (my version), and it can be solved, but I don't recommend to install XCode 3.x. I will try with XCode 5, taking into account the changes suggested by Urkle, and using the "frozen" 2010 version of OALWrapper.
01-29-2014, 11:02 AM
Website Find Reply


Messages In This Thread
RE: Error caused by a version of a function that shouldn't be compiled - by jorgeas80 - 01-29-2014, 11:02 AM



Users browsing this thread: 1 Guest(s)