Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem Running Editor On OS X 10.10.1
Stolas Offline
Junior Member

Posts: 13
Threads: 2
Joined: Dec 2014
Reputation: 0
Solved: 4 Years ago Problem Running Editor On OS X 10.10.1

I'm having a huge issue.
After days of hard work,
I can no longer use the editor suite.
Previously, I had to wrestle with it to make it work,
but it did work with effort.
The mac editor installer did not work, so I had to manual install.
Then, I had to paste and overwrite all the editor files every time I used it.
But yesterday, I went to reinstall and open the editor,
and I got an alert.

LevelEditor cannot be opened because of a problem.
Check with your developer to make sure LevelEditor works with this version of OS X.
Be sure to install any available updates for the application and OS X.

(I will put the Problem Details and System Configuration below)

I am running the Steam version of Amnesia.

So I tried restarting.
the I tried reinstalling, both manually, and with the installer.
I tried restarting again.
I tried uninstalling the game, restarting, reinstalling the game, restarting,
reinstalling the Editor Suite, (with all available methods for mac)
and restarting.
I have tried uninstalling Steam, reinstalling,
and of course, restarting.
I've also tried running all editors, both from the launcher tab and directly.

I'm running:
OS X Yosemite Version 10.10.1
iMac (27-inch, Late 2009)
2.66 GHz Intel Core i5
4 GB 1067 MHz DDR3
ATI Radeon HD 4850 512 MB

The version should not be the issue,
as I was successfully running the editor on this version previous to the problem.
As far as I know, there have been no kind of updates to anything on my system,
including the game itself, that would be the cause to my problem.
If there was any kind of update to anything, I was never prompted or alerted.

The game itself runs perfectly,
I have had absolutely no issue playing Amnesia.
So as far as I can gather, it has nothing to do with system requirements,
such as the graphics card.

I have tried searching these forums and many, many other places on the net.
I hope I have posted sufficient information as to my problem,
the measures I have taken to solve it, and my system.

here is the Problem Details report that I recieve with the message.
Process: LevelEditor [444]
Path: /Users/USER/Library/Application Support/Steam/*/LevelEditor.app/Contents/MacOS/LevelEditor
Identifier: com.frictionalgames.HPL2.LevelEditor
Version: ???
Code Type: X86 (Native)
Parent Process: ??? [1]
Responsible: LevelEditor [444]
User ID: 501

Date/Time: 2014-12-07 00:48:27.113 -0500
OS Version: Mac OS X 10.10.1 (14B25)
Report Version: 11
Anonymous UUID: 647CD23A-6F6E-13D0-1A1B-DD4043477883

Time Awake Since Boot: 23000 seconds

Crashed Thread: 0

Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries
DYLD_FALLBACK_LIBRARY_PATH=/Applications/Steam.app/Contents/MacOS:/Users/macosx/Library/Application Support/Steam/steamapps/common/Amnesia The Dark Descent:/Users/macosx/Library/Application Support/Steam/steamapps/common/Amnesia The Dark Descent/bin:/usr/local/lib:/lib:/usr/lib

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/ALUT.framework/Versions/A/ALUT
Referenced from: /Users/USER/Library/Application Support/Steam/*/LevelEditor.app/Contents/MacOS/LevelEditor
Reason: image not found

Binary Images:
0x8fe31000 - 0x8fe64e03 dyld (353.2.1) <EBFF7998-58E8-32F5-BF0D-9690278EC792> /usr/lib/dyld
0x913ae000 - 0x913aefff com.apple.Carbon (154 - 157) <5A078967-8437-3721-A6B1-70CC00461D7B> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

Model: iMac11,1, BootROM IM111.0034.B02, 4 processors, Intel Core i5, 2.66 GHz, 4 GB, SMC 1.54f36
Graphics: ATI Radeon HD 4850, ATI Radeon HD 4850, PCIe, 512 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54313235533642465238432D47372020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54313235533642465238432D47372020
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x8F), Atheros 9280:
Bluetooth: Version 4.3.1f2 15015, 3 services, 27 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: ST31000528AS, 1 TB
Serial ATA Device: OPTIARC DVD RW AD-5680H
USB Device: Hub
USB Device: G13
USB Device: Internal Memory Card Reader
USB Device: BRCM2046 Hub
USB Device: Bluetooth USB Host Controller
USB Device: Hub
USB Device: Logitech Extreme 3D
USB Device: IR Receiver
USB Device: Built-in iSight
Thunderbolt Bus:

Please, somebody help me.
Up til now,
I have had to struggle so hard just to get the editor to work,
Searching the web for answers because there is little help for mac owners.
I finally get the editor to work, and this happens.
I am extremely frustrated that all my work is lost.
If anybody can help, I would be extremely thankful.
(This post was last modified: 12-07-2014, 07:27 AM by Stolas.)
12-07-2014, 07:25 AM

Messages In This Thread
Problem Running Editor On OS X 10.10.1 - by Stolas - 12-07-2014, 07:25 AM

Users browsing this thread: 1 Guest(s)