Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Soma crashes at beginning with Arch Linux
tommy221 Offline
Junior Member

Posts: 5
Threads: 1
Joined: Sep 2015
Reputation: 0
#1
Solved: 3 Years, 9 Months ago [SOLVED] Soma crashes at beginning with Arch Linux

Dear Team and dear community

The game crashes under Arch Linux when starting it:

t@e:/opt/soma/game$ ./Soma.bin.x86_64
process 5753: arguments to dbus_connection_open_private() were incorrect, assertion "address != NULL" failed in file dbus-connection.c line 2664.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
Abgebrochen (Speicherabzug geschrieben)
t@e:/opt/soma/game$

her is the logfile:

Version 1.00
-------- THE HPL ENGINE LOG ------------
Creating Engine Modules
--------------------------------------------------------
Creating job manager with 7 threads and 1024 jobs
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
Creating script module
Creating lipsync module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init lowlevel graphics: -1x-1 bpp:32 rr: 60 fs:0 ms:0 driver: 0 cap:'SOMA Loading...' pos:(-1x-1)
Available drivers:
  (0) - 'x11'
  (1) - 'dummy'

Here is the output from ldd:
t@e:/opt/soma/game$ ldd Soma.bin.x86_64
    linux-vdso.so.1 (0x00007fffb1928000)
    libGL.so.1 => /usr/lib/libGL.so.1 (0x00007fb1f3feb000)
    libGLU.so.1 => /usr/lib/libGLU.so.1 (0x00007fb1f3d6a000)
    libtheora.so.0 => /opt/soma/game/lib64/libtheora.so.0 (0x00007fb1f3b18000)
    libvorbis.so.0 => /opt/soma/game/lib64/libvorbis.so.0 (0x00007fb1f38e9000)
    libvorbisfile.so.3 => /opt/soma/game/lib64/libvorbisfile.so.3 (0x00007fb1f36e1000)
    libogg.so.0 => /opt/soma/game/lib64/libogg.so.0 (0x00007fb1f34db000)
    libIL.so.1 => /opt/soma/game/lib64/libIL.so.1 (0x00007fb1f3133000)
    libz.so.1 => /usr/lib/libz.so.1 (0x00007fb1f2f1d000)
    libfmodex.so => /opt/soma/game/lib64/libfmodex.so (0x00007fb1f2b6d000)
    libfmodevent.so => /opt/soma/game/lib64/libfmodevent.so (0x00007fb1f28e2000)
    libSDL2-2.0.so.0 => /opt/soma/game/lib64/libSDL2-2.0.so.0 (0x00007fb1f25bb000)
    libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007fb1f239e000)
    libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fb1f219a000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fb1f1e18000)
    libm.so.6 => /usr/lib/libm.so.6 (0x00007fb1f1b1a000)
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007fb1f1904000)
    libc.so.6 => /usr/lib/libc.so.6 (0x00007fb1f1560000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007fb1f1336000)
    libglapi.so.0 => /usr/lib/libglapi.so.0 (0x00007fb1f1108000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0x00007fb1f0ef6000)
    libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007fb1f0cf3000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007fb1f0aed000)
    libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0x00007fb1f08eb000)
    libX11.so.6 => /usr/lib/libX11.so.6 (0x00007fb1f05a9000)
    libxcb-glx.so.0 => /usr/lib/libxcb-glx.so.0 (0x00007fb1f038f000)
    libxcb-dri2.so.0 => /usr/lib/libxcb-dri2.so.0 (0x00007fb1f018a000)
    libxcb-dri3.so.0 => /usr/lib/libxcb-dri3.so.0 (0x00007fb1eff87000)
    libxcb-present.so.0 => /usr/lib/libxcb-present.so.0 (0x00007fb1efd84000)
    libxcb-randr.so.0 => /usr/lib/libxcb-randr.so.0 (0x00007fb1efb76000)
    libxcb-xfixes.so.0 => /usr/lib/libxcb-xfixes.so.0 (0x00007fb1ef96e000)
    libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0x00007fb1ef764000)
    libxcb-shape.so.0 => /usr/lib/libxcb-shape.so.0 (0x00007fb1ef560000)
    libxcb-sync.so.1 => /usr/lib/libxcb-sync.so.1 (0x00007fb1ef359000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fb1ef136000)
    libxshmfence.so.1 => /usr/lib/libxshmfence.so.1 (0x00007fb1eef33000)
    libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0x00007fb1eed2d000)
    libdrm.so.2 => /usr/lib/libdrm.so.2 (0x00007fb1eeb1e000)
    librt.so.1 => /usr/lib/librt.so.1 (0x00007fb1ee916000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fb1f4283000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fb1ee712000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fb1ee50c000)

here is the snipped output from glxinfo:

OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD HAWAII
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.6.7
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:

PS.: debian jessie runs the game with some graphical glitches. But it works.

Thank you very much & have a nice day.
Tom
(This post was last modified: 10-11-2015, 11:48 AM by tommy221.)
09-22-2015, 02:04 PM
Find


Messages In This Thread
[SOLVED] Soma crashes at beginning with Arch Linux - by tommy221 - 09-22-2015, 02:04 PM



Users browsing this thread: 1 Guest(s)