Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOLVED: AL lib: pulseaudio.c:612
codeastronomer Offline
Junior Member

Posts: 1
Threads: 1
Joined: Sep 2011
Reputation: 0
#1
Solved: 3 Years, 5 Months, 3 Weeks ago SOLVED: AL lib: pulseaudio.c:612

Hi

Installed the Amnesia demo on 64bit Arch Linux. I see the initial screens (with sound playing) and then it seg faults at the loading screen with the error:
AL lib: pulseaudio.c:612: Context did not connect: Connection refused

I don't use pulseaudio (I tried installing it and still had the same issue).
I use OSS but also have ALSA emulation set up. I've tried selecting ALSA and OSS when running Launcher.bin64, but I still get the same error about pulseaudio.


SOLUTION:
installed libtxc_dxtn



(This post was last modified: 09-18-2011, 11:06 AM by codeastronomer.)
09-18-2011, 10:47 AM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#2
Solved: 3 Years, 5 Months, 3 Weeks ago RE: SOLVED: AL lib: pulseaudio.c:612

OpenAL-soft scans through all of your devices. That is simply stating it couldn't connect to pulse audio and probably arts and a few others. And had nothing to do with the lack of S3TC in the open source drivers. ( which is what libtxc_dxtn provides )

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-18-2011, 03:45 PM
Website Find




Users browsing this thread: 1 Guest(s)