Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Text won't show up
Sauron The King Offline
Junior Member

Posts: 42
Threads: 10
Joined: Oct 2011
Reputation: 0
#1
Text won't show up

Hello,

I have a note inside my map. When you take it, the following text will show up:
The hidden room of the divine artifact may only be entered by those who are sane. Take the cross of Jesus with you and it will be guide towards the light.

I have the following text in my extra_english.lang:
<LANGUAGE>
    <CATEGORY Name="CustomStoryMain">
        <Entry Name="Description">Just a description.</Entry>
</CATEGORY>

<CATEGORY Name="Journal">
    <Entry Name="Note_Oratory_Name">The Oratory</Entry>
    <Entry Name="Note_Oratory_Text">The hidden room of the divine artifact may only be entered by those who are sane. Take the cross of Jesus with you and it will be guide towards the light./Entry>
</CATEGORY>

</LANGUAGE>

My custom story contains three big maps, these are found at this directory:
C:\Program Files\Amnesia - The Dark Descent\redist\maps

The scripts from the levels and stuff can all be found at this directory:
C:\Program Files\Amnesia - The Dark Descent\redist\custom_stories\The Haunted Castle of Algium
The Language file also is in here.

When you take the note when playing the game, there will be no text at all. When you look in your journal, no text will be there.

What am I doing wrong?
11-11-2011, 08:26 PM
Find Reply
Statyk Offline
Schrödinger's Mod

Posts: 4,390
Threads: 72
Joined: Sep 2011
Reputation: 241
#2
RE: Text won't show up

<Entry Name="Note_Oratory_Text">The hidden room of the divine artifact may only be entered by those who are sane. Take the cross of Jesus with you and it will be guide towards the light./Entry>

you're missing the "<" at the "/Entry>".... just fix to </Entry>
11-11-2011, 08:32 PM
Find Reply
Sauron The King Offline
Junior Member

Posts: 42
Threads: 10
Joined: Oct 2011
Reputation: 0
#3
RE: Text won't show up

(11-11-2011, 08:32 PM)Statyk Wrote: <Entry Name="Note_Oratory_Text">The hidden room of the divine artifact may only be entered by those who are sane. Take the cross of Jesus with you and it will be guide towards the light./Entry>

you're missing the "<" at the "/Entry>".... just fix to </Entry>
Changed it to this:
<LANGUAGE>
    <CATEGORY Name="CustomStoryMain">
        <Entry Name="Description">Just a description.</Entry>
</CATEGORY>

<CATEGORY Name="Journal">
    <Entry Name="Note_Oratory_Name">The Oratory</Entry>
    <Entry Name="Note_Oratory_Text">The hidden room of the divine artifact may only be entered by those who are sane. Take the cross of Jesus with you and it will be guide towards the light.</Entry>
</CATEGORY>

</LANGUAGE>

Still it won't show up at all.
Also, when I start Amnesia and click on dev_user, the story won't show up at Custom Stories, but it will only start when I just click Start New Game, maybe these problems are caused by the same error. I've followed all the steps from this site: http://wiki.frictionalgames.com/hpl2/start
I have followed these steps over and over, in case I missed something.
Everything works, but I will have to start my custom story by selecting "dev_user" and then Start New Game. Only the notes can't be seen (I've not tried the momento's yet).

I hope you can help me further now.



11-12-2011, 12:33 AM
Find Reply
flamez3 Offline
Posting Freak

Posts: 1,281
Threads: 48
Joined: Apr 2011
Reputation: 57
#4
RE: Text won't show up

(11-12-2011, 12:33 AM)Sauron The King Wrote:
(11-11-2011, 08:32 PM)Statyk Wrote: The hidden room of the divine artifact may only be entered by those who are sane. Take the cross of Jesus with you and it will be guide towards the light./Entry>

you're missing the "<" at the "/Entry>".... just fix to
Changed it to this:
    
        Just a description.



    The Oratory
    The hidden room of the divine artifact may only be entered by those who are sane. Take the cross of Jesus with you and it will be guide towards the light.

Still it won't show up at all.
Also, when I start Amnesia and click on dev_user, the story won't show up at Custom Stories, but it will only start when I just click Start New Game, maybe these problems are caused by the same error. I've followed all the steps from this site: http://wiki.frictionalgames.com/hpl2/start
I have followed these steps over and over, in case I missed something.
Everything works, but I will have to start my custom story by selecting "dev_user" and then Start New Game. Only the notes can't be seen (I've not tried the momento's yet).

I hope you can help me further now.


I'm pretty sure notes journals don't appear when in dev mode. Try reading them in-game.

11-12-2011, 01:50 AM
Find Reply
Your Computer Offline
SCAN ME!

Posts: 3,456
Threads: 32
Joined: Jul 2011
Reputation: 235
#5
RE: Text won't show up

In the level editor, what did you specify for the note in the NoteText field under the Entity tab?

Tutorials: From Noob to Pro
11-12-2011, 05:20 AM
Website Find Reply
Sauron The King Offline
Junior Member

Posts: 42
Threads: 10
Joined: Oct 2011
Reputation: 0
#6
RE: Text won't show up

(11-12-2011, 05:20 AM)Your Computer Wrote: In the level editor, what did you specify for the note in the NoteText field under the Entity tab?
The Notetext and name are "Oratory". Left you can see how it shows up ingame. On the right you can see how it looks in level edit. Maybe you can now see what's wrong, at least, I hope you do.



Attached Files
.jpg   The Oratory.jpg (Size: 41.05 KB / Downloads: 58)
11-12-2011, 10:36 AM
Find Reply
sasukeroxxx Offline
Junior Member

Posts: 39
Threads: 5
Joined: Sep 2011
Reputation: 0
#7
RE: Text won't show up

(11-12-2011, 10:36 AM)Sauron The King Wrote:
(11-12-2011, 05:20 AM)Your Computer Wrote: In the level editor, what did you specify for the note in the NoteText field under the Entity tab?
The Notetext and name are "Oratory". Left you can see how it shows up ingame. On the right you can see how it looks in level edit. Maybe you can now see what's wrong, at least, I hope you do.


Make sure, you had marked the box in Leveleditor Called : OpenNoteInJournal . or try to rename the: name of note,CustomSubItemTypeName and NoteText to the same name.




Hallucination

Constantine - in Construction
11-12-2011, 12:59 PM
Find Reply
Sauron The King Offline
Junior Member

Posts: 42
Threads: 10
Joined: Oct 2011
Reputation: 0
#8
RE: Text won't show up

(11-12-2011, 12:59 PM)sasukeroxxx Wrote:
(11-12-2011, 10:36 AM)Sauron The King Wrote:
(11-12-2011, 05:20 AM)Your Computer Wrote: In the level editor, what did you specify for the note in the NoteText field under the Entity tab?
The Notetext and name are "Oratory". Left you can see how it shows up ingame. On the right you can see how it looks in level edit. Maybe you can now see what's wrong, at least, I hope you do.


Make sure, you had marked the box in Leveleditor Called : OpenNoteInJournal . or try to rename the: name of note,CustomSubItemTypeName and NoteText to the same name.
Hhhmm... tried it, but it won't work. The "OpenNoteInJournal"-box is marked and I renamed all many times. Could someone send me a working note? Then I can see if that note will work in my map (after adjusting the name of course). If it doesn't, I know that the problem isn't with the note, but with something else...

11-12-2011, 02:02 PM
Find Reply
Statyk Offline
Schrödinger's Mod

Posts: 4,390
Threads: 72
Joined: Sep 2011
Reputation: 241
#9
RE: Text won't show up

you're in Dev_mode, right? make sure your .hps is in the main maps folder along with the map. I don't use dev_mode because it won't do this and doesn't play sounds, even when all in the same folder. Try opening the note WITHOUT being in dev_mode.
11-12-2011, 06:00 PM
Find Reply
Sauron The King Offline
Junior Member

Posts: 42
Threads: 10
Joined: Oct 2011
Reputation: 0
#10
RE: Text won't show up

(11-12-2011, 06:00 PM)Statyk Wrote: you're in Dev_mode, right? make sure your .hps is in the main maps folder along with the map. I don't use dev_mode because it won't do this and doesn't play sounds, even when all in the same folder. Try opening the note WITHOUT being in dev_mode.
I've tried opening it without being in dev_mode, that didn't work.
I've searched for a working note on the forums, I found this one:
<CATEGORY Name="Journal">
<Entry Name="Note_Note01_Name">[insert title here]</Entry>
<Entry Name="Note_Note01_Text">[insert text here]</Entry>
</CATEGORY>
I pasted it in my file and renamed "Note01" to "Oratory". Than I tested it again and it worked. I don't know what was wrong, but it is finally solved now, thanks for helping me Big Grin
Ps, [b]Statyk, [/b]you always are a great help. Each time I ask something, you try to solve my problems. Great to have someone like you Tongue



11-13-2011, 12:02 PM
Find Reply




Users browsing this thread: 1 Guest(s)