Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 4 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lang Editor Tool (V1.1 - Spell Checker Added)
devin413 Offline
Member

Posts: 175
Threads: 7
Joined: Jul 2011
Reputation: 3
#11
RE: New Language Editor Tool (Beta) (Testers Wanted)

lOl so nice Big Grin
thx for that tool dude
will make my life mutch easier to make that trolol notes xD

but I have a question Tongue when i make this see pic


then this just come
<Entry Name="">The door is locked</Entry>
the name missed Tongue


Attached Files
.jpg   Neue Bitmap.jpg (Size: 47.58 KB / Downloads: 185)

Boris Game Studios: Devin413 Moddels Maps Scripts.
Tenebris Lake
Killings In Altstadt

(This post was last modified: 12-31-2011, 05:30 PM by devin413.)
12-31-2011, 05:17 PM
Find Reply
Apjjm Offline
Is easy to say

Posts: 496
Threads: 18
Joined: Apr 2011
Reputation: 52
#12
RE: New Language Editor Tool (Beta) (Testers Wanted)

Could you upload the original language file which this occurs with? Or does it happen to entries you have added?

Quote:As stupid as I sound right now, could you put that in layman's terms? I'm not quite the programmer at the moment >>
If you have something like "hammer & chipper" written, it should be written in the xml as "hammer &amp chipper". The tool didn't do this (though it would load &amp as & correctly).

Edit: NVM found the bug - good find Smile
(This post was last modified: 12-31-2011, 05:50 PM by Apjjm.)
12-31-2011, 05:44 PM
Find Reply
Cryaotic Offline
Senior Member

Posts: 369
Threads: 13
Joined: Oct 2010
Reputation: 72
#13
RE: New Language Editor Tool (Beta) (Testers Wanted)

This is really something, Apjjm!

Going to make things a lot smoother - good work and thank you for the work you put into this. :]

12-31-2011, 06:10 PM
Find Reply
Apjjm Offline
Is easy to say

Posts: 496
Threads: 18
Joined: Apr 2011
Reputation: 52
#14
RE: New Language Editor Tool (Beta) (Testers Wanted)

New beta Smile.
http://www.mediafire.com/?s3xl1vdhifry0xo


Fixed all the bugs mentioned.

Edit 2:
This release has been rushed out a little as I wanted to get it out before I'm out for new year's eve. I had to battle visual studio trying to revert my designer code for no apparent reason so hopefully there aren't any stupid errors. Totally professional Tongue.
(This post was last modified: 12-31-2011, 07:47 PM by Apjjm.)
12-31-2011, 07:39 PM
Find Reply
triadtimes Offline
Senior Member

Posts: 508
Threads: 16
Joined: Jan 2011
Reputation: 21
#15
RE: [V1.1] New Language Editor Tool (Beta) (Testers Wanted)

This looks awesome! However, for some reason I can't right click on the left pane so I can't really see the other options (which I assume are adding categories and such). Do you know what could be causing this?

12-31-2011, 08:00 PM
Find Reply
devin413 Offline
Member

Posts: 175
Threads: 7
Joined: Jul 2011
Reputation: 3
#16
Thumbs Up  RE: [V1.1] New Language Editor Tool (Beta) (Testers Wanted)

thx now it works Big Grin

gonna start work with it now
on my 2nd chapter of
The Forgotten House

Boris Game Studios: Devin413 Moddels Maps Scripts.
Tenebris Lake
Killings In Altstadt

(This post was last modified: 12-31-2011, 08:03 PM by devin413.)
12-31-2011, 08:03 PM
Find Reply
Apjjm Offline
Is easy to say

Posts: 496
Threads: 18
Joined: Apr 2011
Reputation: 52
#17
RE: [V1.1] New Language Editor Tool (Beta) (Testers Wanted)

(12-31-2011, 08:00 PM)triadtimes Wrote: This looks awesome! However, for some reason I can't right click on the left pane so I can't really see the other options (which I assume are adding categories and such). Do you know what could be causing this?
Good spot. Something i forgot to enable when changing around controls. I've uploaded a fixed version:
http://www.mediafire.com/?3dr3z1krs3py128
(This post was last modified: 12-31-2011, 08:08 PM by Apjjm.)
12-31-2011, 08:07 PM
Find Reply
Your Computer Offline
SCAN ME!

Posts: 3,456
Threads: 32
Joined: Jul 2011
Reputation: 235
#18
RE: [V1.1] New Language Editor Tool (Beta) (Testers Wanted)

(12-31-2011, 08:07 PM)Apjjm Wrote: Good spot. Something i forgot to enable when changing around controls. I've uploaded a fixed version:
http://www.mediafire.com/?3dr3z1krs3py128

Well, it works in Linux, somewhat. Does it crash on you when you open a .lang file, click on New and then try to insert a new category? Also, is asking to save upon exiting implemented? I know it's implemented at some point, but it's not asking me to save when i open the program, create a category, and then exit.

Tutorials: From Noob to Pro
12-31-2011, 08:56 PM
Website Find Reply
Apjjm Offline
Is easy to say

Posts: 496
Threads: 18
Joined: Apr 2011
Reputation: 52
#19
RE: [V1.1] New Language Editor Tool (Beta) (Testers Wanted)

(12-31-2011, 08:56 PM)Your Computer Wrote:
(12-31-2011, 08:07 PM)Apjjm Wrote: Good spot. Something i forgot to enable when changing around controls. I've uploaded a fixed version:
http://www.mediafire.com/?3dr3z1krs3py128

Well, it works in Linux, somewhat. Does it crash on you when you open a .lang file, click on New and then try to insert a new category? Also, is asking to save upon exiting implemented? I know it's implemented at some point, but it's not asking me to save when i open the program, create a category, and then exit.
Save dialogue on exit hasn't been implemented yet (it will be in the next version though). I cannot re-produce the crash you speak of on my machine running windows 7 x64. If it happens on Linux I cannot make any guarantees about compatibility as this was programmed using c# and the .net framework (along with a call to user32's sendmessage), and it is possible that the freeze is due to the label-edit stuff in the tree view property and it's behaviour on non-windows platforms? It is possible I am not performing the correct sequence of actions however, or that this bug is to do with the loaded file?
(This post was last modified: 01-01-2012, 04:14 AM by Apjjm.)
01-01-2012, 04:07 AM
Find Reply
Your Computer Offline
SCAN ME!

Posts: 3,456
Threads: 32
Joined: Jul 2011
Reputation: 235
#20
RE: [V1.1] New Language Editor Tool (Beta) (Testers Wanted)

(01-01-2012, 04:07 AM)Apjjm Wrote: I cannot re-produce the crash you speak of on my machine running windows 7 x64. If it happens on Linux I cannot make any guarantees about compatibility as this was programmed using c# and the .net framework (along with a call to user32's sendmessage), and it is possible that the freeze is due to the label-edit stuff in the tree view property and it's behaviour on non-windows platforms? It is possible I am not performing the correct sequence of actions however, or that this bug is to do with the loaded file?

Funny thing, i tried to make the program crash again doing the same process, and it didn't crash. However, after several attempts i got it to crash again. Here's the debug info:

System.ArgumentOutOfRangeException: Value has to be >= 0.
Parameter name: length
  at System.Array.Copy (System.Array sourceArray, Int32 sourceIndex, System.Array destinationArray, Int32 destinationIndex, Int32 length) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.TreeNodeCollection.Insert (Int32 index, System.Windows.Forms.TreeNode node) [0x00000] in <filename unknown>:0
  at LangEditor.DisplayForm.addCategory (System.String defaultName) [0x00000] in <filename unknown>:0
  at LangEditor.DisplayForm.addCategoryToolStripMenuItem_Click (System.Object sender, System.EventArgs e) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.ToolStripItem.OnClick (System.EventArgs e) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.ToolStripMenuItem.OnClick (System.EventArgs e) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.ToolStripMenuItem.HandleClick (Int32 mouse_clicks, System.EventArgs e) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.ToolStripItem.FireEvent (System.EventArgs e, ToolStripItemEventType met) [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.ToolStripItem:FireEvent (System.EventArgs,System.Windows.Forms.ToolStripItemEventType)
  at System.Windows.Forms.ToolStrip.OnMouseUp (System.Windows.Forms.MouseEventArgs mea) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.ToolStripDropDown.OnMouseUp (System.Windows.Forms.MouseEventArgs mea) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.Control.WmLButtonUp (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.ScrollableControl.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.ToolStrip.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.ToolStripDropDown.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
  at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0


Either this is fixable or it's just purely random. If purely random, then the blame can easily be placed on the mono framework.

Tutorials: From Noob to Pro
01-01-2012, 04:53 AM
Website Find Reply




Users browsing this thread: 1 Guest(s)