Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Level Editor Help FATAL ERROR plz help
zombiehacker595 Offline
Member

Posts: 141
Threads: 51
Joined: Mar 2012
Reputation: 3
#1
FATAL ERROR plz help

help my amnesia custom story scripting is not working
this is my script so far
void OnStart()
{
SetEntityPlayerInteractCallback("key_study_1", "ActivateMonster", true);
}
void OnEnter()
{
}
void OnLeave()
{
}
void ActivateMonster(string &in item)
{
SetentityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1". 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2". 0, "Idle");
}
and i get this message
FATAL ERROR could not load script file
custom_stories/test/maps/intro.hps
main 19,60 : ERR: expected identifier
main 20,60 : ERR: expected indentifier
how can i fix this i did it before and it worked than i added level doors or something now its fucked little help plz Smile?
03-28-2012, 03:26 PM
Find Reply
Robby Offline
Posting Freak

Posts: 2,549
Threads: 38
Joined: Jun 2009
Reputation: 47
#2
RE: FATAL ERROR plz help

(03-28-2012, 03:26 PM)zombiehacker595 Wrote: help my amnesia custom story scripting is not working
this is my script so far
void OnStart()
{
SetEntityPlayerInteractCallback("key_study_1", "ActivateMonster", true);
}
void OnEnter()
{
}
void OnLeave()
{
}
void ActivateMonster(string &in item)
{
SetentityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1". 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2". 0, "Idle");
}
and i get this message
FATAL ERROR could not load script file
custom_stories/test/maps/intro.hps
main 19,60 : ERR: expected identifier
main 20,60 : ERR: expected indentifier
how can i fix this i did it before and it worked than i added level doors or something now its fucked little help plz Smile?

There is this part of the script.

SetentityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1". 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2". 0, "Idle");

There are wrong pieces here. It should be like this...

SetEntityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1", 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2", 0, "Idle");

At the AddEnemyPatrolNode, at "PathNodeArea_1" and PathNodeArea_2", you placed ".", which is wrong. Just copy the code I gave you. It should work.

Infrequently active. Don't expect an immediate response. Best to contact me at a different locale. If I create a thread, expect me to be quite active.
03-28-2012, 03:40 PM
Website Find Reply
zombiehacker595 Offline
Member

Posts: 141
Threads: 51
Joined: Mar 2012
Reputation: 3
#3
RE: FATAL ERROR plz help

(03-28-2012, 03:40 PM)Nemet Robert Wrote:
(03-28-2012, 03:26 PM)zombiehacker595 Wrote: help my amnesia custom story scripting is not working
this is my script so far
void OnStart()
{
SetEntityPlayerInteractCallback("key_study_1", "ActivateMonster", true);
}
void OnEnter()
{
}
void OnLeave()
{
}
void ActivateMonster(string &in item)
{
SetentityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1". 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2". 0, "Idle");
}
and i get this message
FATAL ERROR could not load script file
custom_stories/test/maps/intro.hps
main 19,60 : ERR: expected identifier
main 20,60 : ERR: expected indentifier
how can i fix this i did it before and it worked than i added level doors or something now its fucked little help plz Smile?

There is this part of the script.

SetentityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1". 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2". 0, "Idle");

There are wrong pieces here. It should be like this...

SetEntityActive("servant_grunt_1", true);
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_1", 0, "Idle");
AddEnemyPatrolNode("servant_grunt_1", "PathNodeArea_2", 0, "Idle");

At the AddEnemyPatrolNode, at "PathNodeArea_1" and PathNodeArea_2", you placed ".", which is wrong. Just copy the code I gave you. It should work.
thank you so much i was actually going spaztic but i cant beleive i missed that dot thanks dude Smile
03-29-2012, 06:40 AM
Find Reply




Users browsing this thread: 1 Guest(s)