Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Possible new idea to fix audio problems
GFree Offline
Junior Member

Posts: 44
Threads: 5
Joined: Mar 2007
Reputation: 0
Solved: 2 Years, 3 Months, 2 Weeks ago Possible new idea to fix audio problems

Recently I tried playing Penumbra on my Ubuntu Gutsy 64-bit setup, but it had some rather large problems with crackly/popping sound. The last time I tried playing Penumbra was with a Feisty 32-bit setup, so I tried the regular fix of editing /etc/openalrc and instead of

(define devices '(alsa))
(define alsa-out-device "default")

I switched the lines to show

(define devices '(oss))
(define alsa-out-device "default")

This removed some of the problems, but I still got a ton of crackly in the initial cabin area, plus every few seconds I'd get a burst of really crackly sound. I experimented with the replacement OpenAL lib in the stickied thread, but it didn't help (only made things worse actually). The idea of replacing alsa with oss normally helps in OpenAL games, but I've actually found an even BETTER quality solution, which I want to share.

Try this: edit your /etc/openalrc file and leave it using alsa, but remove the second line in the file. When done, your /etc/openalrc should look like this:

(define devices '(alsa))

When I did this, this not only removed most of the crackling in Penumbra but reduced the sound problems to very slight and occasional pops in a few places. It's not perfect, but still light years ahead of previous results I had. I'm not sure why the second line causes the problem it does, but removing it helped a lot. Other games which had crackly sound like OpenArena also benefited.

Two things to mention though:

(1) If you edit the /etc/openalrc, you need to do so as root. If you've got files called .openalrc or .asoundrc in your home directory, delete them otherwise they'll override. If you want, you can make the changes just in .openalrc instead of having to sudo to edit /etc/openalrc.

(2) Urkle's replacement OpenAL lib does NOT work if you try this. It seems to only work if you've changed the devices line to oss, so if you stick with ALSA, it will crash. I never had much luck with it anyway.
(This post was last modified: 12-22-2007, 02:38 AM by thechef.)
12-22-2007, 12:41 AM

Users browsing this thread: 1 Guest(s)